Force 422 video output


#1

Hi!

Sometimes when playing HDR UHD content Vero plays it using 444 10 bit instead of 422 and I get an Image with sparklies/ snow. Can I force 422 10 bit?

Thanks!


#2

I’ve been wondering this, too. Prior to the October release you could force 422 by doing something like
echo "422,10bit" | sudo tee /sys/class/amhdmitx/amhdmitx0/attr
but that doesn’t seem to work any more - it picks up on the bit depth, but it always outputs 444 regardless.


#3

In my TV it seems that 4:4:4 content doesn’t work. The sound works properly but I can only see a black screen so I wonder about it too.
I don’t know if it’s the TV or the Pi2 fault though.


#4

Try

echo "422,10bitnow" | sudo tee /sys/class/amhdmitx/amhdmitx0/attr


#5

That still gives me 444.


#6

I solved it connecting the Vero to one of the non HDCP 2.2 compliant HDMI inputs of my AV Receiver. Now I get 4Kn422 8bit without image notes. Wish I could get 4K 422 10 bit but will wait until it is menu selectable…

Regards


#7

Sparklies/snow on an HDMI signal is usually an indication that the bandwidth is too high for the cable in use. 444 10 bit may require a higher bandwidth than the cable is capable of, especially if it’s a long cable. Trying a different cable may help.


#8

Tried different cables from Vero to AV. Now I will try the same from AV to TV… will let you know what I get by doing so…

Thanks!


#9

Update!

Changed both HDMI cables in my chain (good quality ones, I thought): Vero 4K to AV and AV to TV set. Using the much cheaper Amazon Basics ones and… voilà, it works!
Now I get perfect quality 4K HDR 444 10bit video, no video noise whatsoever. So glad with my Vero 4K +

Thanks a lot to you all for your valuable help.


#10

I’m glad to hear this.

Sam


#11

I’m sorry to dredge this up again, but my system is definitely a little more comfortable with 422 10-bit colour than it is with 444 10-bit. It used to be the case that you could do something like
echo "422,10bitnow" | sudo tee /sys/class/amhdmitx/amhdmitx0/attr
and it would force 422; but since the October update, that no longer works. (You can still control the bit depth that way, but it remains stuck on 444 no matter what you specify).

Other than rolling back all the October video improvements, is there any way around that?


#12

The latest testing kernel (130) should let you do that again. It doesn’t work at 4k60Hz though without a fix in Kodi which is about to be released.


#13

I suppose I’d better wait for the Kodi fix.

Thanks. :slight_smile: