Force HDMI, Disable DSI not working since update

Hi all,
I’m running osmc on a raspberry 3b+. There is a 7" DSI screen attached to it but in this particular setup i am not using it (only using HDMI). Everything was running great until the last update. Since then I can"t have HDMI used as the main display. At boot i get the rainbow screen on both screens, then the DSI becomes the main one. I checked the config.txt and display_default_lcd=0 is still there but it seems not to be taken into account since the update. I also tried to add a combination of hdmi_force_hotplug=1 and hdmi_safe=1 but it always stays on the DSI screen, no output on the HDMI except from the rainbow splash screen (disable_splash was commented a long time ago).
Any clue ? it is quite tricky to unmount the screen so i was hoping there was a way to get display_default_lcd=0 option working again before I physically dismantle the DSI screen.

Thanks !
Operating System 2020.03-01 (kernel: Linux 4.19.55-6-osmc)

Did you try using ignore_lcd=1

That was it !!
Thanks !!

1 Like