Forced subs not displayed on Vero V

Hello OSMC team,

Since Kodi 20.2, the forced subtitles of my MKVs are no longer displayed automatically.

In Kodi, the subtitle setting is set to forced under Settings/Player/Language.

Could you take a look here to see if it’s a bug that can be fixed?

Kodi Version 20.2 - Skin Aeon Nox Silvo (Vero V).

Greetings from Germany


1 Like

There have been some updates to sub selection behavior which may make some settings configurations work differently than they did in the past so this is probably a matter of tweaking your settings. Please find a file that you believe should work but doesn’t and provide mediainfo for the video that shows the details of the languages as well as a link to a log you upload that contains your guisettings.xml.

You may also want to search this forum a little bit as well. It hasn’t been very long since this topic was last covered.

I have the same setting in Kodi, all my mkv’s with forced subs have the track tagged as Forced using the mkvtoolnix header editor, and everything is working fine for me with the current release of OSMC, so perhaps a settings/tagging issue?