Frameskipping in some 4K files

Sure, here goes:

Adjust display refresh rate : on start/stop
Sync playback to display: off
Minimize black bars : off
Display 4:3 : Normal
Enable Hq scaling above 20%
Allow hw acceleration - amcodec: on
Accelerate mpeg2: always
Accelerate mpeg4: hd and up
Accelerate h264: always

Resolution 1920x1080p
Refresh rate: 60
Black other displays: off
Delay after refresh rate: off
Number of buffers used by gfx driver: 3

and audio settings i.e passthrough?

Audio settings:

Output device : Aml-m8audio, hdmi
Number of channelse: 5.1
Output config: Optimized
Volume control steps: 90
Maintain org. Volume: Yes
Stereo upmix: Off
Boost center channel: 0db
Resample quality: Medium
Threshold for pitch correction: 2
Keep audio alive: off
Allow passthrough: on
Dolby digital ac3 capable: yes
Dolby digital eac3 capable: yes
Dts capable: yes
TrueHD capable: no
Dts-hd capable: no
Enable dsp processing: off

Just for testing, try with pass-through disabled

Pass-through disabled: Same result.


Unfortunately I’ve not got 4k tv at the mo to test (V4k is a future investment), or I would ask for a sample clip. Have you got any other 4k clips, which are of a different container or codec, to test further? As it may it well be a codec or container issue.

Thanks Tom.

Ok. I’ll try out some clips from the link that @Mobula so kindly provided.

So I tried five different 4K clips and they all play perfectly.

Some of the clips have almost identical mediainfos when compared to my stuttering files, but there’s a difference in “Format settings, ReFrames”, which is 5 in my files and the highest among all the clips.

I have no idea what that setting means.

I still think the problem is Kodi though. Something definitely goes wrong when “Adjust display refresh rate” is enabled on these files.


This could be an issue with the auto adjust rate, but if the clips you’ve tested all played perfectly and some had almost identical mediainfos; I’d be more inclined to suspect the issue lays else where.

I would try as Sam suggested and try remuxing the videos, which present the issue.

Thanks Tom.

I tried that yesterday. Didn’t work. Thanks though.


Could you provide logs showing the issue with the redux file? The Comparison may shed more light.

Thanks Tom.

I think the issue here might be the
“Format profile : High@L5.1”

I have the same issue only with 4K clips
with same media info mentioned here:
4K media encoded with H.264, Level 5.1 profile

This could be a limitation of the VERO H/W
if someone could confirm it ? Sam ?

If this is true the solution is re-encode file
to a L4.1 profile, or even re-encode using H.265 instead of H.264
using an app like handbrake
(did it and plays fine, you save some space also, but the process is time consuming)

If I remember correctly, the Vero 4K is powered by an Amlogic 905X cpu which should be able to decode h264 5.1 up to 30fps in 4K:

H.264 AVC HP@L5.1 up to 4Kx2K@30fps, H.264 MVC up to 1080p @60fps

It’s obvious that H265 is the preferred codec for 4K and the specs are better:

H.265 HEVC MP-10@L5.1 up to 4Kx2K@60fps

Log from original:
Log from redux:

Redux file has the same issue, I see no difference. Stuttering when “Adjust display refresh rate” is enabled. Smooth when disabled.


thanks if I see anything of note, I’ll report back.

regards tom.

1 Like

I sincerely do not hope you’ve given up on this.
Please let me know if I can provide you with more information or try other things.

These files are playing without a hitch on a Minix 8x-h plus.


I’ve not given up, I hadn’t found anything in the logs, to report back; but still trying to work out of what the issue could be.

Have you tried a different HDMI cable?

Thanks Tom.

Thanks Tom. I appreciate your effort. :slight_smile: I have my faith in the Vero 4K! It’s a slick little machine, and I hope this issue will help making compatibility even better.

This evening I tried connecting to an older 1080p tv with the supplied HDMI cable.

Same result!

Would a sample clip help? The issue is the same on a 1080p screen.

Ok, when you’ve uploaded I’ll see if I can reproduce.

Also a photo of your video & audio settings in export mode, may help.

Thanks Tom.