Frameskipping in the most 1080p files


#98

Hey Sam,

Thanks for your long reply! I have been waiting for that… :grin:
Understood about the frame rate now. And after some more watching I can confirm that it’s just a coincidence. Many of the frame skips happen without the “framerate” shown in the debug overlay dropping significantly.

But interestingly enough, the skips seems to happen at the same places of the my test video. Not in the same amount every time, but at the same passages of the file (mostly when there’s a lot of movement in the picture - panning or moving objects/people). Although that might suggest it being a flawed file at first sight, it can’t explain why it happens with every 23.976fps file at some point. Just watched a full movie and it happened every now and then with that file, too…

As I said somewhere in the thread, I first thought, the issue might have shown up first with the April update, but I’m not so sure about the timeline. At the beginning, I didn’t look for the issue too closely thinking that it might be a flawed file. But it kept on appearing. So, honestly, I can’t say. Sorry! I ordered my Vero 4k just before the April update and updated right after the device arrived. The April update as the start of the issue can’t be correct that means.
Correcting my first thought, I’d say: it was always there, but I didn’t notice it as a major issue at first…

Here are the photos of my audio settings (for my test attempt connecting the Vero directly to the TV, I just changed the output device to PCM, the number of channels to 2.0 and the passthrough to disabled; all other settings have always been this way):



If it’s just a setting that causes the problem, I’d be more than delighted obviously! :see_no_evil: :joy:

Cheers!


#99

Hi Sam!

Here are my audio options - picture one shows the video options, because one question: is it normal that the displaymode is “windowsmode” and not fullscreen?

In my case the problem occurs after a while of watching, not at the beginning! I saw some movies and episodes and the frame skips comes so after 15 minutes and later and the problems doesn´t occurs always at the same timestamp - i´m playing the testfile (a 70 minutes episode of “The Strain”) very often and sometimes it comes after 15 minutes, sometimes after 50 minutes… but it´s occurs not only on this episode - all of the affected files are untouched bluray rips made with makemkv. I´ve test all of them with my Q10 Pro and Q5 Pro without these problems with the same equipment, network cable, hdmi cable and have no problems… so i´m very confused WHAT is wrong…

Regards!
Michael


#100

Hi @Tom_Doyle and @sam_nazarko … my second ordered Vero 4K arrived me today… It has been the March Software installed. So i change the Veros and play the testfile (The Strain Season 1, Episode 1) with the new one (no addon is installed, no emby, nothing but the preinsalled software)… same issue…frame Skips… can´t belive that! So i do some more tests:

  1. the second Vero in my bedroom connected with my second Samsung TV without a A/V Receiver playing the testfile… issue occurs
  2. the second Vero on my A/V Receiver playing the testfile from a usb stick without network… issue occurs

https://paste.osmc.tv/avezagekan

  1. the first Vero connected with my A/V Receiver playing another testfile (The Strain Season 1, Episode 2) … issue occurs
  2. the first Vero connected with my A/V Receiver playing the testfile (The Strain Season 1, Episode 1) converted from mkv to m2ts… issue occurs

Frame skips occurs not on all movies or episodes and not at the same timestamp when i play the testfile again… test with two Episodes Game of Throne and no Frame Skips are visible… i´m totally confused about that…

Here are the Media Infos from two of the affected files:

General
Unique ID : 202253232330666543313884296559645298230 (0x98288E3F0B3E928DE04D27E7F2660E36)
Complete name : V:–=Serien=–\The Strain\Season 01\The Strain - S01E01 - Flug 753.mkv
Format : Matroska
Format version : Version 2
File size : 10.7 GiB
Duration : 1h 11mn
Overall bit rate mode : Variable
Overall bit rate : 21.3 Mbps
Movie name : The Strain, Season 1 Disc 1
Encoded date : UTC 2015-12-09 06:34:59
Writing application : MakeMKV v1.9.7 win(x64-release)
Writing library : libmakemkv v1.9.7 (1.3.0/1.4.1) win(x64-release)

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 1h 11mn
Bit rate mode : Variable
Bit rate : 20.1 Mbps
Maximum bit rate : 37.0 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.404
Stream size : 10.1 GiB (94%)
Language : English
Default : No
Forced : No

Audio
ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Mode : 16
Format settings, Endianness : Big
Codec ID : A_DTS
Duration : 1h 11mn
Bit rate mode : Constant
Bit rate : 768 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Frame rate : 93.750 fps (512 spf)
Bit depth : 24 bits
Compression mode : Lossy
Stream size : 394 MiB (4%)
Title : Surround 5.1
Language : German
Default : Yes
Forced : No

Text #1
ID : 3
Format : PGS
Codec ID : S_HDMV/PGS
Codec ID/Info : Picture based subtitle format used on BDs/HD-DVDs
Language : German
Default : Yes
Forced : No

Text #2
ID : 4
Format : PGS
Codec ID : S_HDMV/PGS
Codec ID/Info : Picture based subtitle format used on BDs/HD-DVDs
Language : German
Default : No
Forced : No

Menu
00:00:00.000 : de:Chapter 01
00:06:52.620 : de:Chapter 02
00:11:50.376 : de:Chapter 03
00:14:51.473 : de:Chapter 04
00:20:36.902 : de:Chapter 05
00:28:37.048 : de:Chapter 06
00:32:29.739 : de:Chapter 07
00:36:58.966 : de:Chapter 08
00:41:57.014 : de:Chapter 09
00:45:26.056 : de:Chapter 10
00:47:07.658 : de:Chapter 11
00:49:37.391 : de:Chapter 12
00:53:10.187 : de:Chapter 13
00:56:50.532 : de:Chapter 14
01:00:19.407 : de:Chapter 15
01:03:43.778 : de:Chapter 16


Here from another affected file (The Island, one of the last reencodes i have):

General
Unique ID : 238591291223495294165782473715419393264 (0xB37F02DF8F04A73A8B66AD8083DB2CF0)
Complete name : V:–=Filme=–\Die Insel (2005) tt0399201 bluray\Die Insel (2005) tt0399201 bluray.mkv
Format : Matroska
Format version : Version 2
File size : 14.9 GiB
Duration : 2h 15mn
Overall bit rate : 15.7 Mbps
Encoded date : UTC 2010-07-17 13:57:21
Writing application : mkvmerge v3.3.0 (‘Language’) gebaut am May 14 2010 17:11:50
Writing library : libebml v0.8.0 + libmatroska v0.9.0

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 2h 15mn
Bit rate : 15.0 Mbps
Width : 1 920 pixels
Height : 800 pixels
Display aspect ratio : 2.40:1
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.408
Stream size : 14.0 GiB (94%)
Writing library : x264 core 67 r1148M 400740b
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=9 / psy_rd=1.0:0.0 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=12 / nr=0 / decimate=1 / mbaff=0 / bframes=4 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=3 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=15032 / ratetol=1.0 / qcomp=0.50 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.10 / pb_ratio=1.10 / aq=1:1.00
Default : Yes
Forced : No

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Format settings, Endianness : Big
Codec ID : A_AC3
Duration : 2h 15mn
Bit rate mode : Constant
Bit rate : 640 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Frame rate : 31.250 fps (1536 spf)
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 623 MiB (4%)
Title : ger
Language : German
Service kind : Complete Main
Default : Yes
Forced : No

What i can say:

  1. it´s not my network or Synology NAS because it occurs also on USB HD
  2. It´s not the April Software because with the March Version it occurs also
  3. the first Vero is not faulty because the second on has the same problem
  4. it´s not my A/V Receiver because in my bedroom the Vero directly connected th the Samsung TV has the same problem
  5. it´s not a problem with the testfiles because my Q10 Pro plays it without any Frame Skipping

So i do a last test:

the first Vero connected with my A/V Receiver playing the testfile (The Strain Season 1, Episode 1) --> in the Kodi playback settings adjust display refresh rate set from “at start/stop” to "off"so the testfile plays with 60 fps… and NO Frame Skipping occurs (only 7 to the beginning and when i´m press the Info Button)… wtf… !?

Change the adjust display refresh rate back to “at start/stop” and play another testfile… 95 Frame Skips in the first 16 minutes, stop playback

Change the adjust display refresh rate again to “off” and play the same testfile again… after 25 minutes NO Frame Skips…so i think at the moment that the problem is located…

@Chillbo… can you test it to confirm?

Any idea what´s the reason is for that and what to do to fix it? Playing all Media with 60fps isn´t a real solution…

Regards!
Michael


#101

Well, I did a test with framerate adjustment set to off, but I had the Vero set to 1080p24. There were a lot of skips (see post #43).

As requested by @MikeDelta, doing a test at 1080p60 now with framerate adjustment set to off… Starting off without any skips, no skips added when skipping forward a few minutes in the file - everything looks very smooth! Except the 3:2 pull down stutter of course. :joy:
The critical scenes of the file don’t show any skipping now. I don’t have time for a full length test today, but it looks very promising.

Will do another full test with log tomorrow. But I’d say that we’re getting closer to the problem. It seems to be a problem of the Vero 4k with 24p (or 23.976p) files. I shall do a test with 50p tomorrow, too. To me, it starts to point towards a 24p problem here… Hope, that could be fixed! As it is a main selling point over other Kodi boxes which are mostly not capable of that properly - and the main selling point for me besides HD audio passthrough.


#102

That’s good to hear that this is consistent, as it makes things easier for us to investigate and easier for you to confirm when things are resolved.

It would be good if you could test the March version from osmc.tv/download for a day or so and note if you get problems with this version.

If you are using HDMI, you should set Audio out to HDMI, not PCM or you may experience stutters.
I’d also recommend changing audio configuration to Fixed.

If I understand correctly, @Chillbo also finds this to be the same.

Thanks for confirming issues with the March version.

This shouldn’t be the problem. Most content is 23.976 and I personally watch content regularly with Adjust Refresh Rate without issue. If there was a problem with framerate automation, I’d expect you to see skips constantly. Forgive me if this is wrong (I’ve had a lot of posts to read this week), but you both experience issues only after a period of viewing, right?

We had some issues with 23.976Hz on Vero 2, but we fixed them. Some of the users that reported this upgraded to Vero 4K, and some of these users have a very keen eye for microstutters, so even larger skips would cause the forum to be quite vocal.

Can you run:

cat /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap
cat /sys/devices/virtual/amhdmitx/amhdmitx0/rawedid

So I can see your TV / AVR’s capabilities?

Also want to know if the 23.976 framerate automation is kicking in. dmesg | grep framerate should show that.

With the new video improvements in the pipeline, it’s possible to configure framerate automation via sysfs; which means that:

  • We will be able to guarantee it is working
  • We will be able to override some TV advertised capabilities. For example. some receivers do not fully advertise the supported video modes correctly.

Are you guys both using MakeMKV to rip content? Have you tried any other content?

I’m confident we can fix this – I just need to work out why you guys are having issues and most others are not, and in turn, what’s unique here.

Sam


#103

Hi Sam!

Thanks for your words… i´m very confused and disappointed… not on the vero, i like the box, but on the situation what the fu… problem is…

First, in another thread you wrote this…

What does it mean? My first Vero is connected over hdmi with an Marantz NR1607 7.2 - but the second Vero with the same issue in my bedroom not, this box is connected directly to the tv over hdmi.

Ok, done!

Yes, but this is changing randomly i play the file again… sometimes after 15 minutes, sometimes after 30, and so on…

the same problem is reported with 4k files, so i think this isn´t exclusive for us… when i understand it right in the other case the only thing helps is to set adjust display refresh rate to “off also” … so i think the source of the problem is the same…

https://discourse.osmc.tv/t/frameskipping-in-some-4k-files/

After starting the testfile and type in the command i geht this output:

Yes, but the same problem appears with reencoded content… in post 98 i paste 2 media info files, the first is from my untouched testfile made with makemkv and the second is from a reencoded source…

So i´m hope the problem can be solved shortly, which the setting display refresh rate set to “off” the frame skipping problem is passed but playing all content with 60fps is a bad experience, so i have to use my Q10 at this time…


#104

I also have tried to follow this problem. An interesting test would be to check if frameskips occour, when hardware acceleration is off…

The ghosting problem in other threads seems to base on Hardware acceleration on, so it could be the same source of problem.


#105

Can I do that without losing anything or should I look to make a backup first? (and if yes, how?)

Yes, that’s correct. It never happened before 15-20mins of playback before. Except, of course, the few skips/drops at the very beginning of playback when the framerate is adjusted.

So, result from the first command:

osmc@osmc:~$ cat /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap
480i60hz
480p60hz
480p_rpt
576i50hz
576p50hz
576p_rpt
720p60hz
1080i60hz
1080p60hz*
720p50hz
1080i50hz
1080p50hz
1080p24hz
osmc@osmc:~$ cat /sys/devices/virtual/amhdmitx/amhdmitx0/rawedid
00ffffffffffff0011ee4e0001010101001a0103800000780adaffa3584aa22917494b00000001010101010101010101010101010101023a80d072382d40102c4580ba882100001e023a801871382d40582c4500ba882100001e000000fc0044454e4f4e2d41565248440a20000000fd00173d0f440f000a20202020202001de02035e72589f9014052013041203110216071506010e230f241d251e26380f7f071507503d1ec04d02005706015f7e03677e015f7e01835f00007f030c002500b8262fc0150141007c061608001800767800868800969800a6b6e3051f01011d80d0721c1620102c2580ba882100009e00000000000000000000000000000051

And from the second when playing the video file:

osmc@osmc:~$ dmesg | grep framerate
[25845.902253] tv_vout: vout [framerate_automation_process] duration = 3840
[25845.902256] tv_vout: framerate_automation_process[1111] fps_playing_flag = 0
[109775.398436] tv_vout: vout [framerate_automation_process] duration = 4004
[109775.398443] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[109775.398464] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[109995.497235] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[109995.553290] tv_vout: vout [framerate_automation_process] duration = 4004
[109995.553292] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[109995.553303] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110001.818843] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110001.887282] tv_vout: vout [framerate_automation_process] duration = 4004
[110001.887287] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[110001.887309] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110477.032437] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110477.087969] tv_vout: vout [framerate_automation_process] duration = 4004
[110477.087971] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[110477.087982] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110479.440107] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110479.502055] tv_vout: vout [framerate_automation_process] duration = 4004
[110479.502061] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[110479.502082] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110481.842937] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110481.911361] tv_vout: vout [framerate_automation_process] duration = 4004
[110481.911365] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[110481.911382] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110624.245641] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[146458.606055] tv_vout: vout [framerate_automation_process] duration = 4004
[146458.606058] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[146458.606069] tv_vout: vout [framerate_automation_set_mode] mode_target = 16

Yep, I normally do have it set to HDMI. But setting it to fixed wouldn’t really make me happy… I actually want the Vero 4k to deliver the actual properties of the audio streams to my AVR. So, if it’s 24bit 48kHz Stereo, it should send that to the AVR (that’s also why I was asking about the 192kHz 24bit capabilities before :wink:).

I have tried all kinds of content without any links between these files…

That cannot be affecting us. I also tried mine without the AVR, so there can’t be a link (and I’m not using a Marantz, but a Denon - same company, but not same AVRs).

@sam_nazarko Should I still do another test with fixed framerate to 50/60fps? And is @MoD256’s idea worth a shot?


#106

With Hardware acceleration off it´s a little better, 39 frame skips in the 70 minutes testfile… not good enough to use it…


#107

@sam_nazarko… i do some more tests… unfortenately i have other results then yesterday… set adjust display refresh rate to “off” and test again with 50 & 60fps and have many frame skips at the beginning with the same files i´ve tested yesterday without problems… also noticed that the vero is VERY hot. Must rechange the Audio setting “fixed” to “best match” because my A/V Receiver don´t switch to the correct audio format, e.g. from dd to dts when i play first a file with dd and then another with dts… i have absolut no idea was is wrong, have such problems to the first time and give up at this point… so i hope you find the trick that i can use the both boxes… :worried:


#108

How could I test/see if frameskips occur to me?

I think not, but eventually I’m a little less sensitiv for frameskips.

How can I count my frameskips (if there should be some)?

I think it could be interesting to know wether it are individual cases or is it an general problem (for all), but not everybody can register/feel the problems. So I would check this (for myself) if I knew the procedure of checking/logging frameskips.

@MikeDelta Don’t forget to activate Hardware Acceleration again. Acceleration off would be an explanation for a more hot Vero4k


#109

@MoD256… Frame skipping is like when the picture is jumping - some frames missing and it’s stuttering… can’t say it better, my english isn’t perfect… with a Remote Keyboard you can track the skippings, press “o” when the Movie is playing!

Thanks for the hint about the Hardware acceleration, forgot to turn it on again…


#110

So after turn on the Hardware acceleration and with normal temperature the Vero plays the testfiles with display refresh rate “off” without frame skippings same as friday… so i think my tests from yesterday with Hardwareacceleration off and the temperature problem are not valid…it looks like that the core of the frame skippiing problem is something with the framerate switching…


#111

Well, it does only give problems when, during framerate switching turned off, the framerate is fixed to 24p. When set to 50p (did test that now, too) or 60p, there’s no skipping. I could test some DVDs with 25fps and 30fps played respectively at 50fps and 60fps with framerate switching turned on. I have the strong feeling that there are no problems at 50fps and 60fps no matter whether it is by a fixed framerate or by switching to that framerate because it is the source’s framerate…

That is, @sam_nazarko, why I said, it looks like a 24p problem to me. Not in general, maybe, but some settings or anything specific to @MikeDelta’s and my Vero 4k is causing this only at 24p with framerate switching turned on or off (see post #43).
Or did you, @MikeDelta, get skipping with 50p or 60p source material and framerate switching turned on?


#112

No, problem occurs only with 24p source material!


#113

Next question would be: only 23.976fps material or also true 24fps material? I think, I only tested 23.976 files so far…


#114

23.976fps material… i don´t have true 24fps media i think…


#115

Well, I’ll look what I can find… But @sam_nazarko, can you give us any news on what you think about our findings and what else we can provide to make a fix possible very soon? Or do you maybe already have an idea what’s going on with our Veros?


#116

Unfortunately I don’t really have any further ideas, other than saying there is some local issue at play here. I think we might be barking up the wrong tree with some of the suggestions being made in this thread.

There’s no correlation that would suggest this is the case.

If you have some ideas as to why I can investigate, but I can’t see how disabling HW accel will improve things for these users.

You can backup and restore in My OSMC

I understand that. I was however asking if you could make that change temporarily to investigate further.

I personally don’t think the issue is related to HW accel or 50/60 content.

The most important thing right now would be to know whether this was a problem on older versions (March for example) version of OSMC.

Sam


#117

Ok, I’ll see when I can do the roll back to the March version and test then…
Also, I’ll check out the audio setting. Sry, did understand that as a general suggestion :wink:

But still isn’t it very strange that only 24p content shows skipping?