Frameskipping in the most 1080p files


#103

Hi Sam!

Thanks for your words… i´m very confused and disappointed… not on the vero, i like the box, but on the situation what the fu… problem is…

First, in another thread you wrote this…

What does it mean? My first Vero is connected over hdmi with an Marantz NR1607 7.2 - but the second Vero with the same issue in my bedroom not, this box is connected directly to the tv over hdmi.

Ok, done!

Yes, but this is changing randomly i play the file again… sometimes after 15 minutes, sometimes after 30, and so on…

the same problem is reported with 4k files, so i think this isn´t exclusive for us… when i understand it right in the other case the only thing helps is to set adjust display refresh rate to “off also” … so i think the source of the problem is the same…

https://discourse.osmc.tv/t/frameskipping-in-some-4k-files/?source_topic_id=37277

After starting the testfile and type in the command i geht this output:

Yes, but the same problem appears with reencoded content… in post 98 i paste 2 media info files, the first is from my untouched testfile made with makemkv and the second is from a reencoded source…

So i´m hope the problem can be solved shortly, which the setting display refresh rate set to “off” the frame skipping problem is passed but playing all content with 60fps is a bad experience, so i have to use my Q10 at this time…


#104

I also have tried to follow this problem. An interesting test would be to check if frameskips occour, when hardware acceleration is off…

The ghosting problem in other threads seems to base on Hardware acceleration on, so it could be the same source of problem.


#105

Can I do that without losing anything or should I look to make a backup first? (and if yes, how?)

Yes, that’s correct. It never happened before 15-20mins of playback before. Except, of course, the few skips/drops at the very beginning of playback when the framerate is adjusted.

So, result from the first command:

osmc@osmc:~$ cat /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap
480i60hz
480p60hz
480p_rpt
576i50hz
576p50hz
576p_rpt
720p60hz
1080i60hz
1080p60hz*
720p50hz
1080i50hz
1080p50hz
1080p24hz
osmc@osmc:~$ cat /sys/devices/virtual/amhdmitx/amhdmitx0/rawedid
00ffffffffffff0011ee4e0001010101001a0103800000780adaffa3584aa22917494b00000001010101010101010101010101010101023a80d072382d40102c4580ba882100001e023a801871382d40582c4500ba882100001e000000fc0044454e4f4e2d41565248440a20000000fd00173d0f440f000a20202020202001de02035e72589f9014052013041203110216071506010e230f241d251e26380f7f071507503d1ec04d02005706015f7e03677e015f7e01835f00007f030c002500b8262fc0150141007c061608001800767800868800969800a6b6e3051f01011d80d0721c1620102c2580ba882100009e00000000000000000000000000000051

And from the second when playing the video file:

osmc@osmc:~$ dmesg | grep framerate
[25845.902253] tv_vout: vout [framerate_automation_process] duration = 3840
[25845.902256] tv_vout: framerate_automation_process[1111] fps_playing_flag = 0
[109775.398436] tv_vout: vout [framerate_automation_process] duration = 4004
[109775.398443] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[109775.398464] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[109995.497235] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[109995.553290] tv_vout: vout [framerate_automation_process] duration = 4004
[109995.553292] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[109995.553303] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110001.818843] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110001.887282] tv_vout: vout [framerate_automation_process] duration = 4004
[110001.887287] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[110001.887309] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110477.032437] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110477.087969] tv_vout: vout [framerate_automation_process] duration = 4004
[110477.087971] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[110477.087982] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110479.440107] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110479.502055] tv_vout: vout [framerate_automation_process] duration = 4004
[110479.502061] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[110479.502082] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110481.842937] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110481.911361] tv_vout: vout [framerate_automation_process] duration = 4004
[110481.911365] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[110481.911382] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[110624.245641] tv_vout: vout [framerate_automation_set_mode] mode_target = 16
[146458.606055] tv_vout: vout [framerate_automation_process] duration = 4004
[146458.606058] tv_vout: framerate_automation_process[1111] fps_playing_flag = 1
[146458.606069] tv_vout: vout [framerate_automation_set_mode] mode_target = 16

Yep, I normally do have it set to HDMI. But setting it to fixed wouldn’t really make me happy… I actually want the Vero 4k to deliver the actual properties of the audio streams to my AVR. So, if it’s 24bit 48kHz Stereo, it should send that to the AVR (that’s also why I was asking about the 192kHz 24bit capabilities before :wink:).

I have tried all kinds of content without any links between these files…

That cannot be affecting us. I also tried mine without the AVR, so there can’t be a link (and I’m not using a Marantz, but a Denon - same company, but not same AVRs).

@sam_nazarko Should I still do another test with fixed framerate to 50/60fps? And is @MoD256’s idea worth a shot?


#106

With Hardware acceleration off it´s a little better, 39 frame skips in the 70 minutes testfile… not good enough to use it…


#107

@sam_nazarko… i do some more tests… unfortenately i have other results then yesterday… set adjust display refresh rate to “off” and test again with 50 & 60fps and have many frame skips at the beginning with the same files i´ve tested yesterday without problems… also noticed that the vero is VERY hot. Must rechange the Audio setting “fixed” to “best match” because my A/V Receiver don´t switch to the correct audio format, e.g. from dd to dts when i play first a file with dd and then another with dts… i have absolut no idea was is wrong, have such problems to the first time and give up at this point… so i hope you find the trick that i can use the both boxes… :worried:


#108

How could I test/see if frameskips occur to me?

I think not, but eventually I’m a little less sensitiv for frameskips.

How can I count my frameskips (if there should be some)?

I think it could be interesting to know wether it are individual cases or is it an general problem (for all), but not everybody can register/feel the problems. So I would check this (for myself) if I knew the procedure of checking/logging frameskips.

@MikeDelta Don’t forget to activate Hardware Acceleration again. Acceleration off would be an explanation for a more hot Vero4k


#109

@MoD256… Frame skipping is like when the picture is jumping - some frames missing and it’s stuttering… can’t say it better, my english isn’t perfect… with a Remote Keyboard you can track the skippings, press “o” when the Movie is playing!

Thanks for the hint about the Hardware acceleration, forgot to turn it on again…


#110

So after turn on the Hardware acceleration and with normal temperature the Vero plays the testfiles with display refresh rate “off” without frame skippings same as friday… so i think my tests from yesterday with Hardwareacceleration off and the temperature problem are not valid…it looks like that the core of the frame skippiing problem is something with the framerate switching…


#111

Well, it does only give problems when, during framerate switching turned off, the framerate is fixed to 24p. When set to 50p (did test that now, too) or 60p, there’s no skipping. I could test some DVDs with 25fps and 30fps played respectively at 50fps and 60fps with framerate switching turned on. I have the strong feeling that there are no problems at 50fps and 60fps no matter whether it is by a fixed framerate or by switching to that framerate because it is the source’s framerate…

That is, @sam_nazarko, why I said, it looks like a 24p problem to me. Not in general, maybe, but some settings or anything specific to @MikeDelta’s and my Vero 4k is causing this only at 24p with framerate switching turned on or off (see post #43).
Or did you, @MikeDelta, get skipping with 50p or 60p source material and framerate switching turned on?


#112

No, problem occurs only with 24p source material!


#113

Next question would be: only 23.976fps material or also true 24fps material? I think, I only tested 23.976 files so far…


#114

23.976fps material… i don´t have true 24fps media i think…


#115

Well, I’ll look what I can find… But @sam_nazarko, can you give us any news on what you think about our findings and what else we can provide to make a fix possible very soon? Or do you maybe already have an idea what’s going on with our Veros?


#116

Unfortunately I don’t really have any further ideas, other than saying there is some local issue at play here. I think we might be barking up the wrong tree with some of the suggestions being made in this thread.

There’s no correlation that would suggest this is the case.

If you have some ideas as to why I can investigate, but I can’t see how disabling HW accel will improve things for these users.

You can backup and restore in My OSMC

I understand that. I was however asking if you could make that change temporarily to investigate further.

I personally don’t think the issue is related to HW accel or 50/60 content.

The most important thing right now would be to know whether this was a problem on older versions (March for example) version of OSMC.

Sam


#117

Ok, I’ll see when I can do the roll back to the March version and test then…
Also, I’ll check out the audio setting. Sry, did understand that as a general suggestion :wink:

But still isn’t it very strange that only 24p content shows skipping?


#118

Yes and no.

Most content is in 23.976Hz, so it may just be the case that you’re watching more clips in this refresh rate.

If this issues only occurs after some time of watching, then it won’t be framrate related.

I was watching a film the other day from my laptop, using sshfs over WiFi, so the throughput wasn’t very good. After about an hour I noticed the video jumping a bit. I found there was a regression since April where under some conditions the buffer is underrunning quite a lot. I will get that resolved for the next update and have a suspicion that it will resolve the problems reported here too.

I can give this more attention now – was dealing with the remote issue for the past few days.


#119

@sam_nazarko… what can i do, i have done so many tests with all the components of my environment:

This occurs also on the march version i wrote in the long thread, the second vero has the march version installed…

Playing the content with 60fps doesn´t show any frame skippings over the complete lenght of my testfiles!

Can this solve it and it is an eta for this?

At the beginnig of the thread a user give us a hint to increase the buffer, doesn´t help but i´ll hope the best… what suspicion do you have?

At last another user hase exactly the same problem with 4k content playing with 23,976fps… so when this is a local problem which cannot be fixed i cannot use the both vero in my environment… :frowning:

Regards!
Michael


#120

[quote=“MoD256, post:116, topic:37277”]
An interesting test would be to check if frameskips occour, when hardware acceleration is off…

[quote=“sam_nazarko, post:116, topic:37277”]
There’s no correlation that would suggest this is the case.
[/quote][/quote]

It was just a try…no more and no less… there are desperate users and I hoped to help a little bit, unfortunately without success.

But now we know hardware acceleration isn’t the problem, at least for this problem.


#121

I don’t know if this will solve your issue.
But the new video scheme will land in this month’s update.

I am trying to see if there are any commonalities between you and the other user.

Sam


#122

@sam_nazarko I will upload a sample to you in a couple of hours :wink: