Frameskipping in the most 1080p files


#203

It looks very much like it does. Doing a second test run now to cancel out coincidence! :wink: As I understood @sam_nazarko, it’s not the video scheme yet, but a different fix specifically for our problem. Right, @sam_nazarko?


#204

The new video scheme has been split up in two a couple of parts. The next update will include some significant changes; and hopefully put this issue to rest.

Sam


#205

The second test was flawless, too!

From my side, it looks like the thread can be closed as solved :sunglasses:

What about you, @MikeDelta?


#206

I hope the update will come soon … If I can help testing something, I’m here.
It seems to be worth waiting :slight_smile:


#207

Test one file, a 120 minutes movie and have no frame skips yet - will do tomorrow deeper tests!


#208

The update is now available. See http://bit.ly/2sC8Mqb


#209

Also did another test with a different file… No skipping.


#210

Did also two tests in the morning… no skips… do the last tests later when i´m back from work but at this moment it looks very good! :slight_smile:


#211

That’s awesome! :grinning:

But just to get this clear: It wasn’t a local issue, but one with clock timings and some buffer issues… So, everybody was affected by the issue and most just didn’t notice it or waited for this thread to bring about a solution?
I have to say, I’m relieved it’s fixed and it wasn’t a local issue that might’ve been unfixable. But I wanna make clear: When a problem is “only” noticed by two or three people, it’s very frustrating, being one of those few, to hear all the time that the problem can’t be a general issue because 2-3 people is not credible enough… Obviously a lot of users are not so sensitive to skipping as you suggested before, @sam_nazarko :wink:

It’s not so much meant as a critique, but as an observation maybe helpful for future problems. Bottom line: If only a few users notice and - more importantly - report a problem, it’s not unlikely that it’s a general issue others simply don’t notice or they don’t speak up and post about it in the forum.


#212

I watched the movie yesterday (until I fell asleep :slight_smile: ) and there was no skipping either changes in percentage of buffer. I’ll do the tests later today (after work) and report the result.
I believe that if the problem is resolved for @Chillbo and @MikeDelta it has been solved for me as well.
Thanks to everyone who participated in solving (and proving) this problem :beers:


#213

Not quite – I made sure that quite a few team members tested it and we couldn’t reproduce the problem. That’s when it gets frustrating for me as well – because I very much understand there’s a problem, but wasn’t sure why only a few users saw it and if the issue being reported was the same as others. For example: the 4K frameskips reported by @acidduck are now fixed; but the issue was different (albeit similar symptoms).

There are two changes that have likely remedied your issue:

  • Not delaying the presentation of a frame for so long
  • Increasing the Render thread’s priority. It’s important to present frames as they come in and if something switches away from that thread (for example to buffer; or run an add-on); then you will see a skip. We had a similar problem affecting all platforms last year; where every 10 seconds a slight skip was seen.

It’s certainly possible that some more people were affected but just didn’t notice, but I suspect a lot weren’t affected. I didn’t say your issue wasn’t credible or that you didn’t have one; but rather that I wasn’t sure that it was an issue that was common to all of you. Particularly, as some had no issue before April; some had no issue with certain content etc.

The good news is that it’s now fixed.
I’m glad to hear that the issue is resolved now.


#214

Thanks for your long reply!

Did just refer to the suspecion that kept on staying that it could be a local issue despite there only being evidence pointing towards a general Vero issue. That was a bit frustrating for me - not knowing, from my quite untechnical standpoint, how else to test and prove it to be a general issue… Well, I guess, this whole thing was frustrating for all of us in the end. :joy:

Good enjoying of the Vero 4k to all of us now, especially @MikeDelta, @Zendra and @soupladel for that matter! :+1:


#215

I can confirm that the frame skipping is indeed resolved for me as well.

I have seen the occasional frame dropped at the start of playback, particularly on larger, higher bitrate files which are more then likely caused by the location of the files (NFS just mounted in Kodi rather than fstab). I would add these dropped frames are literally only at the start and do not persist, although i have yet to have a full play through of anything.

Quite pleased this is resolved, thanks for your work on this Sam.


#216

It’s probably worth us backporting the latest NFS chunksize changes so that we can get
better NFS performance using Kodi’s NFS (libnfs) implementation.


#217

That drop has happened all the time here and still happens… And I’m only mounting via fstab now. But as the drop happens during the frame rate switching and the screen turning black for a short while, it’s doesn’t do harm here.


#218

Exactly, it has no noticeable impact on the playback beyond the blackout for the frame rate change.


#219

I have to say that i´m very pleased over the support by the developers and the community here. With the HiMedia Q10 Pro it takes months to fix errors or problems in the firmware and the support doesn´t answer so i´m very happy to push out the Android Boxes from my configuration next time… :slight_smile:


#220

Hey,
i bought the Vero 4k to play content on my 1080p projector. And i also wanted to watch the german DVB-T2 with HEVC and 1080p50 through tvheadend with it. Thats why i didn’t choose just a raspberry pi because it is not fast enough to play HEVC.

Unfortunately i have this frameskipping/freezing i think you are talking about here.
Only in DVB-T2 the video freezes for some seconds then it plays really fast forward every frames that came over until the actual point and then plays back in normal speed. Sometime i doesn’t have this problem for hours sometime this problem appears every 1-2 minutes. It could be that it depents on the channel and/or signal strength. Sound plays back without any errors all the time.

Before using the Vero 4k i used the DVBViewer to playback DVB-T2 and there i had exactly the same problem with the LAV Filters. On the PC i could solve this by disabling the hardware acceleration. This raises the CPU load but eliminates the freezing problem. On the Vero 4k i can’t do this because the CPU is not fast enough.

So i think the issue depents on a problem inside LAV but how to solve this?

If you need any logs or transport-stream files just tell me what you need and where i can find this.

This thread is really long already and i haven’t read everything. If my problem is different from what is talked about in this thread please split it into a new topic.

All the best,
Bond


#221

Hi

This is quite an old thread.

Do you experience this problem with a recording?
If so – can you send me a small recording?

Sam


#222

Hello Sam,

i uploaded the file here: https://www.dropbox.com/s/qb3lwxibtqb8433/2017-11-07-21-45_ZDF%20HD_heute-journal.ts?dl=0
The freeze starts after about 20sec and has a duration of about 5sec.

I can replicate the problem over and over again with this file.

Bond