Frameskipping in the most 1080p files


#183

Hi Sam,

Would the problem passing colour information cause the really dark picture for HDR 2160p hevc 10bit .mkv files, or is this another issue? (I have adjust refresh rate set to off)


#184

Yes, if it’s HDR encoded, that’s the issue.

The good news is it’s being worked on.
This issue won’t cause frame skipping however.

Sam


#185

Thank you Sam, and thankfully never had an issue with frame skipping.


#186

Kind of off topic then, isn’t it? As @Zendra already pointed out to me, this thread is already so immensely long that people joining now can’t even follow up what has already been discussed or looked at. :wink:


#187

Hello,

I also have tested the testfile with my normal setup, what means on External HDD on Vero4k.

Seems I don’t have the problem. 1 skip direct at beginning and 2 skips over the whole video … +34 skips in the last second of testvideo, but I think thats absolutly normal.

The file was played in 3840x2160 and 24p.

Here some Screenshots from Test.

And here all my Playback, Video and Audio Settings:


#188

Test at last some of your settings without any luck! The only way to playing any content without frame skipping is “set display refresh rate” = off so all content will play with 60fps and this isn´t smooth! When i´m try to play a file with 23,976fps frame skips occurs… :frowning:


#189

Do you recognise those skips without them being shown in the overlay?

There might be some occasions where kodi skips frames to sync that might not be noticeable to the viewer and quite normal.

Also, does your tv really support those refreshrates? If not, frameskips will happen.


#190

Do you read the whole thread start by me from the beginning? We made so much tests in the last weeks and yes, my tv and complete equipment support those refreshrates and i have two other media player from himedia that play all files without such frame skips, but all these things you can read in the long thread… i´m waiting for the new video scheme from @sam_nazarko and hope that it will fix these problems and i´m not alone, some other user have the same…


#191

Yes – hopefully new video scheme will help. The thread is rather long however and it can get quite confusing

The number of users affected (around 2) seems to be low enough that it is still possible to be a local issue.


#192

Sure, the numbers might be low, but even after all the tests that most of us (that have complained about frame skipping) have undertaken you still think it’s something local?


#193

Honestly – yes.

But we will see with the next update. Localised / equipment specific doesn’t mean unfixable; it just makes things harder to get to the bottom of. We had issues with users with Philips TVs having colour issues but also resolved this.


#194

That concerns me a little.

I can’t speak for others but i have tried a number of different combinations of equipment and configurations and none of these changes in equipment has improved things for me and the only thing that has stayed consistent in all of this was the Vero 4k and frame skipping.

I have tried two different TVs and a computer monitor, with and without two different AVRs, playing the media back from a NFS mounted nas, usb HDD and directly from the eMMC, ethernet connection direct to the router and via a switch, a wifi connection as well. I have tried a selection of cables and of course a selection of different media. I have tested the media on other devices such as a minix box, two different laptops (OSX and Windows) and a windows 7 PC.

I have even tried a complete re-install of OSMC and the problem still persists.

The only thing that improves on this and all but eliminates the frame skipping issue is to disable the “adjust frame rate” option. In this event the files play perfectly.

I am open to considering something may have been missed or there is something i have just not tried yet, and i accept that diagnosing an issue like this can’t be easy, but equally i just can’t see where in my various configuration attempts the blame can be placed on anything local.


#195

Let’s wait for the next update, then see if you still have issues. The thread has grown quite long and even today it’s becoming hard to keep on top of it, i.e.

What’s interesting about your issue is that it didn’t occur frequently until recent updates; so I don’t think it’s related to OP’s issue.

Unfortunately as the post has a few participants it’s hard to chase up every person’s issue individually. Looking at your posts again, I would try play a file back locally or using an fstab mount, as the Kodi based NFS mount can cause throughput issues (and stuttering)

Sam


#196

I have to say, he’s right about that. My testing results in the Vero 4k being the only last consistent thing in my tests, too… And I have repeatedly said this already. I’d love to cancel out the Vero and fix an issue locally as it might be way easier to fix. But that just wouldn’t make sense now considering everything.

That’s, I guess, the problem… There’s no equipment, we’re sharing. No brand, no device, nothing. After changing all variables possible during testing, it simply can’t be this kind of a problem.

Well, we did test older version of OSMC that ran on Vero and it didn’t change anything. The only thing I struggle making sense of: why are only a few reporting this problem? The above mentioned and this don’t make sense!

No matter how much I try to make sense of everything and how much I’m writing here, that’s my hope - the update! But, I’m sorry, out of logic, I have to argue against a local issue (until somebody can explain to me how that would be possible despite all the above mentioned.) :wink:


#197

Test this both at the beginning and have also frame skips…


#198

@sam_nazarko was reffering to @soupladel here, not us. I believe he knows that we did already test all this. :wink:


#199

Ah ok…

This is also for me the only way to play a file without frame skips, unfortunately playing all content with 60fps isn´t smooth enough… i´m also confuesed why it occurs not frequently and it takes a while before the frame skips start and the most interesting thing for me is why it´s only occurs when the adjust frame rate option is enabled…

An update without these problems is the only hope i have to use both Vero in the future…


#200

Whilst this might, in general, be entirely valid advice but I am not sure how it is supposed to make a difference in my case given that i stated in my last post i had tried playing from a USB HDD and directly from the eMMC as well as from an NFS share…


#201

Just received a fix from @sam_nazarko and with that I could manage to run my test video from SMB/fstab mount without skipping for the VERY FIRST TIME!!! I don’t wanna rush to the conclusion that it’s fixed after one single test (there has been a test run I did from USB that didn’t have skips, but that was strange coincidence)… But it looks more than promising. :tada: :confetti_ball:

I wanna give a big round of :clap: :clap: :clap: to @sam_nazarko for his endless efforts and patience with us (I might have been quite annoying every now and then :see_no_evil:). Thank you very much!


#202

Hope that this fix will solve our problems here… is this the new video scheme from Sam?