Frameskipping in the most 1080p files


Hi @sam_nazarko !

Do some short tests bevore work - have updated my second Vero 4k and play two of my testfiles (connected the Vero with my Marantz A/V Receiver) - at this time i don´t see any frame skips… what changes do you made? Will do deeper tests later when i´m back at home… will test the direct connect with the TV in my bedroom, test the first Vero after Update, etc…

When you need it, here are the logs:


Did a full test with my test file:

2 skips and 1 drop at beginning of playback, 60 skips during playback and 32 skips at the end of playback… No difference. They just occured at a different time than they roughly occured before during playback of that file. Damn! :disappointed:



Hi guys,

Thanks for testing.

If you can run dmesg | paste-log after playback and pressing Stop, this may give me some hints.




I added some logging to check whether framerate automation rules were kicking in; and also removed a compatibility check for some receivers.



@sam_nazarko… bad luck…

Test the Vero which in the morning runs without frame skips connected with my a/v receiver now in my bedroom direct connected with a TV and have many frame skips!

The first log with dmesg | paste-log:

And the second log collected with myomsc:

Test the other Vero after the kernel update connected with my a/v receiver and got many frame skips:

The first log with dmesg | paste-log:

Forgot to make a screenshot after collecting the logs with myomsc…

I have no idea why it look´s so good in the morning and now the result is bad again… hope the logs help!



On mine the logs show that it’s not a framerate problem of any sorts…


OSMC is latest version + kernel from a few hours ago from your dropbox link…

This is picture from the beginning of the movie started from USB drive. Value under Player part is 100%:

In picture above you can ignore skip:16 info, because I made screenshot from SSH with kodi-send --action=TakeScreenshot and after that command few frame drops occurred.

After 5 min that value is 37%, after 7:30 min value is 19%. and finally after 16:30min value is 10% … After 1:18:00 value is again 100%. Number of MB is always the same. I have lots of screens pictures (taken with the mobile phone because of mentioned frame skips) if you need them.

At the end, movie completed without any skipped frame.

Log files:
dmesg | paste-log

MyOSMC log

Then I started another movie over SMB share and got frame skipping …

Log files:
dmesg | paste-log

MyOSMC log

Also I have video of TV screen.I missed the start of skipping, but I believe that this is enough to see the problem:!Asb7cE-UdQ6b31gEctAfDjiqKEtN

As I said, I do not know if there is a connection between the unstable “%” value and the loss of the frames … Tomorrow I will run second movie from USB and check if the problem reappears.

If you need something else to test, please ask …


VQ and AQ would be good to see.

If the buffer drops, you will get skipping. A user @acidduck experienced this with some high bitrate 4K clips. Fortunately this can be fixed, and I hope to get this solved in the next update.

I’m not quite sure that’s the same issue affecting @MikeDelta and @Chillbo, as it seems they can’t play back content without skips from any source. I think (hope?), that they’ve tried standard clips like BBB.


I’ll now spend the next day or so working on the new video scheme, so I might be absent from the forum for a little bit.

I’ll let you know when I have things to test.



Yes and meanwhile i have so many files testet (untouched and reencoded) and all of them playing well without any frame skips with my Himedia Q10 and Q5 i have.


I didn’t mention VQ and AQ because AQ is constantly 99% and VA is between 68% and 71% from the beginning of movie till the end of the movie.

On the following link you can find word document with all photos taken during the movie (first one - without frame skips):!Asb7cE-UdQ6b31w13YVPftOszFJx

Thanks for the effort to solve the problem …

For info, movie played yesterday over SMB (with frame skipping problem) has same problem when is played from USB drive but skipping occurred on another part of movie … cca 20 min from the beginning …


Just tested my file with a completely different setup at a friend’s place: skips again like before. His setup definitely supports 23.976fps in every way as it shows the correct input framerate coming from the Vero.

It’s definitely something about the device itself. :expressionless:


It´s all very strange, the only fact i can say after so many testing is that the problem not occure when “adjust display refresh rate” is set to “off” and the 23,976fps content plays with 60fps what isn´t very smooth… so i think the source of the problem must be the framerateswitching or something like this…

Hope that is fixed when the new video scheme is finished…


The last possible test I did now… The new PSU arrived today and I started a test with my file. Result: 70 skips within a few minutes (didn’t even take 20-30mins).

So, I think, we have ruled out external setups like TVs or AVRs by having completely different setups (and I even tested a second one), framerate switching kicks in correctly, all framerates are supported, plugged in peripherals are not the problem and it’s not just one file that results on our problems, it’s all 23.976fps and 24fps files… If the logs don’t give any more clues to whether some software issue is causing this, it only leads me to one last possibility: Could it be that a batch of Vero 4ks is having some serious hardware problems playing 24p content correctly? Only this, in my oppinion (if I’m not missing anything), could explain why a few users have serious problems playing this content and not everybody.

Please help, @sam_nazarko! I really wanna keep my Vero as the perfect device for my needs… Might a replacement of the Vero 4k be an option? Maybe replacing it with a device that you yourself have tested before shipping?

And another idea: I could send the file that I tested with mostly to you and you’d run that on your own Vero? It can’t really be the file itself as it happens with all 24p files here, but maybe it could hint towards some hardware inconsistency between older and newer Vero 4ks?


That’s really an interesting idea. I would like to test the file on my Vero4k, to see if there are the same frameskips for me.

Can you send me an Link for download, so I will test it in the next days. Thx :slight_smile:

PS: I was one of the first buyers thus I should have one of the “first generation” Vero4k, if there should be an difference.


There are no significant hardware differences between the Vero 4K units. If there was a problem with the hardware itself we would have more than a couple of users reporting the issue. I’d also expect you to always get stuttering, not just on specific framerates.

I’d be happy to swap the unit for you, but I suspect this won’t change anything if you’re not experiencing any other symptoms (crashes, freezes etc). We aren’t shipping any units until early-mid July at the moment however.

It seems we’ve ruled it out as much as possible, yes.

I am travelling currently but I am working on the new video scheme. I want to get it finished before we proceed further. If that doesn’t work, I’m out of ideas after that unfortunately and it will be best for us to just process a return for you, as it would be impossible for us to resolve the issue if it can’t be replicated here.

Please wait for the new improvements. Feel free to send me a link to the clip you are testing with.




Ok, I’ll wait for the video scheme, but if that doesn’t help, I’ll unfortunately have to return my Vero, yes.

I’ll post the link for you guys soon…

Still I’m wondering very much, if this is related to something being different in only our setups (and even with my friend’s setup which is completely different) - as unlikely as that sounds - why can’t we figure out what that is? Obviously it can’t only be about something in the setup as other devices like @MikeDelta’s Q10 or my RPi3 work flawlessly with the very same setup. So, it would have to be an issue only the Vero 4k has with some part or some property of our setup. But that obviously can’t be normal or wanted and has to be solved (on the Vero’s side!) in some way. It’s working with everything else except the Vero! :confounded:


I am travelling currently but I am working on the new video scheme. I want to get it finished before we proceed further. If that doesn’t work, I’m out of ideas after that unfortunately and it will be best for us to just process a return for you, as it would be impossible for us to resolve the issue if it can’t be replicated here.

And I’m also waiting for a new video scheme to see the results. For almost two years I have used RPi2 in the same system and I have not had such problems.

I will also try the @Chillbo clip even though I’m sure it’s not a problem in video files.

I still believe that the problem can be solved by software upgrade and I believe the following upgrade will prove it :wink:


Yup, waiting on the new scheme as currently I have had to disable “adjust refresh rate” which has all but eliminated the problem with frame skipping.

I know this will prevent it switching up the resolution for 4K files but I can’t play these anyway because in its current incarnation, the Vero 4K doesn’t seem to be able to tell the difference between a 10bit and 8bit capable set.


It can tell the difference, the problem is that:

There’s a dithering issue (resolved)
There’s an issue passing colour information on certain Refresh Rates (in progress)