Freeze on startup - default background displayed


Out of the blue my RP2 has been failing to boot into OSMC, instead just booting to the default background with no menu items. I have tried reformatting my sd card >10 times and reinstalling with no change. I restored a backup image I had of my OSMC install (from last year) and it worked for around 1 week before booting to the background again.

The system was overclocked (default Turbo) but fresh installs have the same problem without OC. An external HDD is attached to a powered hub.

Power Adaptor is as old as the RP2 (1 yr) and is from thepihut (model LA-520W, output 5V 2000mA).

I can still access the pi via ssh and have been able to grab the below logs:

I would be extremely grateful if someone in the know could please take a look at the logs and advise, thanks.

Same behavior with ext HDD disconnected?

Hi ActionA,

I tried booting without ext HDD, and I also tried running OSMC following a fresh reinstall without any HDD attached, with the same result.

What is the output of free -m?

     total       used       free     shared    buffers     cached
     Mem:           733        182        551          9          8         97
     -/+ buffers/cache:         76        657
     Swap:            0          0          0

do you think it could be a corrupt SD card? I wondered this, but would have thought reformatting multiple times would get around that issue.

SD card can always get corruption even if you formatted it several times.

But I assume you still can access it via SSH. Suggest you enable debugging and then upload debug enabled logs after reboot twice

Do you use a different skin?

Thansk fzinken. Correct - I can still access via SSH. I’ll do as you suggest and post the logs as soon as possible.

Yes and no - I use Confluence but of course it is set up out of the box.

Interestingly this issue only seems to appear when using Confluence, and is sometimes triggered when simply opening up system settings. However this could be coincidence, as I am always quick to revert to Confluence from the OSMC skin on reinstalls.

Here are the logs:

Unfortunately this is from a fresh install so maybe the logs maybe won’t prove too useful… however it’s only a matter of time before the issue appears again.

If you wouldn’t mind please taking a quick look just in case the issue is evident in those logs - if not I’ll repost once the issue appears again.



Without a crash not much to see, so suggest you upload logs after your next crash

The crash is now (endlessly!) reproducible. I had to re-enable debug logging via guisettings.xml through SSL as the GUI is now no longer accessible at all, hoping that I’ve done it correctly the logs are as below:

Seems debug loging is not enabled. Also use grab-logs -a to upload logs

debug logging now enabled -

Logs to be found @:

Produced with the following error:

grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory

The freezing behaviour also happens on the normal OSMC skin.

Sorry, my mistake the correct command is grab-logs -A

No problem and thanks for your swift responses - it’s greatly appreciated.

The output of grab-logs -A is below.

I think it must be a corrupt SD card - similar behaviour occurs on fresh installs of OpenELC. Since the power supply has been running fine for around a year I’ll buy a new SD card and cross my fingers!

I tried again with a new SD card today, but the same behaviour is occuring. So therefore it’s not the microSD card… either the software, the Pi itself or the power supply is causing the issue! Could you please take a log at the most recent logs I uploaded and let me know if there’s anything that stands out in them?

Try another power supply. Have the logs been taken while the issue is present?