Freeze when try browse local shares on Synology

Hi guys,

Last few days a made some changes in my setup.

I had to change my Internet provider (many disconnetions and poor stability)

I bought new router with QoS (somebody advised it to me here, because i experienced lags in game during Vero playback.

I also changed all local ip when experimenting with dual wan function on new router.

Also Vero had some new updates.

And now i have problem to access to my NAS into movie library thru the NFS and SMB as well. SMB show unknown error 8216. NFS somehow work, but freeze for a minutes. So i decided to try use Autofs mount, which is beyond my skill. I somehow install it, its showing my shares, but in same time, it say no such a file or directory.
Thx for help and pls some simple advices i am not Linux guy :slight_smile:

Not a good sign, how are you connected? Wireless?
First step check your LAN with iperf3

Well we would need to understand your network and setup a bit better.

  1. Provide output of grab-logs -A
  2. What is the IP of your NAS?
  3. Please copy/paste your autofs copy here using the </> format button

Hi Fzinken,

i am connected with CAT8 cable, i also forgot i can connect to Synology from my pc and also from my Android phone thru the SMB and NFS too. SMB works around 111MB/S and NFS is little bit slower, always was, because Windows client i think. I tried install iperf, but it also need installation on Synology which i want to avoid. IP of nas is Logs available at
Also i can connect from Vero to internet and play 4k movies without problems so i guess no problem with cable.
I dont know what you mean by autofs copy, do you mean this /mnt/volume1/Synology or do you want what is inside /etc/auto.nfs.shares ?

Ok, so you have mounted it as
/etc/auto.nfs.shares /mnt/volume1/Synology

So your files are now under /mnt/volume1/Synology and it seems you can access them there based on the screenshot.
Not sure why you are trying to access them via /mnt/

Basically you are now all set and just need to update your sources in Kodi and use path substitution if you don’t want to rescan your library.

Please see [HowTo] Repairing File Paths with Path Substitution for details.

This is what I was looking for but as written above I think everything should just be fine now.

Because old mnt doesnt work and ip mnt is in Autofs manual.

In my sudo nano /etc/auto.nfs.shares is this:

and i alredy clean my library and its completelly freezzed during process and i dont still have access to my files on NAS.

If i try add new source in file manager and choose NFS it will freeze for a minutes, also strange behavior is in right top coner of KODI about some preparation running…

I also tried put this to advanced xml with no luck:

    <to> smb://</to>

As mentioned, you autofs is working perfectly. Your NAS files are now available on your Vero under local folder /mnt/volume1/Synology

If you use autofs you will not use NFS in Kodi but add source from local folder /mnt/volume1/Synology

That Path substitution is wrong it would need to be from (NFS) to (local Folder)

OMG, now i finally understand what is the point! And i browse in root system of Vero to mnt folder.

Nevermind i rescan whole library, should i delete this entry from the file?

Yes remove the path substitution and the old NFS source, do a rescan and you should be done.

Ok, done.

Now i have another problem, movie library freezed on 92% says something like: looking for new content. Because that, i cant manually change wrongly assigned names.
Should i also somehow unistall iperf?

To be honest I looked at your earlier log again and there so many strange errors that I would suggest a clean OSMC install.
As you want to rescan the library there is not much you loose. Just make a backup of your customizations (like the autofs config).

Dont scare me,
i am using VERO now with addon for watch movies via webshares. I dont want rly do everything from start again. Do have Vero some repair function like sfc or dism in Windows?
Truth is i have few months problem to backup settings, its say: error copy to tar file, but no other problems few years.

Well not sure what you fear to loose if you are rescanning the library anyway.
To be honest it is a bit hard to judge where the problems are coming from.

Not really as the issues most likely coming from installed software.

Fear is about addons, i have to again find them, good version, repositories, everything setup … :frowning:

So Vero itself is ok and addons doing some mess?


Because freezed information about library rly bothered me, and also it showed some, very old movies and seasons during update, which was already deleted from disc, i decided to delete my old library like in this thread How to (properly) completely reset my movie library - #4 by darwindesign

Freezed message is gone, everything now works.

Thank you for your help!

1 Like