Freezes and Crashes While Streaming Large 3D MVC Content

I have had the Vero V since its soft launch, and have been using it to stream my personal library of 3D MVC .mkv content ripped from my Blu-ray collection through the Jellyfin addon for Kodi to my 3D TV. While smaller 2D and 3D video files streamed through Jellyfin work well on the Vero V, these large 3D MVC .mkv files have continued to be a continued source of instability and crashes for my Vero V. The biggest risk of crashes happen whenever the video is paused or seeked, and I often have to pull the power to get the Vero to respond again.
I understand the use case of streaming large (30-40GB) uncompressed 3D content in this fashion is probably very niche, so this is probably why the issue has continued to fly under the radar. I can provide logs or any more information to help you diagnose the issue further.

A log should definitely let us see what’s going on and let us solve this promptly.

Not at all - those that watch 3D are usually watching directly ripped ISO or MKV without any transcoding.

Have you checked the device is actually locking up or is it just Kodi?

So, I just realized an update to OSMC came out a few days ago right after making this post, so I decided to install from SD card. I then restored my settings from backup and tried some movies again. To my surprise, 3D movies are no longer causing freezes/crashes 99% of the time now! I can now properly skim without the movie stuttering and turning into a slide show for ~30 seconds, pause/play, and switch movies. I still got it to crash after playing many movies, but it happens so rarely now it is not a big deal anymore. I do not know how to check whether the device itself or Kodi is at fault for locking up, but whenever it crashes, the screen freezes on whatever the last frame is and the last fraction of a second bit of sound repeats continuously. The device then does not take any input from the controller/keyboard.

Here, the device froze up after watching Avatar for a few minutes, then seeking:

There was an update released on Sunday.

Does this happen with any other content or just 3D?

Can check logs later


just 3D

Another crash, this one while watching a 3D conversion of the Fnaf movie (crash happened after seeking a few times). Another issue I’ve encountered frequently when seeking is that the video may become desynchronized from the audio, and which is only fixed by pausing and letting the video catch up. This happened during this log as well.

Firstly, thanks for confirming that the issue is isolated to 3D MVC content.

The last time I saw this was on a Vero 4K + which had faulty memory.
If this is unique to 3D MVC content however I suspect this won’t be the case.

How was this file converted?

Thanks for the logs, but debugging will need to be enabled for us to extract the necessary information from them to solve the problem



Converted from .iso to mvc .mkv using dvdfab ripper.

I’ll look into enabling debugging in a sec

So, I just enabled debug logging after power cycling the device, and now the device refuses to act up. When I sent the last log, movies were constantly becoming desynchronized and the device was crashing again. This problem definitely seems to be intermittent, where the device sometimes works perfectly, and other times it’s unusable. When I updated the device, it worked perfectly for some time before reverting to instability, which prompted me to send the logs.

Give it a bit of time to see if you can reproduce.

Watched Avatar 2 from beginning for a few minutes, skipped to around the middle, tried to skip again and it froze up.

If you play from local storage / outside of Jellyfin, does the issue still occur?

Does the device respond to ping post crash?

Another: Watched Airbound from the beginning for a few minutes, skipped around, exited, tried to resume playing Coco, device froze (lol at the url)

I have played blu-rays via an external usb player and the issue still occurs (desynchronization, crashes)

I am not sure how to test this, but let me know how and I’ll see.

I wouldn’t worry about desync yet – but rather focus on the crashing element.

If you don’t seek, does the device ever lock up?

It still sometimes does, as it did when I tried to resume watching Coco in the last log, however i seeked earlier while watching Airbound in that instance.

Can you just try and put a 3D film on from the start and walk away and do something else and see if you come back to an unfrozen device?

Looking at your logs there are a few variables (USB drives attached – power consumption); WiFi and Jellyfin…