Freezing on high bandwidth 4k content

This looks a little better:

osmc@osmc:~$ smbclient -m SMB3 -L 192.168.1.110 -U brian
WARNING: The “syslog” option is deprecated
Enter brian’s password:
Domain=[THOREAU] OS= Server=

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D$              Disk      Default share
    IPC$            IPC       Remote IPC
    Movies          Disk
    print$          Disk      Printer Drivers
    TV Shows        Disk
    X-Art           Disk

Connection to 192.168.1.110 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available

Ok, so all you need to do now is edit the FSTAB, and add vers=3.0. For example:

//192.168.1.110/Movies /mnt/Server_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=X,password=X,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=3.0 0 0

and reboot.

Thanks. I need to head to bed but thank you so much for helping me out with this! I’ll keep you posted how it goes tomorrow when I’m able to get back on it again.

Okay, I was successfully able to edit the FSTAB like was mentioned above but I’m not exactly sure what I need to do properly switch Kodi over to using those mounts. I read the Path substitution - Official Kodi Wiki link but was a little unsure where I go to make those changes. I also couldn’t find where I can change the ‘adjust display refresh rate’ to On Start/Stop. I’m running Kodi 18.6 if that helps.

Also, I was able to test via iperf and here are the results:

osmc@osmc:~$ iperf3 -R -c 192.168.1.110
Connecting to host 192.168.1.110, port 5201
Reverse mode, remote host 192.168.1.110 is sending
[ 4] local 192.168.1.21 port 43743 connected to 192.168.1.110 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 11.4 MBytes 95.9 Mbits/sec
[ 4] 1.00-2.00 sec 7.58 MBytes 63.6 Mbits/sec
[ 4] 2.00-3.00 sec 11.0 MBytes 92.5 Mbits/sec
[ 4] 3.00-4.00 sec 10.9 MBytes 91.5 Mbits/sec
[ 4] 4.00-5.00 sec 11.1 MBytes 93.4 Mbits/sec
[ 4] 5.00-6.00 sec 11.0 MBytes 91.9 Mbits/sec
[ 4] 6.00-7.00 sec 11.2 MBytes 94.0 Mbits/sec
[ 4] 7.00-8.00 sec 11.1 MBytes 93.4 Mbits/sec
[ 4] 8.00-9.00 sec 11.0 MBytes 92.6 Mbits/sec
[ 4] 9.00-10.00 sec 10.9 MBytes 91.8 Mbits/sec


[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 108 MBytes 90.2 Mbits/sec sender
[ 4] 0.00-10.00 sec 107 MBytes 90.2 Mbits/sec receiver

iperf Done.
osmc@osmc:~$ iperf3 -c 192.168.1.110
Connecting to host 192.168.1.110, port 5201
[ 4] local 192.168.1.21 port 43745 connected to 192.168.1.110 port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 11.0 MBytes 92.4 Mbits/sec 0 227 KBytes
[ 4] 1.00-2.00 sec 9.67 MBytes 81.1 Mbits/sec 0 267 KBytes
[ 4] 2.00-3.00 sec 10.2 MBytes 85.9 Mbits/sec 0 269 KBytes
[ 4] 3.00-4.00 sec 9.79 MBytes 82.0 Mbits/sec 0 271 KBytes
[ 4] 4.00-5.00 sec 9.68 MBytes 81.3 Mbits/sec 0 271 KBytes
[ 4] 5.00-6.00 sec 10.3 MBytes 86.4 Mbits/sec 0 271 KBytes
[ 4] 6.00-7.00 sec 8.52 MBytes 71.5 Mbits/sec 0 271 KBytes
[ 4] 7.00-8.00 sec 10.5 MBytes 87.9 Mbits/sec 0 271 KBytes
[ 4] 8.00-9.00 sec 10.2 MBytes 85.7 Mbits/sec 0 271 KBytes
[ 4] 9.00-10.00 sec 10.5 MBytes 87.8 Mbits/sec 0 271 KBytes


[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 100 MBytes 84.2 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 99.1 MBytes 83.1 Mbits/sec receiver

iperf Done.

You might find this guide a bit easier…

Settings>Player>Videos>Adjust display refresh rate> On start/stop

Thanks for the link to the other guide. That helps explain things a bit better. I’ll work on that a bit. I was also able to correct the refresh rate, thanks for pointing me in the right direction.

If you wanted to just redo your library you could go to videos>files> context menu over a source, select “change content”, set type to none, click OK, and then say yes when it asks if you want to remove the items from your library. You would then context menu over the source, choose “edit source”, change the file path to point to your system mount, then click OK. You would then context menu over the source again, select “set content”, and then setup your scraper setting again. Repeat for each source you want to switch over.

Personally I think path subs are easier and you won’t lose your watched status, which IMO makes it better, but either way works fine.

If I choose to just redo my library, would I then be able to skip trying to figure out how to do the repairing with path substitution? If so - that seems much easier for me.

Yes. Path subs are only needed here if you want your current library to use the system mounts. If you get rid of your current library, and then change your sources to point to the system mounts, then there should be no old paths that need to be redirected.

So I attempted to do path subs just to see if I could figure it out but I don’t think it worked properly. Here’s what it looks like in terminal:

osmc@osmc:~$ nano ~/.kodi/userdata/advancedsettings.xml
GNU nano 2.7.4 File: /home/osmc/.kodi/userdata/advancedsettings.xml

<advancedsettings>
 <pathsubstitution>
  <substitute>
    <from>smb://192.168.1.110/Movies/</from>
    <to>/mnt/Server_Movies/</to>
  </substitute>
 </pathsubstitution>
</advancedsettings>

You have to select the xml and press the </> in the editor. I fixed your post.

Did you reboot after editing the file?

Did you use the file manager in settings to make sure that your mount was not only accessible but able to play a file?

If you did both of those I would reboot twice, try to play a movie, and then upload a new log. Assuming the only thing you changed in your fstab was adding in SMBv3 that looks correct to me.

Yep, I rebooted after editing the file. If I look in file manager, all I see is the 192.168.1.110 folder. Shouldn’t I see the mount called “Server_Movies”?

The file manager only has whatever shortcuts that are setup. If you are missing the “add source” entry then you can turn it on via settings>media>general>files>show add source buttons>

You can then add a source for root, or the /mnt folder, or whatever tickles your fancy to get to it. The file manager is independent of your library and its sources so this will have no impact elsewhere.

Got it. I was under the impression that changing the path subs would also correct the path in file manager but it sounds like that’s not the case.

Okay, I was able to add “Server_Movies” and play a file off it, but I’m still getting the same issue with stuttering during playback.

Here’s an updated log: http://paste.osmc.tv/unenabiyow

So was that played from the library or file manager? When you said “I don’t think it worked properly” was this because it was still stuttering or not playing?

That was played from the file manager. My response about it not working properly was incorrectly assuming that my entire library was going to get updated automatically and point to the new system mounts but it sounds like that’s more of a manual process to add them through file manager.

Gotcha. Nothing in Kodi will look any different when your doing the path sub method. The way I verify it is to look at a log and search for “OnPlayBackStarted” and then look at the file path that gets logged. In your case it should show it opening /mnt... instead of smb://...

Does the stutter now only happen on files with Atmos soundtracks?

I just tried a non-Atmos movie and had similar issues with stuttering. It seems like it’s the most prevalent when I skip a few minutes ahead in the movie. Here’s a new log: http://paste.osmc.tv/ayebuxovuj