Freezing on high bandwidth 4k content

Hello,

Hoping that somebody can point me in the right direction on this one. Lately I’ve been noticing that some Remux 4k movies (very high bandwidth) are stopping a few seconds into playing them. I have a Vero 4k, files are being hosted on my desktop computer via fstab NFS mounts, Vero 4k is hardwired into router, as is desktop computer. I attempted to check the connection via iperf through this method ([How To] Check Network Performance with iperf3) but kept getting errors (connection timed out, refused, etc.)

Here’s a copy of my most recent log where this happened this evening while trying to watch Frozen, which has a video stream of 56.8 Mb/s per MediaInfo: http://paste.osmc.io/ikiqotovew

For what it’s worth, I threw the movie on a flash drive and plugged it into the Vero 4k and it worked just fine.

Let me know if there is anything else that I can provide which might help with troubleshooting this.

Thanks in advance!

The first major thing I see is that you don’t have ‘Adjust Display Refresh Rate’ set to On Start/Stop. But it is odd that the video would play fine locally.

The second major thing is that you have fstab mounts, but your sources are still pointed to the Kodi mounts. You also mention that you have NFS mounts, but all the mounts in your fstab are SMB.

Thanks for the quick reply. I can change the ‘adjust display refresh rate’ if you think that might improve things.

If I’m understanding your 2nd paragraph correctly, are you saying that it appears that the mounts don’t appear to be configured correctly?

Your FSTAB mounts look OK, but your never switched Kodi over to using them. Kodi is still trying to use what’s defined in your sources.xml. Have a look at this how to setup path substitution to help:

Path substitution - Official Kodi Wiki for details.

Or, if you don’t have a large library you could just remove the Kodi SMB sources, add the FSTAB sources and rebuild your library.

Thanks. I’ll do some poking around the link you sent over. I guess I’m not sure what would constitute a “large” library. I currently only have around 100 movies and 10 tv shows that I’m sharing.

Honestly I don’t think it would take that long to rebuild the library if that was the easiest option.

If you want to test it without having to configure anything else first you can access your system mounts from the file manager in settings and try playing from there. If that solves your problem then you can do either method to point your library to the system mount.

1 Like

If you don’t mind rebuilding (And I don’t consider 100 movies and 10 shows as large as I have 1235 movies and 352 TV shows (16907 episodes) :wink: then I would consider that as the best option.

Good idea. I didn’t think of that.

I attempted to access my mounts from the file manager like you mentioned and received a “Couldn’t connect to network server” error, so I assume that means that when I play content from my Vero that it’s not accessing the files via FSTAB mounts like I want it to?

Since you setup FSTAB, I assume you know how to use SSH?

From ssh what happens if you try:

cd /mnt/Server_Movies

I’m very much a novice with Linux but did my best to follow the guide at Configuring fstab based NFS share mounts to get everything set up.

If I connect to the Vero through SSH and try the command you mentioned, I get “No such device”

The “cd /mnt/Server_Movies” command was always the point that I couldn’t get past when I was trying to properly configure everything through that guide. Since most of the time my movies worked, I assumed that I did everything correctly but now I’m realizing that probably wasn’t the case.

You are confusing things. The link you are using is for NFS mounts. You would use those from another linux server and rarely from Windows servers. You are use Samba (or SMB) mounts in your fstab.

Have your tried:

smbclient -L 192.168.1.110 -U <my_username>

Oh okay, so because I’m sharing my files on a windows machine, you’d actually recommend I do it via SMB shares but still through configuring FSTAB?

If I type in the command that you referenced, here’s what I get back:

osmc@osmc:~$ smbclient -L 192.168.1.110 -U Brian
WARNING: The “syslog” option is deprecated
Enter Brian’s password:
Connection to 192.168.1.110 failed (Error NT_STATUS_IO_TIMEOUT)

Once again, thanks for walking me through all of this. Most of it is clearly over my head, if that wasn’t readily apparent.

First you need to verify your WIndows system IP. Is it really 192.168.1.110?

Yep, can definitely confirm that.

What happens if you try

smbclient -m SMB3 -L 192.168.1.110 -U brian

I get the same error message. I assume when it asks me to “enter brian’s password” that I provide the same password as to when I login to the vero through SSH?

osmc@osmc:~$ smbclient -m SMB3 -L 192.168.1.110 -U brian
WARNING: The “syslog” option is deprecated
Enter brian’s password:
Connection to 192.168.1.110 failed (Error NT_STATUS_IO_TIMEOUT)