Freezing Video after July update


I have a rpi2 and upgraded it to the latest July update, and i started to experience issues with streaming, 10/5 times it plays only the audio, while it keeps the first frame of the video frozen. OR sometimes it is playing the video with double speed, and no audio.

Do you have any idea what could possibly cause this?

Thank you,

No… That’s why we ask for a minimum amount of information with which to work with.


Thanks for the template, so here are my details:

Device: Raspberry Pi 2
Installation media: OSMC is running from the sd card (2015.07-1)
Connection: Wired
Power Supply Type: Dedicated wall socket for the mini usb.
Power specs:
Peripherals: Just a single pendrive
Storage Device (incl. Network Sharing Protocol): USB drive
OSMC version: 2015.07-1
Codecs: mpeg2, vc1
Audio/Video Output: HDMI cable directly to the TV
Overclocked: No overclocking.
Config.txt Extras: nothing.

My Log file:

Does enabling omxplayer in video/acceleration settings avoid the problem?

10:24:03  15.414211 T:1957310464  NOTICE: Disabled debug logging due to GUI setting. Level 0.
10:24:03  15.414273 T:1957310464  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"

What you have provided is not a debug log…


doesn’t tell us anything. Streaming from what? Your USB drive? Your local file server? Some addon? You are leaving out the most important information here.

How could i provide a debug log?

Streaming from any plugin, e.g. kmediatorrent or pulsar. Same result. (These are using torrent sources.)

You’ve obviously not read the information I provided for you?

How does local content perform? Because if there are no issues there, then that would indicate that your issues are with the torrent streaming addons for which you should contact their developers for support.

Ok, let me try to do that. It seems others have the same issue with local media as well, just FYI:

hi @ActionA!

So i tested it, and actually if i enable the acceleration for the omxplayer the video is not freezing anymore, BUT for mkv files there is no sound anymore.

Here is the kodi.log file, you can found the other log above:

It is almost like the same that @DerDaumen mentioned here. So it is like somewhere it is working only with this acceleration, but on the other hand it is disabling the sound for mkvs: Video playback halt at startup (Aug 5 update) - #3 by ActionA

Can you try disabling “Support 8 channel DTS HD audio decoding” in system/audio settings?


Tried, and i can confirm it started to work (while both acceleration for omxplayer and the other remained enabled, passthrough remained disabled, so this was the only change I made)

Try updating.


I did the update, seems to be okay now as well. Do you have any specific options/options combo I should try to help test this update?

Also thanks for the quick fix and update!

Just a quick update: I enabled the 8-bit DTS HD… option and i can confirm i can hear the sound again on mkvs, also no freezing for the video (OMX… acceleration remained enabled).

Thanks again!

Hi at all… I have the same issue with mkv files in local (located in a HD connected by USB).
I have disabled “Support 8 channel DTS HD audio decoding” but seems doesn’t work in any way… Any solution?


I use the last Kodi on RPI1…before that I was on Raspbmc and works fine …now my HD video…size more than 30gb freezing every few minutes for two seconds…but just movie they are large than 30gb…others works fine…

I paused all torents but video still freezing…my external disc is on EXT4

any info…