Frequent Buffering with 4K content

I am getting constant buffering with 4k content. Logs here:
I am running media via hanewin NFS via wired ethernet. I have attached my iperf results and I have tried using this for advancedsettings.xml:


Example of a file that is stuttering here:

Thanks guys

Try this instead:


(That’s just a snippit)

Complete name                            : M:\XBMC\Movies\Goodfellas - 1990\Goodfellas.1990.UHD.BluRay.2160p.DTS-HD.MA.5.1.4K.HEVC
Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 81.4 GiB
Duration                                 : 2 h 25 min
Overall bit rate                         : 80.2 Mb/s

Should be watchable over Wired.
An fstab mount will help you a lot I would suspect.


Try removing:


From advancedsettings.xml, me & @dillthedog have found with recent testing readfactor hasn’t been working as expected.

Thanks Tom.

Changing to 5 did not help. Is it possible I didn’t create the XML file properly? I just right clicked “New” in winscp.

I’ve read that fstab helps, how exactly do I implement it?

No luck here as well. But thanks!

Post the complete contents of advancedsettings.xml, and make sure you use preformatted </>


Well, you didn’t make the changes I suggested.

I tried every suggestion and combination of the memory size and readfactor in this thread. That is just what it is at the moment.

Did you reboot after making the changes?

Info about how to use NFS with fstab: Configuring fstab based NFS share mounts

Yes I rebooted everytime. I will look into fstab.

Depending on whether you’re using SMB or NFS shares, it’s either this article:

Configuring fstab based Samba share mounts

Or this one:

Configuring fstab based NFS share mounts

Those articles should get you going on the fstab front. No matter, if the problem should be resolved by adjusting advanced settings or not, fstab is always recommend as it gives you better througput and higher stability.

Thanks @bmillham and @Chillbo for the thread link. I see the example is for just one movies folder and one tv folder. I have several folders in my case:

I:\XBMC\Movies -public -readonly -name:Movies
I:\XBMC\TvShows -public -readonly -name:TV
J:\XBMC\Movies -public -readonly -name:Movies2
J:\XBMC\TV -public -readonly -name:TV2
K:\XBMC\Movies -public -readonly -name:Movies3
K:\XBMC\Test -public -readonly -name:Test
K:\XBMC\TV -public -readonly -name:TV3
L:\XBMC\Movies -public -readonly -name:Movies4
L:\XBMC\TV -public -readonly -name:TV4
E:\XBMC\TV -public -readonly -name:TV5
E:\XBMC\Movies -public -readonly -name:Movies5
E:\XBMC\Blair -public -readonly -name:Blair
M:\XBMC\TV -public -readonly -name:TV6
M:\XBMC\Movies -public -readonly -name:Movies6\

Do I just add multiple lines with the appropriate names?

Yes, each share needs a separate line and mountpoint.

Ok. Will this change all my file paths and need to readd media resulting in lost history for watched/unwatched?

Unfortunately, yes.

Edit: See next post. Sry :see_no_evil:

You could use path substitution to keep your watched status. What I’d suggest is just doing one share that has problem content on it for testing purposes.

Alright that kinda sucks but it will be for the better.