Frequent Buffering with 4K content


Well, you didn’t make the changes I suggested.

I tried every suggestion and combination of the memory size and readfactor in this thread. That is just what it is at the moment.

Did you reboot after making the changes?

Info about how to use NFS with fstab: Configuring fstab based NFS share mounts

Yes I rebooted everytime. I will look into fstab.

Depending on whether you’re using SMB or NFS shares, it’s either this article:

Configuring fstab based Samba share mounts

Or this one:

Configuring fstab based NFS share mounts

Those articles should get you going on the fstab front. No matter, if the problem should be resolved by adjusting advanced settings or not, fstab is always recommend as it gives you better througput and higher stability.

Thanks @bmillham and @Chillbo for the thread link. I see the example is for just one movies folder and one tv folder. I have several folders in my case:

I:\XBMC\Movies -public -readonly -name:Movies
I:\XBMC\TvShows -public -readonly -name:TV
J:\XBMC\Movies -public -readonly -name:Movies2
J:\XBMC\TV -public -readonly -name:TV2
K:\XBMC\Movies -public -readonly -name:Movies3
K:\XBMC\Test -public -readonly -name:Test
K:\XBMC\TV -public -readonly -name:TV3
L:\XBMC\Movies -public -readonly -name:Movies4
L:\XBMC\TV -public -readonly -name:TV4
E:\XBMC\TV -public -readonly -name:TV5
E:\XBMC\Movies -public -readonly -name:Movies5
E:\XBMC\Blair -public -readonly -name:Blair
M:\XBMC\TV -public -readonly -name:TV6
M:\XBMC\Movies -public -readonly -name:Movies6\

Do I just add multiple lines with the appropriate names?

Yes, each share needs a separate line and mountpoint.

Ok. Will this change all my file paths and need to readd media resulting in lost history for watched/unwatched?

Unfortunately, yes.

Edit: See next post. Sry :see_no_evil:

You could use path substitution to keep your watched status. What I’d suggest is just doing one share that has problem content on it for testing purposes.

Alright that kinda sucks but it will be for the better.

Yeah that is my intention to just make a path to the 4K stuff and see if it is resolved.

You don’t even need to add it to your library until you resolve the problem. Just use the file browser.\XBMC\Movies /mnt/Server_Movies nfs noauto,x-systemd.automount 0 0

With this line in fstab I am getting this :

osmc@osmc:~$ cd /mnt/Server_Movies
-bash: cd: /mnt/Server_Movies: No such device

Apologies for being so incompetent here and I appreciate the patience

[4]+  Stopped                 sudo nano /etc/fstab
osmc@osmc:~$ sudo nano /etc/fstab
osmc@osmc:~$ cd /mnt/Server_Movies
-bash: cd: /mnt/Server_Movies: No such device
osmc@osmc:~$ ^C
osmc@osmc:~$ sudo mount /mnt/Server_Movies
mount.nfs: Failed to resolve server Name or service not known
osmc@osmc:~$ ^C
osmc@osmc:~$ grab-logs -f - J
usage: grab-logs [-h] [-A] [-T FILENAME] [-C] [-P] [-I] [-p] [-v] [-k] [-r]
                 [-s] [-f] [-O] [-o] [-a] [-J] [-l] [-i] [-d] [-K] [-m] [-D]
                 [-b] [-z] [-n] [-X]
grab-logs: error: unrecognized arguments: - J

WIthout knowing about your NAS, the fstab line should probably look like this: /mnt/Server_Movies        nfs     noauto,x-systemd.automount  0  0
1 Like

I dont have a NAS. Its just HDDs on my PC running hanewin NFS.

M:\XBMC\Movies -public -readonly -name:Movies6\
This is the path I want to add to fstab. Its physical address is drive M:\XBMC\Movies
If I want to find it over NFS via kodi or my phone its

I’ve tried\XBMC\Movies /mnt/Server_Movies nfs noauto,x-systemd.automount 0 0
and /mnt/Server_Movies nfs noauto,x-systemd.automount 0 0
And both get the previous errors I had.

We need to know how they are actually shared:

showmount -e
Export list for