Frequent crashes with Vero 4k+

I purchased my Vero 4k+ a few months ago because it was time to replace my rpi3 when I purchased a new TV. I’ve been using OSMC since first release I think and love it. Unfortunately my experince with the V4k hasn’t been that great. I’m having a couple of crashes every day with the unit. When I first got the unit, I think OSMC was on Kodi v 19.3. I kept updating when updates arrived and troubleshooting and trying to figure out why I was having the crashes and also trying to reproduce the scenario where it would crash, but couldn’t find any apparent reason for it crashing.

Just a few days ago I tried reinstalling the V4k with a fresh image (19.5) since the switch to 20 didn’t solve my stability issues.

Often times I can turn the TV on and Kodi is unresponsive, I can then SSH in to the device and reboot - most of the time, but not always, some times I simply need to pull the plug.
I also get the sad face from time to time, sure, I got this with the rpi aswell some times, but not 3 times a day :confused:

I tried enabling the debug logs and wait for a crash, but since I can’t reproduce the issue, the logs get big - I have a log now that’s around 160MB and can’t upload it because of it’s size, I am however seeing quite many “Out of memory” messages. in the logs.

Would greatly appreciate som tips on what to try next. Thanks

That is quite untypical. I suggest:

  1. Reboot twice and upload logs so that we can see if we see something from the logs.
  2. Disable Debug Logs and next time the Vero hangs try to login via SSH and upload logs

Thanks, I’ve rebooted twice and disabled debug logs. This morning I found OSMC frozen (as per usual). I could SSH in to the machine and get logs:

No out of memory in the logs this time though.

I think it may be related to the issue this person was having…

which unfortunately didn’t come with a discovery of what was causing it. You might try disabling add-ons until you find the one responsible for the “UpdateDetailsForMovie: Starting updates for movie” in your logs.

Thanks, I’m thinking it could be Trakt, I’ve found it caused issues for me previously (a few years back). I’m starting of by disabling the Youtube and Tubecast addons since these stopped working (Youtube API thingy) recently anyways, although, I doubt these addons are causing the issue. Will continiue on and disable Trakt if the issue persists. After that, there’s only the Kodi auto library refresh addon.

I run Trakt on one of my test build boxes and haven’t seen an issue with it so far. I would guess the library auto updater to be more likely.

1 Like

Kodi crashed several times with the YT addons disabled, so I’ve now disabled the library auto updater and report back when I see how it goes

Alright, 4 days now without a crash, longest ever since I got my V4k! Great catch @darwindesign, thanks, just curious, could this be a V4k specific issue or just newer kodi version issue? I’ve been running the auto library updater for as long as I can remember, even before osmc time and never had issues before.

I doubt it is specific to the Vero or Kodi version. I also don’t know why it is sometimes problematic. I just know that I’ve seen many times, over many years, people get crashes when using auto library updater. I personally just run a script from my PC after adding files to tell my players to update their libraries. If your using an OSMC remote you can just hold down the OK button when you are in the home screen and that will kick off an update to the video library without having to do the extra navigation.

Thanks again, I’ve now also switched to pushing library updates via script instead :+1:

1 Like