Frequent disconnects when Tethering

Continuing the discussion from Please recommend a WiFi dongle that will support tethering:

@sam_nazarko Thanks again for recommending a dongle for tethering. I purchased the Netgear A6100 and set it up. Everything worked (!), but unfortunately the results were mixed. There are two issues:

  1. Frequent disconnects
  2. No internet access on tethered device (Android phone)

I was able to setup a hotspot and connect with my phone (Android). I was able to use Yatse to control OSMC on the Raspberry Pi B+. Trouble is, the Wi-Fi connection drops and reconnects very frequently (say, every 2-3 minutes). This is strange because the phone never has connection issues when on my home Wi-Fi network. I tried “forgetting” my home Wi-Fi just in case there were connection priority conflicts, but no change.

For the times the tethering worked, I did not actually have internet access on my phone (but Yatse worked). What I mean is that any internet-connecting app reported “no internet connection” (like gmail, for example). Maybe I misunderstood what tethering achieves, but I thought it would allow me to share the Pi’s internet connection?

Does this sound like I configured something incorrectly? Logs are here:

You’ll need to edit /etc/connman.prefs and change dnsproxy to yes then reboot. This is a known problem that we hope to have fixed by the next update.

Thanks for the info. I made the change and can now access the internet. Once the fix is released, should I change this dnsproxy setting back? (I am not sure what it does - is there some security risk or other reason why default is no?)

I only tested for about 10 minutes, but the connection did not seem to drop in that limited time. Is this change supposed to resolve the connection issues too? From your reply, it seemed like it would only address the internet access, so I am not sure.

There’s no harm in leaving it enabled. dnsproxy is a feature in connman (our network manager) that as its name suggests, provides a dns proxy, much like most home routers also provide a dns proxy. We disabled it by default some months ago because it was causing some very obscure issues for a few users (like addons unable to connect to a specific site) but I think the bugs that were causing that have since been fixed.

The connection “drop” was probably your phone deliberately dropping the connection when it discovered that it couldn’t do any DNS lookups. iOS now has a similar feature called “Wifi assist” which will drop the wifi connection and go back to 3G/4G if it thinks the wifi connection is not providing good connectivity to the internet. (Which would include dns lookup failures) This will happen even if the wifi connection itself is technically good.

Thanks for the further details! So it sounds like this change might resolve both issues. I will continue testing and report back if any further issues.

Hmmm… unfortunately, this frequent disconnect problem seems to have returned after the latest release. Did anything change that might have caused this to revert?

I double-checked /etc/connman.prefs and still have dnsproxy=yes set in there.


Most likely you just have an intermittent issue that was never truly working properly.

Thanks for clarifying, but I am not too sure how to interpret this. Does it mean there is something wrong with my setup that I should be looking to resolve? Or that there are still issues with OSMC that I just need to wait on?

I have a pretty barebones setup (no addons etc), Sam confirmed the dongle I am using is compatible with OSMC tethering, and I added the dnsproxy=yes you recommended. So I am not sure why there might be intermittent issues?

Sorry, but I am still having problems with tethering. I am back to the original situation reported where my Android phone disconnects almost immediately. Is there anything else I can do? Can anyone confirm they have tethering working with the latest version of OSMC?

I guess logs are not useful here since it is my phone having trouble connecting?

I have been having trouble connecting two. I have the wipi dongle I will try a new one and send a logwhen I get back home. The led will go out on the dongle then I unplug it and plug it back in and it will stay connected for 5 to 10 min.

Mine won’t even connect for that long… at most 30 seconds :frowning:

Tethering is pretty central to my use-case, so I would love to get this fixed!