Frequent random muting, then freezing

Hi Have you any ideas what this might be? Are there any OS logs that may have some information?

1 Like

FYI an update was installed yesterday but I am still experiencing the same issues.

1 Like

I think I have the same experience.
On my regular system usually freezing after playing of few recorded files (*.ts).
About 1 min after freezing I saw the “sad face” and kodi is restarted. If it was some file recorded, recording continue, but in file is only new video. If it was happened during playing movie - there is no mark that movie was played.
I attached my complete log here
and printscreen of TOP

As @holgerd said change of vm.min_free_kbytes not help.
My regular system has RPi2, 16 GB memory card Kingston with NOOBS installation, both codec installed, Ethernet connection, power from powered USB hub (4 Amps power), same like 1TB USB HDD and USB DVB-T tuner, connected to Panasonic TV via HDMI, using CEC and Confluence skin

For the test I prepared on another card (8 GB Samsung EVO) new OSMC system (ver. 2015.11), upgraded to the last version and install only Samba, FTP and TVHeadend from App store (no any other addons), OSMC skin. After repeated playing of 1 .ts file (5 hours) the system freezing.
Last screenshot is here:

Unfortunately no sad face, sudo reboot no function, just freezing. I restarted system by reset pins. After this reset the CEC no function.
I renamed the .kodi directory and made restart and try repeated playing of same file.
There is a top screenshot after 2 hrs and 15 minutes playing:

Any help or advice what I can try to find this bug?
Thanks for your very good job.


Not to get hopes up, but @popcornmix may have found the issue. If you are using TVHeadend it’s possible some transport streams are being malformed, causing the Pi to leak memory. This eventually causes the Pi to freeze up. This has been fixed in Kodi, and I’m sure it will be fixed in TVHeadend soon too.

The fix will be included in OSMC when Kodi Jarvis is finalised. We are offering Kodi Jarvis test builds for all platforms and I will update these soon (with the aforementioned fix) when RC1 is made available




I don’t know if that attempt to fix has made it into the testing builds yet, but FWIW the Jan 29 testing build still exhibits the same unfortunate behavior.
Also, I’m seeing this while not having touched or used the TVHeadend stuff.
Moreover, I’m skeptical about the memory leak theory, because the crashes happen randomly, but sometimes only a few minutes into the stream (yesterday evening after about 3 minutes), which to me seems too short to build up a oom from a memory leak.

I’ve noticed the following pattern:

  1. The subtitles stop updating (the last one stays on)
  2. some seconds later, the sound stops
  3. some more seconds later, the image freezes

I did not have any luck with accessing the Pi remotely, the only remedy was restarting by power cycling.

A strangeness (which may be unrelated) that I noticed: after the Pi has rebooted after such a crash and you restart the playback, it may take several tries to get that right: either you get no sound at all, or the sound plays like fast-forwarding, completely garbled; usually, the 4th or 5th try gets it right.


1 Like

Out of curiosity, how many folks that are seeing this problem have their Pi setup with a USB install? I haven’t tested it very much yet, but my SD install Pi seems to be behaving better than my USB install one was…

I’m running from SD card, never had a USB setup.
Also, the freezing is arbitrary, had several days in a row w/o any problem, thinking ‘yep, it’s fixed’, only to experience it again several times on the same evening after that…

Regarding my previous post (No. 85):

The described audio strangeness is unrelated.

For the time being I changed over to Openelec to keep the WAF from dwindling, and I’m seeing the audio problem there either; it might be a result of the audio stream being a bit heavy for the poor old Pi as it can only play this particular stream w/o interruption or stutter when moderately overclocked (no passthrough, 5.1 stream).

Openelec does not exhibit the freezing though (it is only on kernel 4.1.16 FWIW). So it has to be something specific to osmc.

I’m having this same problem - sound goes out, then video stops, then ffs if I can get it to respond w/o rebooting. I believe I am as up-to-date as possible. I have a rpi b+. I only stream over samba. The only thing I have found to work is to quickly pause & disconnect ethernet (I don’t have a wifi dongle). But this may only work for people viewing over the network/internet & using ethernet. I rarely/never had this problem until recently & I almost always update as soon as it asks. I believe that is because I’ve only recently been preferring 720p videos over sub-720p versions. So this makes me think it has a lot to do with video bitrate. Next time this happens, I’ll pull the logs.

I think it’s a kernel issue

New kernels will be ready for you to test in the morning, and your feedback will be greatly appreciated




A new kernel is ready for testing.

Please run these commands:

sudo apt-get update
sudo apt-get install rbp2-image-4.4.1-1-osmc

(Change to rbp1-image if installing on Pi 1).

Then reboot.

You can verify the kernel is active with:

uname -a

Which should say:

Linux osmc 4.4.1-1-osmc #1 SMP PREEMPT


Thanks Sam
When I updating, I received these messages:
`osmc@osmc:~$ sudo apt-get install rbp2-image-4.4.1-1-osmc
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
apt-transport-https libbluray1
Use ‘apt-get autoremove’ to remove them.
Suggested packages:
fdutils rbp2-doc-4.4.1-1-osmc rbp2-source-4.4.1-1-osmc
rbp2-image-4.4.1-1-osmc-dbg rbp2-manual-4.4.1-1-osmc
Recommended packages:
initramfs-tools linux-initramfs-tool kernel-common
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/18.4 MB of archives.
After this operation, 63.5 MB of additional disk space will be used.
Preconfiguring packages …
Selecting previously unselected package rbp2-image-4.4.1-1-osmc.
(Reading database … 32817 files and directories currently installed.)
Preparing to unpack …/rbp2-image-4.4.1-1-osmc_1_armhf.deb …
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/001-preprocess-rbp 4.4.1-1-osmc /boot /vmlinuz-4.4.1-1-osmc
Unpacking rbp2-image-4.4.1-1-osmc (1) …
Setting up rbp2-image-4.4.1-1-osmc (1) …

Hmm. There is a symbolic link /lib/modules/4.4.1-1-osmc/build
However, I can not read it: No such file or directory
Therefore, I am deleting /lib/modules/4.4.1-1-osmc/build

Hmm. The package shipped with a symbolic link /lib/modules/4.4.1-1-osmc/source
However, I can not read the target: No such file or directory
Therefore, I am deleting /lib/modules/4.4.1-1-osmc/source

Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.1-1-osmc /boot/ vmlinuz-4.4.1-1-osmc
run-parts: executing /etc/kernel/postinst.d/inform-updater 4.4.1-1-osmc /boot/vm linuz-4.4.1-1-osmc
run-parts: executing /etc/kernel/postinst.d/process-vmlinuz-rbp 4.4.1-1-osmc /bo ot/vmlinuz-4.4.1-1-osmc

Any advice?
Thank you

osmc@osmc:~$ uname -a
Linux osmc 4.4.1-1-osmc #1 SMP PREEMPT Mon Feb 15 01:00:53 UTC 2016 armv7l GNU/Linux

Your command line output doesn’t indicate an error.

And uname -a shows you are up to date

Let us know how things go.

Now testing playing of recorded files.
My RES is now 119236 and slowly increasing.
What is in new update? I now see the icon on my TV.

Just a new kernel update there, from 4.4.0 -> 4.4.1, but this has not been publicly pushed yet.


After 25 min I have RES 131372 - I think it is wrong.
But maybe is necessary make new record first? And testing this new file?

After 60 minutes of playing new recorded file I have RES 217412
I think the new kernel not help to my issue.

I just upgraded to the Jan release and it installed 4.4.1-1 upon checking over command line by using uname -a

Sorry to interrupt this thread but I have also been doing some testing. Hope this evidence is usefull…

I installed the latest update,checked it was 4.4.1-1 using uname -a. Turned logging on and rebooted the RPi2 again.
Next I used SSH to log in and ran TOP

I took a screen shot of the terminal window showing the info TOP was providing before playing a video…

next I played some videos and observed the RES starting to rise and also the VIRT was rising.

I accelerated the process by stopping, playing, fast forward, reverse, switching back to the main window while the video was playing and returning to the video, and changing to different videos of different sizes and bit rates, playing different videos randomly while watching the TOP data in the terminal.
The next photo is after doing this for a little while as can be seen below…

I continued this some more… watch as the RES rises. sometimes it dropped back a little bit when I stopped the video and returned to the movie selection menu.

and the process contimues…

After repeating this random process of playing different videos, stop, start, pause, start, fast forward, reverse, changing menus while video playing in the background this is the point when the sound wont play…

The clicking sound that normally happens when you click on something in a menu is also gone and now the videos are starting to freeze and when I press stop and return to the movie selection menu it takes a few seconds before it returns back to that screen. Here’s the TOP display at the point when this happens…

Finally I uploaded the logs while I am still able to…

You seem to have turned off the free memory summary at the top of the display - which makes evaluating your screenshots a bit difficult. Also you are not sorting based on memory usage, but by the looks of it based on CPU usage, which also makes it impossible to gauge overall memory usage. (of other processes)

Although 188MB res is higher than I’d like to see I doubt this is the cause of your problem on a Pi 2 which will still have plenty of free memory.

ok, yes I did but I see what I did wrong now when I ran TOP and didn’t configure it right. I will try again and watch the other processes for anything unusual.

Ive just run the same tests again… just the same as before but this time it happened much quicker before the sound stopped and the freezing video occurred…
Started with a reboot, then a screen shot from TOP before any videos where played…

Then played some videos, not from start to finish but a few minutes of each and also fast forward, reverse, pause, randomly and leaving the video running while going back to menu screens and returning to the video playing. I noticed the REZ getting higher but no other processes changing in the next screenshot…
Then the sound stopped when I played another video but nothing changed in TOP in this next screenshot…

after that the video started freezing and took a few seconds to exit back to the movies menu screen when I pressed stop. I tried to play another video I had previously played but it kept freezing. I took another screenshot at this point.

Then I uploaded the logs…

Hope this is of use to someone