Fresh install issues

I just got a RPi 4 and am doing a fresh install of OSMC. I have tried the new 2023.08.01 as well as the 2023.07.01 bersiond from the installer, but get the same issues.
Samba doesn’t appear to be running. I configured what I could find in the menus, but no change. Also, I cannot launch the Store app from OSMC, not sure this is related, but I used to go there to “install” it.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks, I reverted to the 2023.01.01 build and got samba configured and the menu worked then updated to a recent build.
I also was getting errors about “couldn’t connect to server” for add-ons, but when I enabled debug logging, it started working. Turned it off, and still is working.
I can still submit logs if you want, but not noticing any more issues at the moment.