Fresh Install of OSMC won't start up

EDIT: My PI 1 was broken or something, I’ve got a new PI 2 now and thats worked fine.


Relatively new user of a Raspberry here, I’ve played around with a few things in the past when I first got my PI but since then its been dormant. Finally decided to make use of it and tried installing OSMC and so far its not going so great :slight_smile:

Raspberry PI 1 - Model B
HDMI connected to my monitor
Ethernet cable connected to router directly
Proper Power supply cable thats worked since day 1 really (Input: 100-240V - 50/60Hz / Output: 5V - 1500mA)
USB Wireless Keyboard connected, tried with this disconnected aswell

I’ve installed OSMC via the NOOBs startup screen and tried installing it on a completely blank SD card and both times I can’t get past the first load of the program. It seems to fall over each time as the OSMC splash appears and startup checks start appearing all saying OK in green.

It will get to one of 4 places and then just stop for 30+ mins until I restart it.

  1. Started Authenticate and Authorize Users to Run Priveleged Tasks
  2. Sit on the splash screen and none of the OK checks appear
  3. Started update utmp about system runlevel changes
  4. It once got to the OSMC menu but it was frozen and I couldn’t move using the keyboard

I’ve been googling for ages, seen some posts about console commands by SSH into it but as its crashed, the PI doesn’t appear for me to remote and connect to :frowning: Tried reinstalling a few diff versions aswell.

I’m at a bit of loss now so any ideas or steps would be great.


Are you speaking specifically of the cable alone here? Or the complete power supply? What is it rated at? Plugged into mains or are you attempting to power by USB from TV or laptop etc?

Sorry was a bit vague, its a power supply plugged into the mains which then goes into the PI. Its the one I ordered when I first got it and its worked fine since.

Input: 100-240V - 50/60Hz
Output: 5V - 1500mA

1500mA is quite low. Try one that provides at least 2000mA.

I’ve plugged in one with 2000mA and now I just get sadface after the splash has disappeared :frowning:

EDIT: Now even with the 1500 I get the sadface so not sure whats happened now.

EDIT2: I’ve clean reinstalled again and thats resolved the sadface but now we’re back to it crashing on Update UTMP

If possible try another SD card

Just given it a shot on another SD card I have. Its stopped on the same line for Update UTMP :frowning:

Wow then we slowly coming to the end of ideas. Last one, assuming that you still have used a NOOBS install on the new card could you try a full OSMC install with the OSMC installer instead of NOOBS? Just a warning that would replace anything else on the card.
Also what is the size of the card you used?

I formatted and reinstalled with just the installer. This time it got stuck at (A start job is running for Set Time using HTTP) and then the sadface appeared again.

Both cards are 8GB.

Now I am really at the end of my ideas. Other than Powersupply issue or hardware defect no idea anymore.

Wait just one last idea. How is the device connected to the internet?

[quote=“ItsTehShadow, post:1, topic:14621”]
Ethernet cable connected
[/quote] - but, possibly you wanted to know to what it is connected?

Its connected via an Ethernet cable directly to the router. I’ve unplugged it from my main computer so I can be confident its working :slight_smile:

EDIT: I do have a wireless USB for the PI but that didn’t seem to change the problems I’m having so I’ve been trying Ethernet instead

This is the point at which I feel the obvious next step is to try a different Pi instance, as you’ve substituted everything else.
Without that, the only other thing you could try is a different OS package which would load things differently (OpenElec, Raspbian, …)
Sorry, but there isn’t anything else I can think of.

No worries. I’ve decided to upgrade to a PI 2 anyway as its a relatively small investment and means I can try make use of this older one for something else. So we’ll see how it goes installing OSMC on that.

Surely I can’t have the same issue then :stuck_out_tongue:

1 Like

Just wanted to add here, that I got my PI2 today. Installed NOOBS then OSMC and its worked instantly, straight to the menu so I’ve no idea. Maybe something had broken on my older one over time.

Either way thanks for your suggestions :smiley:

1 Like