Fresh install Pi2 - black screen

I just got a new SD card (Kingston 32gb) for my pi2 (dead sd), and installed the latest osmc img.
Hooked my HDMI screen on the pi for 1st boot, i saw the logo and then nothing-black screen.
Removed the pi, went to an analogue TV where it was before, same thing, logo and black screen.
The wifi won’t connect even though i added the proper details on setup.
I tried changing the config.txt by adding my previous settings but that didnt work, so i changed the config-user.txt adding the following:


Again, no boot.
Removed the SD card, loaded it with ext2explore and got this kodi.log

And i am stuck, i got no idea how to fix this. Is it because it’s a pi2?
Do i need to download an earlier version of osmc?

Just tried adding hdmi_safe=1 but that didnt work either…same problem.

I used a lan cable and was able to log in via ssh. Then i installed VNC and was able to see the gui via my PC.
First of all now in MyOsmc my wifi doesnt show any networks…(the dongle doesnt get recognized anymore? It did before), and then I manually changed all the appropriate hdmi_* configs again but still it won’t show the gui both on my hdmi monitor nor the analogue tv.

Thank you.

I think I should go back to Kodi v18.9, everything was working fine with that version.
Anyone knows which is the latest stable v18.9 from the repo?
I think it’s the 20201019, but I am not sure