Fresh re-install issues: USB stick and black-screen

I’ve done a few fresh OSMC image installs onto my Vero4k lately, and I’m seeing two behaviors…

Once a USB stick has been used for an install, it can never be used for an install/recovery again. I’m guessing that the BIOS is leveraging some kind of hardware ID logic for knowing when to boot into recovery mode?

I can understand this behavior for a default install, but I’m seeing this behavior even when leveraging the recovery.img and the hardware reset, specified at:

Is there any way around this? As it stands right now, if I need to do an image reinstall, I’m having to buy a new USB stick. Is there a command I can use prior to doing a re-image, that will clear the USB hardware IDs from the BIOS? I would sort of expect the hardware reset to do that, but it doesn’t seem to be doing so.

I’m also always seeing a strange behavior where after the recovery.img is loaded and when the Vero4k restarts, I’m getting a black screen. I did track this down to what seems like an issue with the HDMI comms between the Vero4k, my receiver, and my TV. All I had to do to fix this was to power off the TV, and the power it on again. Unfortunately it took me several “reinstalls” before I figured out that was all the issue was. I just wanted to capture this here, incase anyone else was seeing a similar behavior.

Basically, any time I get a black-screen I just reboot my TV (not the Vero4k) and I’m back to visual.

The recovery images are deleted off the install medium to prevent an install loop.

You don’t need to buy a new USB stick, you just need to reformat it using the osmc installer each time.

The second issue may be harder to track down. Has this always been a problem?


I have tried that, using the installer to reformat the USB stick that is. Doesn’t matter. Basically, that only works if I use a different USB stick. If I try to use the same USB stick, the Vero4k never reboots into recovery mode with that previously used USB stick, even when I use the hardware reset, and rename to recovery.img.

The black-screen isn’t really a big deal, once I figured out all I had to do was the hard-reset of my TV.

My guess is that after the image is installed, there’s not a hardware “full” reboot, more of a system reset where the HDMI signal isn’t actually being reset, so the TV isn’t switching “display modes”? That’s just a guess.

I just wanted it captured in the forums incase anyone did a search on black-screen. I’ve just found that doing a reboot of my TV vs a reboot of the Vero4k fixed the problem. I’m sure it’s something specific to my HDMI setup (AVReceiver and older Samsung TV/Monitor).

No — there’s a full reboot.
The Vero doesn’t remember a USB stick. My guess is that it’s not being partitioned correctly. You can reuse the installation media.

Getting some logs so we can see your EDID might help us work out the black screen issue


I get that you don’t believe me, but I have been unable to use the same USB stick to do a re-install of a new image when I previously used that same USB stick to do the current image install.

Just to be clear, I’m saying when I successfully install an image using a given USB stick, I can then not reuse that same USB stick to re-install a new image. Even when I fully delete all partitions on the USB stick (using Windows disk manager), and then use the OSMC installer tool to fully repartition the memory stick anew. The Vero4k will not reboot into recovery/image-install mode using the same SD/USB stick that was used to install the currently installed image.

I mean, even your own instructions state:

Sometimes, Vero 4K may not boot from an SD card or USB stick even though you have prepared it. We recommend that you try and use another SD card or USB stick if you have one at hand.

This is why I just started using new USB sticks every time I need to re-install a new image.

Is there some chance that the SD/USB hardware ID is being stored on a previously successfully installed image, and thus using that same hardware ID to prevent the bootloader from starting into restore mode on subsequent reboots? I know you said it’s just deleting the .img from the SD/USB memory, but could it also be storing a hardware ID to prevent restarting into recovery mode on reboot? It seems to be the only thing that makes sense given the information that I have provided.

USB sticks can be temperamental.
Have you tried with an SD card? It may work more reliably.

No – that’s impossible.

Upon your claim I tested this with a Vero4k, actual Widnows installer, 1 GB pendrive and actual 2019.06-1 release.

  1. prepared the USB stick on Windows
  2. first installation went fine
  3. prepared the USB stick on Windows a second time
  4. second installation went fine

So, in general I cannot confirm your statement. There must be other circumstances which let you assume your issues follow such recognition rule. What is the exact failure/behaviour if you prepare the stick a second time and try to boot from it?

After the installer successfully ended its work, the stick should contain

Volume in drive D has no label.
Volume Serial Number is 9B47-B29E

Directory of D:\
06/23/2019  04:01 AM        22,007,808 kernel.img
06/23/2019  04:01 AM            83,968 dtb.img
06/23/2019  12:19 AM       221,653,456 filesystem.tar.xz
           3 File(s)    243,745,232 bytes
           0 Dir(s)       7,120,896 bytes free

OK, I must have it wrong.

Just delete the post.

No need to delete the post.
Let us know if this happens again and we can check your stick to make sure it’s imaged correctly