Fresh USB install - stuck on "sad face", read-only?

Dear fellow OSMC users,

I have been trying to install OSMC on three different USB flash drives (including a new one I just purchased) and while the install works fine, the system doesn’t boot after install and I’m stuck on the “sad smiley” screen.

I’m able to SSH on the machine, none of the Kodi logs are created, however I have attached the logs from journalctl below:

It looks like the usb drive switches to read-only mode. Any idea on how to fix this issue?

Thank you,

Apple TV1 (stock HDD, no Broadcom CHD installed yet)
3x different usb sticks tested
Disk images created via osmc-install on OSX

Please read the sticky at the top of the “Help and Support”-“Apple TV” section of the forum.

Thank you for your reply @yknivag, I had followed these steps but it didn’t fix the issue. Below are the logs:

osmc@osmc:~$ sudo umount /boot
osmc@osmc:~$ sudo fsck.hfsplus -f /dev/sdb1
** /dev/sdb1
** Checking HFS Plus volume.
** Checking Extents Overflow file.
** Checking Catalog file.
** Checking Catalog hierarchy.
** Checking volume bitmap.
** Checking volume information.
** The volume untitled appears to be OK.
osmc@osmc:~$ sudo mount -o force,rw /dev/sdb1 /boot
osmc@osmc:~$  sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot
E: List directory /var/lib/apt/lists/partial is missing. - Acquire (30: Read-only file system)
W: Not using locking for read only lock file /var/lib/dpkg/lock

for context, here is the devices list currently connected

Disk /dev/sdb: 7.5 GiB, 8019509248 bytes, 15663104 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: E5DB6DBE-A16D-45F6-A8C6-48EDCEF77AB2

Device      Start      End  Sectors   Size Type
/dev/sdb1      40   500000   499961 244.1M Apple TV recovery
/dev/sdb2  503808 15661055 15157248   7.2G Microsoft basic data

Using /dev/sbd2 doesn’t solve the issue either

osmc@osmc:~$ sudo umount /boot
osmc@osmc:/$ sudo fsck.hfsplus -f /dev/sdb2
** /dev/sdb2
** Root file system
osmc@osmc:/$ sudo mount -o force,rw /dev/sdb2 /boot
mount: /dev/sdb2 is already mounted or /boot busy

Use a different USB

I will try buying another usb stick then. I’ve just tried installing on the internal HDD and get the same issue :confused:

Quick update: I have bought 2x new sticks including a “SanDisk Cruzer CZ36 64GB USB 2.0 Flash Drive”, and the installation still fails. I will probably have to give up :confused:

Thank you @sam_nazarko & @yknivag for your help.

Well I am still struggeling to understand the real problem here. So can you confirm that the installation guess through and you can access the ATV via SSH but Kodi is not starting?
If that is the case I suggest you just upload full logs via grab-logs -A so that we can check what might be wrong

I’m also struggling to understand the issue, I’m starting to suspect some kind of hardware issue on my ATV. This is the result of grab-logs -A

osmc@osmc:~$ grab-logs -A
grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory
df: cannot read table of mounted file systems: No such file or directory
Unable to write temporary log to /var/tmp/uploadlog.txt

The volume must switch to read-only at some point during installation, and none of the commands seem to unlock that volume…

At this stage I’m pretty sure the usb sticks are not at fault unless I’m exceptionally unlucky (I’ve tried a total of 7), I’ve formatted the flash drives on OSX & Windows machine. I can’t think of anything else.

Well something defiantly is odd


I’m seeing exactly the same issue after fresh install (USB to HDD) !!

Install works fine with “SUCCESS” Message, but first automatic (as well as every following) re/boot the system get’s stuck with a SAD SMILEY :-((

Tried various times to install without improvement…

As I have installed “only” to HDD, I’m using /dev/sda1 for umount and fscheck…

Before Installing OSMC, in ATV1 ver3.0.2. SETTINGS, I set the video settings to RGB(high) as I installed a crystalHD adaptor previously…

…besides: I used the OSMC_TGT_appletv_20161130-HDD.img

Do this:

sudo mount -o remount,rw /

Edit /etc/fstab and add:

/dev/sda2 / ext4 defaults,noatime 0 0

(for HDD install)

/dev/sdb2 / ext4 defaults,noatime 0 0

(for USB install)

Will fix in the next version.

Thanks Sam, here is the issue I get (subsequently editing /etc/fstab doesn’t work because still in read-only)

osmc@osmc:~$ sudo mount -o remount,rw /
mount: can't find / in /etc/fstab


sudo mount /dev/sda2 or /dev/sdb2 / -o rw

still not there :wink:

Still not getting access to /etc/fstab ith sudo nano /etc/fstab I can edit but not save… “ERROR writing /etc/fstab: Read-only file system”

what’s the full command chain ?? after I booted ??

  1. ssh (pw: osmc)
  2. sudo mount -o remount,rw / i assume “/” it has to be “/dev/sda1” in HDD install ??
    … then fstab is not writeable… and subsequently /devsda2 can not be mounted by “sudo mount /dev/sda2 / -o rw”
    as not included in fstab…

You need to post the output of remount.

Otherwise, just use an older image (October) which won’t have this problem and then update.

there’s no error when I do
“sudo mount -o remount,rw /dev/sda1”

but an error when I do “sudo mount -o remount,rw /”
mount: can’t find / in /etc/fstab

That’s fine, you should be remounting 2nd partition not first though

right, but:

“sudo mount -o remount,rw /dev/sda2”
mount: can’t find /dev/sda2 in /etc/fstab

and I don’t have write privileges to add in fstab… this is where the snake bites in it’s own tail ;-))

Don’t pass remount to mount.

Just follow my commands above. Otherwise boot to rescue shell or reinstall an older image

just installed the october version !!! works fine !