I’m getting tired of all the problems I’m experiencing with my Vero 4K+

First of all, if crashes a lot, totally randomly. Even if I just reinstalled it and restored my latest backup, it crashes.
I also start having problems with sound in movies and music being choppy or glitchy, not a lot, but enough to make it irritating.
Sometimes when it crashes, I have to unplug and plug the power several times before it boots properly.
And my VPN add-on tends to lose its settings, resulting in having to uninstall OpenVPN, reinstalling it and setting it up all over again.

On top of that, now I think I bricked my device! I did a full backup, downloaded the latest install image, flashed it on SD card, as I have done many times before, inserted it in Vero, and now I’m getting the “install failed: could not mount bootfs”. I tried the toothpick trick, but no luck. When I insert the toothpick and power on the device, I’m presented with the “Please stand by”-screen, and it’s stuck there. Even after a minute with pressing the toothpick into place.

I’m ready to throw this device in the bin and buy a Rpi4 or Nvidia Shield TV Pro. Please help! First of all, I need to get it to install and boot, before that, I’m not able to include logfiles.

You might have better luck running the installer from a thumb drive,

Thanks, I will try that, when I get my hands on a thumb drive large enough. But the SD card installation has worked flawlessly until now, so I wonder what happened. I tried to format the SD card, and it seems there’s no issues with the card. I also tried a few install images, but no luck.

It’s always possible the card might be getting a bit old.

Could you show us the SD card’s contents, ideally with file sizes?

Do you have any previous posts about this? You shouldn’t have needed to reinstall OSMC so many times.

I would recommend a reinstall of OSMC and posting logs if you continue to experience a problem so that we can get a better understanding of any issues you have

Don’t use the toothpick method without installation media attached or it could prevent reinstalls from working correctly in the future without further changes.


Thank you all for answering. No, I haven’t posted about this earlier, @sam_nazarko. I guess I should have done it a long time ago.

I did have a SD card inserted, flashed with the latest install image, while trying the toothpick trick. I tried the USB method as @darwindesign suggested, and that worked perfectly. Thank you for the help!

After a fresh install, I changed a few settings, added my videos and music to my library and started scanning, and after a while Vero crashed again. Totally random. If I turn on the debug log, then the top left screen is showing text, so it’s difficult to watch video, while that is on. And as long as the crashes are totally random, I have no chance to reproduce a crash. What can I do?

I have now restored latest backup. Getting choppy sound and glitches again (not much, but still irritating)

Another thing: when restoring, it seems like all settings aren’t restored. (Regional, sound output, video output ect) what am I doing wrong here?

What do you have plugged into your Vero? Are you running a bus powered hard drive, tuner, or some other type of device that may be drawing a significant amount of currant?

What method are you using to backup and restore your settings?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

No, all I have plugged into Vero 4K+ are HDMI, network cable, IR and the USB dongle. I never had anything else plugged into the device.
I use the OSMC add-on to backup and restore settings. Library, thumbnails, add-ons + settings works fine when restoring, but the basic Kodi settings stays at the default settings after reinstallation and restoring of backup.

@sam_nazarko, as I said, it’s totally random when the crashes happen, and I have no control over when it will happen. And having the debug log enabled, and with that the flickering text I’m the left top corner all the time, it’s totally unusable as a media device, and I can’t use it like that.

So, technical question: is it possible to log without the visible text on the screen? And can I have the debug log turned on for hours/days, and still get a logfile that you can make sense of?

In advancedsettings.xml set
<advancedsettings> <loglevel>1</loglevel> <!-- Change this to "1" to hide the on-screen debug log text --> </advancedsettings>

Are you sure you have the guisettings.xml option enabled in the backup settings? That is the file where those settings are stored.

Thank you, @ActionA . I added the line to advancedsettings.xml and rebooted, but when I turn on debug log I still get the overlay text in the top left corner.

My advancedsettings.xml looks like this:

<?xml version="1.0" encoding="utf-8"?>
<advancedsettings version="1.0">
<advancedsettings> <loglevel>1</loglevel> <!-- Change this to "1" to hide the on-screen debug log text --> </advancedsettings>

@darwindesign Yes, I have everything enabled when making backup

Did you shutdown the media center before editing?
sudo systemctl stop mediacenter

Kodi will not load that file if the xml has errors. It should be this…

<?xml version="1.0" encoding="utf-8"?>
	<!-- Change this to "1" to hide the on-screen debug log text -->

Thank you @darwindesign, I thought that it looked wrong. Now it seems to be working. At least I can turn on Debug Logging, and not getting that annoying on-screen text :+1:

1 Like

I had similar problems which I eventually tracked down to the SD card having exceeded its life in terms of the number of write cycles.

If you haven’t already why not try a brand new SD card. Once I did this, the problems went away.

An sdcard is not relevant when using a Vero 4k+, it uses an internal eMMC.

@Fred_Colon thank you, I tried to install from USB stick, and that worked perfedtly. So apparently the SD card has a defect. Now on to struggling with the other problems.