Fstab NFS to UNRAID shares (tv,movies) video stops after couple minutes (like someone pressed stop)


#1

So i followed the above guide to the letter and it works perfectly up until it stops playing.
The playback is much smoother this way is definitely superior to the zeroconfig way I had before. Were it not for the fact that its like someone pressed stop on the remote every couple minutes.

Also when I restart the vero the shares are not connected and I have to mount manually.

this way seems to be the superior way since both UNRAID and vero are linux based.

fstab file:

# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0
10.0.0.10:/mnt/user/tv /mnt/tvshows        nfs     noauto,x-systemd.automount  0  0

iperf:

osmc@osmc:~$ iperf3 -R -c 10.0.0.10
Connecting to host 10.0.0.10, port 5201
Reverse mode, remote host 10.0.0.10 is sending
[ 4] local 10.0.0.60 port 59122 connected to 10.0.0.10 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 108 MBytes 903 Mbits/sec
[ 4] 1.00-2.00 sec 110 MBytes 922 Mbits/sec
[ 4] 2.00-3.00 sec 102 MBytes 855 Mbits/sec
[ 4] 3.00-4.00 sec 105 MBytes 883 Mbits/sec
[ 4] 4.00-5.00 sec 106 MBytes 889 Mbits/sec
[ 4] 5.00-6.00 sec 105 MBytes 879 Mbits/sec
[ 4] 6.00-7.00 sec 103 MBytes 866 Mbits/sec
[ 4] 7.00-8.00 sec 101 MBytes 848 Mbits/sec
[ 4] 8.00-9.00 sec 105 MBytes 877 Mbits/sec
[ 4] 9.00-10.00 sec 107 MBytes 899 Mbits/sec


[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 1.03 GBytes 885 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 1.03 GBytes 882 Mbits/sec receiver

EDIT: cant reply to anymore posts since I am a new user so I will send the log over the weekend since its not a huge priority. Have a nice weekend


#2

Can you post a debug log when you experience stuttering?


#3

What is the output from the “mount” command?

also, the ‘noauto’ option means “do not automount” which it is why it’s not mounting on boot.

for example, here’s one of my fstab lines:
192.168.1.2:/media-share /media-share nfs nofail,vers=4,rw,bg,async,noatime 0 0


#4

That’s not entirely correct. If you look at his fstab line, it has x-systemd.automount in it. That uses the systemd mounter so it only mounts drives upon access. noauto is used to prevent the drive from mounting on boot.


#5

yeah, but then it is not yet mounted when something asks for it, and it takes time to mount up, so you add a risk of the app timing out when waiting on the connection attempt (if it cannot mount fast enough) and it will un-mount when idle (not sure what the default timeouts are for systemd automount)


#6

Yes, that is the point of using automount, don’t mount until needed. Prevents problems if trying to mount from a NAS that is offline while the system is booting.

In my several years of using automount, a very rare occurrence.

Yes, very helpful when the NAS goes to sleep as many people do here.


#7

Assuming the server is actually able to respond to the mount request, I don’t think it’s possible for an app to time out because of the way the kernel and file system mounters behave. Now, the mount attempt itself could time out, but again, that almost certainly means the server isn’t there at all. And, the default for nfs mounts is hard, which would mean it would never time out, and the app would completely freeze until the server and mount were available again.

A “read-mostly” mount for media would be better if “soft” is set, as the only real issue with “soft” is possible data corruption on writes. If you are rarely writing (and by “writing”, I mean changing files on the share, not just deleting them), then it’s not a problem. And, this will keep Kodi from locking up if the the NAS goes away while you are reading data.

Also, since most people don’t create .automount unit files for the lines in fstab, the defaults are used, and the default is to have no idle timeout, so the file system is never unmounted.


#8

mount gave me:

osmc@osmc:~$ sudo mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=791072k,nr_inodes=197768,mode=7                                                                                                                                                             55)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /run type tmpfs (rw,relatime)
/dev/mapper/vero--nand-root on / type ext4 (rw,relatime,stripe=1024,data=ordered                                                                                                                                                             )
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relat                                                                                                                                                             ime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmod                                                                                                                                                             e=000)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xa                                                                                                                                                             ttr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpu                                                                                                                                                             set)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blki                                                                                                                                                             o)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatim                                                                                                                                                             e,cpu,cpuacct)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,de                                                                                                                                                             vices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,fr                                                                                                                                                             eezer)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,mem                                                                                                                                                             ory)
cgroup on /sys/fs/cgroup/bfqio type cgroup (rw,nosuid,nodev,noexec,relatime,bfqi                                                                                                                                                             o)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=27,pgrp=1,time                                                                                                                                                             out=0,minproto=5,maxproto=5,direct)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=183124k,mode=7                                                                                                                                                             00,uid=1000,gid=1000)

once I start playing a movie after couple minutes it stops playback. I can start the movie right away again and it continues to play where it stopped before.

I have set my UNRAID server to go to sleep after 30 minutes of inactivity but still I checked and that didn’t happen when I was testing.

I tried: 10.0.0.10:/mnt/user/tv /mnt/tv nfs nofail,vers=4,rw,bg,async,noatime 0 0

also not working. not even getting the shows when I try to list the contents of the /mnt/tv

EDIT

got something back when following the original guide:

osmc@osmc:~$ grab-logs -f -J
Traceback (most recent call last):
  File "/usr/bin/grab-logs", line 885, in <module>
    copy, termprint = parse_arguments()
  File "/usr/bin/grab-logs", line 627, in parse_arguments
    SETS[k]['active'] = arg
KeyError: 'fstab'

help? what does that mean?


#9

OK final observation:

  • following the original guide I can reboot vero and it mounts my shows.
  • I can map directory in osmc and play a show.
  • after 3-5 minutes playback stops but I can start again right away.

can I log if the mounted directory is very briefly disconnected? because that makes the most sense of what is happening.

EDIT: could play for 15 minutes now its gone again. rebooting wont mount the share again… so weird.


#10

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


#11

ah thanks will do once I am back home.