Fstab troubles after reset of Vero 4K. "No such device"

Dear all,

I’ve used this guide in the past succesfully to connect my Vero 4K+ to my windows 10 shares in my HTPC. Somehow it stopped working and I could not get it fixex, so I reinstalled my 4K+ according to the instructions of this guide

Now I wanted to get my shares te get to work, so I used the first mentioned guide again. It will not give me any error messages while performing the steps. Only if I go to the \mnt\ folder", I see my mounted “Films” folder but but when I try to acces it, it will not respond for a few seconds and will return "-bash: cd: Films/: No such device

Also then trying to use the mount option in the guide, i get this response:
Couldn’t chdir to /mnt/Films: No such device

And finally when just trying to acces my IP or computer network name (as last part of the troubleshooting section) I get this response:
Connection to failed (Error NT_STATUS_IO_TIMEOUT)

I tried “vers 1.0, 2.0, 2.1, 3.0 and 3.02” whit no difference (only tried the extra troubleshooting with 3.0)

Logs available at https://paste.osmc.tv/tazolarazu

I don’t understand, it used to work just fine… Can anybadoy give me a hint in the right direction?

Install smbclient with sudo apt-get install smbclient
And then run smbclient -L -U osmc and post the output here.

Thanks!. I tried it. It installs with no errors. then when i run the second commant, it asks for the share password after performing, I enter ithe password and then this:

osmc@osmc:/mnt$ smbclient -L -U osmc
WARNING: The “syslog” option is deprecated
Enter osmc’s password:
Connection to failed (Error NT_STATUS_IO_TIMEOUT)

(sorry haven’t figured out yet how to properly post logs)

I fixed it. It was on the win10 computer. I tried mounting a drive with my chromebook and did not work. Somehow network discovery was disabled and I enabled it and now both the Vero and the Chromebook can mount that drive