FTP access from OSMC to SD Card on a Macbook

I have OSMC (Rpi 3) setup to access a Movies folder on my Macbook through FTP (not sFTP) as a shared location from which I can stream videos from time to time on my LAN. This works and has always worked perfectly.
Yet, as I don’t have a lot of HDD space I thought it would be a good investment to get a 200gb SD card and use that instead, as a shared location.

I can’t access that SD Card from OSMC in any way. I can do it from an Android phone, with the same configuration I’m trying to use in OSMC and I can also confirm on my FTP client on the Mac that the configuration works, so, my question is, has anyone pulled this (or anything similar) off? Is FTP completely ironed out in OSMC or are there any known issues?

I’ve used the debug logs but those give no major hints (to my knowledge at least).
I’ve tried giving all the permissions, and then some more, to the card, using BatChmod, to no avail (even though Android connected just fine without any of that), and I tried a number of url variations (/, // or /// before Volumes) all to no avail…

18:01:10 3647.494873 T:1957155760   DEBUG: OnKey: return (0xf00d) pressed, action is Select
18:01:10 3647.496582 T:1738798064   DEBUG: CurlFile::Open(0x67a3d878) ftp://USERNAME:PASSWORD@hoya.local:21/Volumes/warsaw/
18:01:10 3647.670654 T:1738798064   ERROR: CCurlFile::FillBuffer - Failed: Access denied to remote resource(9)
18:01:10 3647.670898 T:1738798064   ERROR: CCurlFile::Open failed with code 550 for ftp://USERNAME:PASSWORD@hoya.local:21//Volumes/warsaw/
18:01:10 3647.671143 T:1957155760   ERROR: GetDirectory - Error getting ftp://USERNAME:PASSWORD@hoya.local:21//Volumes/warsaw/
18:01:10 3647.671387 T:1957155760   ERROR: CGUIDialogFileBrowser::GetDirectory(ftp://USERNAME:PASSWORD@hoya.local:21//Volumes/warsaw/) failed
18:01:11 3647.944580 T:1957155760   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x0000, modifier: 0x0

Logs are saying username or password is wrong

Thing is, on Add Network Location, if I leave everything as it is (username and password) and only change the Remote Path to, say, Movies, it works (which proves the username and password are indeed right).
Yet when I change it to /Volumes/warsaw (the SD Card) that’s the message it outputs in the log.

Finally got it to work, all I had to do was write in the terminal

ln -s /Volumes/name-of-the-SD~card/ name-of-the-shortcut

This created a “shortcut” for the SD Card on the Macbook’s Home Folder, which I was able to access from OSMC without any issue.