Full Frame 3D still not working with September update


#1

Hi there!

I just updated my Raspberry Pi 2 with OSMC to the September update, which is bringing, among others, a “fix for issues with Full Frame 3D playback on Raspberry Pi”.

Full Frame 3D is something I’ve been trying to get working since I bought my Raspberry Pi 2, without success.

I’ve read other threads on the Help and Support forum, such as this one. So I do have:

  • “Adjust display refresh rate” set to “Always” (switched from “On Start/Stop”, just in case)
  • “Support MVC video (full frame 3D)” enabled
  • “Use Full HD HDMI modes for 3D” enabled

Here is the result of “tvservice -m CEA”, even though I think it’s not used anymore:

osmc@osmc:~$ tvservice -m CEA
Group CEA has 16 modes:
           mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive 
           mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive 
           mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive 3D:TopBot|SbS-HH
           mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive 3D:FP|TopBot|SbS-HH
           mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 3D:FP|TopBot|SbS-HH
           mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced 
  (native) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive 3D:TopBot|SbS-HH
           mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive 
           mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive 3D:TopBot|SbS-HH
           mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive 3D:FP|TopBot|SbS-HH
           mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced 3D:FP|TopBot|SbS-HH
           mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced 
  (prefer) mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive 3D:TopBot|SbS-HH
           mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive 3D:FP|TopBot|SbS-HH
           mode 33: 1920x1080 @ 25Hz 16:9, clock:74MHz progressive 
           mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz progressive

(I own a Panasonic TX-P50ST60E)

And after launching a 3D Blu-ray MKV Remux, “tvservice -s” returns:

osmc@osmc:~$ tvservice -s
state 0x12000a [HDMI CEA (32) RGB full 16:9], 1920x1080 @ 23.98Hz, progressive

Whereas with a 3D Blu-ray Half SBS transcode, I get:

osmc@osmc:~$ tvservice -s
state 0x12000a [HDMI CEA (32) 3D FP RGB full 16:9], 1920x1080 @ 23.98Hz, progressive

And a really crappy image quality.

Any idea what can be wrong?

Anyway thank you for OSMC which, beside my 3D issue, is the perfect mediacenter solution.


#2

Did you put the .3D.SBS. tag in the MKV remux file name? A debug log would of showed that info plus more.


#3

In another thread, OSMC Raspberry Pi engineer popcornmix said:

Couple of points:
We no longer use 3D flags from the EDID. There are too many incorrect EDIDs out there to rely on this. Kodi settings are the only thing that affects whether 3D SBS/TAB signalling or frame packed modes are used.

Use “tvservice -s” when playing a video to check whether we are signalling SBS, TAB or FP 3D modes.

Whether a 3D video is output as FP is purely determined by the “Use Full HD modes for 3D” switch. Not by mkv tags or filename tags. You will need a valid 3D tag to get the switch to a 3D mode however (or use the video OSD).

As he says that we should be able to use the “3D mode” menu from the OSD regardless of the filename, and as this menu was unavailable, I hadn’t tried to rename a file until now. I just did, I added “.3D.SBS” before the .mkv extension. Now I’m asked which 3D mode I want, so I choose “Preferred mode (Same as movie)”. My TV switches automatically to 3D, but I get a “Stereoscopic 3D Mode : Side by side” notification, and indeed it seems that I only get half the resolution. Now the “3D mode” menu is available, but there’s no Frame Packed option.

Although I get:

osmc@osmc:~$ tvservice -s
state 0x12000a [HDMI CEA (32) 3D FP RGB full 16:9], 1920x1080 @ 23.98Hz, progressive

Any suggestion?

The debug log is 1.6MB, should I share it entirely on some file sharing service? Or do you only need a few specific lines?


#4

You need to either use the .3D.SBS. type tags in the filename (recommended), or use the OSD to set the 3D type.

You need to bring up OSD then video then set “Stereoscopic mode of video” from “auto” to “side by side”.
Then you will have to stop the video and next time you play it you will get an option to play as mono or 3d.

The first option is preferred as it will work indefinitely. Using the OSD will store a tag in the database, but that would get lost if you deleted the source and rescraped, or renamed or moved the file for example.


#6

Hello!

You say “either” the filename, “either” the OSD. But if there’s no tag in the filename, I can’t access the 3D menu in the OSD. Which is a problem because I’d rather not rename files.

I’ve attached close ups of my TV, on which you can see that resolution seems to be devided by 2 both in horizontal and vertical directions when 3D is activated.

So at this point I’m not sure to understand if or how OSMC and/or Kodi are supposed to support full frame 3D. :smile:


#7

http://kodi.wiki/view/Video_playback#OSD_video_settings
"stereoscopic mode of video"


#8

OK thank you. So with this menu we are able to enable 3D with a 3D Blu-ray MKV Remux whatever the filename.

A 3D Blu-ray MKV Remux contains one MVC video track with two full frame channels, correct?

With such a file, I can select “Stereoscopic mode of video” > “Side by side” then go to the 3D OSD menu and choose Enable. But then OSMC and/or Kodi outputs video in Half SBS, is it expected?

Is Kodi or OSMC supposed to be able to output full frame 3D? From a MKV Remux? From a Blu-ray ISO?


#9

If the video is MVC, then it will be decoded at full resolution (e.g. 1080p for each eye).
If “Use Full HD HDMI modes for 3D” is enabled then the video will be output at full resolution. If it is disabled then either half-SBS or half_TAB will be used for the video.

Note: for MVC with “Use Full HD HDMI modes for 3D” enabled, the SBS/TAB settings only affects how the GUI is rendered - the video will identical (and full resolution) in both cases.