Full SSH Settings?

Just received my Vero

Tried to SSH into my new Vero with Winscp. I think im picking it up but Vero keeps rejecting the connection. So I can copy my advanced settings file over for Samba shared network.

Previously was working on my raspberry pi over SFTP using port 21 and OSMC/OSMC login and password.

It came up with a dialog saying use FTP i tried this with different combinations of settings.

What are the full connection settings for my reference and for future customers be great to have in the wiki somewhere under the Login and password details.

Full Vero review to come once its up and running. As I havent seen many people comment on how there units are actually running hope its a good sign that everyone is to busy using the new tiny boxes :smile:

Thanks again for all the hardwork Sam

Ftp would be 21. Sftp should be 22.

It’s worth checking that the SSH has been installed and is running on your Vero, if you want to use that (in OSMC Settings). Then all you need is the username/pwd of osmc/osmc


SSH is installed and enabled by default, so unless it has been deliberately disabled (services) or uninstalled (app store) it will be there.

As ActionA says the wrong port number is being used - 21 is FTP, 22 is SSH and SFTP. (SFTP is file transfer over SSH)

Use the SCP protocol over port 22. That’s what I used to do with Raspbmc, can’t remember trying that with OSMC.


Looks like I added two new devices to network and had wrong IP address.

As noted above SCP with port 22 works fine with WinSCP

Thank you guys for confirming the settings. Would be good to have this copied into the Wiki.

Best regards