FW transfert

Hello i cannot transfer .fw in the /lib/firmware folder.
I don’t have the access for write in these folder (no problem in /osmc).

I need to implement my usb TV stick driver in Vero.

Can you help me ?


Copy it to /home/osmc

then sudo mv it to /lib/firmware.

Thanks a lot sam it’s working but not the dvb tuner .It’s working before with the vero 1.
Any ideas

The server is connected ,it doesn’t find the hardware dvb T210

Provide grab-logs -J and lsusb | paste-log

the log here



@sam_nazarko this is similar strange to an old entry where someone had this stick on ATV.

@gounette also had it running on the Vero1.

I am not sure if it is a USB issue or maybe some drivers removed in recent versions?


it’s me again

is there something planned for correct this tuner issue ?

I need to see a full log so I know what tuner driver is missing




for information i copy/paste the .fw of the vero 1st gen to vero 2 and it’s not working.




for information i copy/paste the .fw of the vero 1st gen to vero 2 and it’s not working.




Now i have exactly the same .fw files in the 2 vero 1st and last gen.

When i plug the dvb T210 in Vero 1 no problem the tuner is detect and fully operational but in the 2nd one nothing appears in the material ,the tuner isn’t detect.


thanks for your help

Have you tried one of the different USB Ports on the Vero2?

Yes i tried all the ports.

In the drivers folder in the kernel on yhe vero 1 device i find a si2168.ko file (folder dvbadapter ) but not in the vero2.


Okay, that helps.

You want E28XX based si2168 tuner support.

I’ll see if it can be added.


For the moment i have a si28xx in the folder.
I copy paste the si2868.ko of the vero1 in the vero 2 but nothing happened.
I don’t know if the .ko is generated by the device ?


I found this with the dmesg instruction

[ 1.200488] first
[ 1.396798] usb 2-1: string descriptor 0 malformed (err = -61), defaulting to 0x0409
[ 1.398850] usb 2-1: New USB device found, idVendor=0572, idProduct=c688
[ 1.398865] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1.476197] usb 1-1.1: new low-speed USB device number 3 using dwc_otg
[ 1.585218] usb 1-1.1: New USB device found, idVendor=2252, idProduct=1037
[ 1.585234] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1.585254] usb 1-1.1: Product: USB Keyboard Mouse
[ 1.585266] usb 1-1.1: Manufacturer: HBGIC Technology Co., Ltd.
[ 1.591413] input: HBGIC Technology Co., Ltd. USB Keyboard Mouse as /devices/lm1/usb1/1-1/1-1.1/1-1.1:1.0/input/input0
[ 1.591788] hid-generic 0003:2252:1037.0001: input,hidraw0: USB HID v1.10 Keyboard [HBGIC Technology Co., Ltd. USB Keyboard Mouse] on usb-lm1-1.1/input0

maybe it will help you

here the dmesg of vero 1

[ 2574.396426] dvb-usb: found a ‘Mygica T230 DVB-T/T2/C’ in warm state.
[ 2574.626971] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 2574.627672] DVB: registering new adapter (Mygica T230 DVB-T/T2/C)
[ 2574.657353] i2c i2c-4: Added multiplexed i2c bus 5
[ 2574.657368] si2168 4-0064: Silicon Labs Si2168 successfully attached
[ 2574.669364] si2157 5-0060: Silicon Labs Si2147/2148/2157/2158 successfully attached
[ 2574.669414] usb 1-1: DVB: registering adapter 0 frontend 0 (Silicon Labs Si2168)…
[ 2574.671649] input: IR-receiver inside an USB DVB receiver as /devices/soc0/soc/2100000.aips-bus/2184000.usb/ci_hdrc.0/usb1/1-1/input/input6
[ 2574.671894] evbug: Connected device: input6 (IR-receiver inside an USB DVB receiver at usb-ci_hdrc.0-1/ir0)
[ 2574.671905] dvb-usb: schedule remote query interval to 100 msecs.
[ 2574.672106] dvb-usb: Mygica T230 DVB-T/T2/C successfully initialized and connected.
[ 2574.672214] usbcore: registered new interface driver dvb_usb_cxusb
[ 2574.964481] si2168 4-0064: found a ‘Silicon Labs Si2168-B40’
[ 2574.979686] si2168 4-0064: downloading firmware from file ‘dvb-demod-si2168-b40-01.fw’
[ 2575.564844] si2168 4-0064: firmware version: 4.0.4
[ 2575.576974] si2157 5-0060: found a ‘Silicon Labs Si2158-A20’
[ 2575.585535] si2157 5-0060: downloading firmware from file ‘dvb-tuner-si2158-a20-01.fw’
[ 2576.949715] si2157 5-0060: firmware version: 2.1.9
[ 2576.949774] usb 1-1: DVB: adapter 0 frontend 0 frequency 0 out of range (55000000…862000000)