FYI: My OSMC - Pi - Config: does not save

I changed dtoverlay= in My OSMC-Pi Config-Editor and saved changes but changes actually were not saved.
Manual editing of /boot/config.txt worked.

It would help if you told us which overlay settings you changed.

I’ve using -> MY OSMC -> Pi Config -> Config Editor
and changed the row
dtoverlay=gpio-ir, gpio_pin=18
dtoverlay=gpio-ir-tx, gpio_pin=18
saved and reboot but the changes were not saved

I had to change this and also
sudo nano /etc/modules: insert
lirc_rpi gpio_in_pin=18
save, reboot

to get my IR remote working again.
(the costum /etc/lirc/lircd.conf file was still there after November update)
Maybe this my be informative to other users?

Best and thanx for osmc

You won’t need to edit /etc/modules.
We made some changes to GPIO IR support, so will check that.

/etc/modules were empty/not existing after update; I created before but update removed it and remote not working

without creating/adding these 2 lines in /etc/modules the remote was not working

The update would not touch /etc/modules.
If you need to define modules there, then your overlays aren’t configured properly. This is simply overriding device tree, which isn’t ideal.

ok, but according my notes I created that file when I installed my remote some time ago and after update file was deleted (or empty; I’ve not checked because I’ve done sudo nano …)

unfortunately, I’m not expect;
sure, I may have configured not properly:
MY OSMC -> Pi Config -> Hardware Support -> gpio_out_pin
(this has changed since I initially configured the remote (maybe more than 1 year ago)). At that time I’ve done:
Enable LIRC GPIO support
gpio_out_pin 23
gpio_in_pin 18

recorded my personal lird.conf file, copied to /etc/lircd.conf

(as far as I noted and remember).

It is not possible for an OSMC update to impact this file.


maybe I deleted (/etc/modules) after installation but forgot this;
there is a file: /etc/modules_delete_later.

I commented-out the lines in /etc/modules;
I kept /boot/config.txt like before update: dtoverlay=gpio-ir,gpio_pin=18

and voila, IR remote is working
(proper configuration?)

I can’t reproduce the failure of the IR remote after update; maybe I didn’t test the remote carefully.

After commenting-out the /etc/modules file and
/boot/config.txt as above (the version which is working now)
I changed the dtoverlay line with sudo nano /boot/config.txt to:
save, reboot
after reboot, /boot/config.txt was like edited and not changed
but remote not working

Why are you trying to change gpio-ir to gpio-ir-tx ?

gpio-ir-tx is for sending, eg an IR blaster it is not for receiving.

The original overlay name is correct - just adjust the pin number to match the pin you use for your IR receiver.

You’re right. I do not need to change my config.txt. And I do not need the functionality to send.
My remote did not seem to work after the update (presumably I did not thoroughly test and thought too fast that the remote did not work). And on the net I have read discussions that due to the kernel update this statement in the config.txt must be changed. I did not read things properly and did not understand.