General crash link to MariaDB

Hello guys,

I have a trouble and I don’t know why.
I have setup a data base with my mane pc and allow in myphp an use to access those database.

myphp confg :
USER : osmc
GRANT : yes

My advance settings :

When i start my vero 4K+ I have a black screen and at the end of the log i can find those information :

2021-10-17 16:05:45.836 T:2728 INFO : MYSQL: Connected to version 10.5.8-MariaDB
2021-10-17 16:05:45.846 T:2728 ERROR : SQL: [MyMusic82] Undefined MySQL error: Code (1142)
Query: SELECT idVersion FROM version

2021-10-17 16:05:45.847 T:2728 ERROR : Process error processing job

How can i fix this ?

I have already delete all my previous database and start a new one from scratch just in case

ps : full log here :

Ok i have work around and now i have some other trouble…

I have a lot of error in the log file and i don’t understand why.
I have create two data base and now i want to understand what is wrong in my setup :slight_smile:

To get a better understanding of what is wrong enabling debug login might help.
Also how did you create the two databases? From scratch? Does the Osmc user have full permission on the database server?

I use Kodi 19.2 on my Windows PC to create the to database
Osmc user have Select and Grant but not other rigth

I have test the acces with putty on my nas and i have full access with Osmc

Normally the Kodi user need full database rights as it would create views and change the database.

GRANT ALL ON *.* TO 'Osmc';

Kodi user have full rigths
Osmc have just Grant and Select (since it’s just for consultation)

The osmc user should still have full rights, as it also needs to save to the database (like after listening to a song) or if you scan. I can’t see any reason security wise on a home network to not just give the osmc user full rights.

Just because i don’t want any updage on my dbb with the osmc user but only with my Kodi master user.
Before the vero update, i had no trouble with this setup

I’m surprised it ever worked since Kodi will try to write to the database after watching/playing media.

Why not at least try changing the rights to see if that fixes that issue?

Already tried…
My nas as a trouble (I’m waiting for asustor support or i will lose all my data)

Maybe my trouble is link to the Nas (After all the NFS have stopped to work…)

Double check the rights on Maria. It could be that you have a right for osmc that is only allowing access from a single IP. You could also just change the Vero to use the kodi user for database access instead and see if the problem persists.

I have tried also with the Kodi user…
Now i have to wait from Asustor before trying anything else

Ah, that would explain it if that’s where the database is also hosted.

yeah but i don’t understand why my nas will go bananas without any reason…

I have create a temporaire volume to test :
here is the log.

advancesetting for my master PC and for osmc are the exact same

Just clean instal Kodi same trouble.

I have tried another stuff :
Copy paste mymusic82 and Myvideo119 in Osmc database and it work just fine.

I guess the trouble come from my nas…

Sorry guys for the time lost.