Generally poor user experience; slow response, fickle remote(s), and network oddities

Wifi cutting out combined with the OSMC remote (which is RF as well) acting in a very uncharacteristic manor (it should not be slower than CEC) makes me wonder if there is radio interference from a nearby device.

Agreed. I have a Logitech keyboard set with an RF USB dongle and it regularly gets blocked when stuff like laptops are in the way of the keyboard/mouse. To be honest I haven’t found the bundled OSMC controller to be as susceptible. Is it in the 2.4GHz band then?

If the OP is looking for something less sluggish, I’d point out I’ve just set up a pretty decent FLIRC USB dongle template for my Vero 4K and it’s pretty snappy in use; much faster than the Xbox 360 IR I tried before. From what I understand that tends to be the best workaround if you aren’t using Bluetooth or RF.


I got up early today for no reason and had plenty of time to play with this today. Since correcting the resolution, scan, and refresh rate, I have had absolutely zero issues with my LG Magic Remote! I have even used it to switch back and forth to my old Raspberry Pi with no slow down or stutter with commands being passed through. It’s truly remarkable!

I do have my laptop on my lap almost always when watching the TV, so that might have something to do with the included remote being laggy. I will test that some more. I just had another network issue pop up yet, but I think I should move that to it’s own topic. I am happy enough to mark the remote issue solved though.

I cannot explain why, but these changes allowed my LG Magic Remote to work without issue.

That should be okay. I’ve spent countless hours with a laptop on my lap and two different models of the OSMC remote connected to two different OSMC devices in a spot that is relatively noisy in the 2.4ghz range. I’ve not experienced what you describe. You might try re-pairing the remote by holding down the home and OK buttons which may get it to use a different frequency.

Are you noticing the websocket error when accessing the Kodi web interface through a browser? I ask as I’ve sometimes seen this as well with reliable wired connections.

I would also check websocket connections are enabled on Kodi. I can’t remember which one of the settings changes it but I would check under Settings > Services > Control that the following are ticked/checked:

(You will need to enable Expert mode)

  • Allow remote control via HTTP
  • Allow remote control from applications on this system
  • Allow remote control from applications on other systems

If you made a change, reboot Kodi before trying again