Generally poor user experience; slow response, fickle remote(s), and network oddities

TL;DR - GUI is laggy or non-responsive. LG Magic Remote control is sporadic. Vero randomly “disappears” from the network. Do I perhaps have a bad unit?

Verbose post:
I’ve been using Kodi for several years. Started on a Raspberry Pi 2 I think. Worked awesome until high resolution movies came along and it just didn’t seem to handle them very well. Then I got a Firestick 4K and it worked better. Wll, except for the atrocious Amazon home screen and the tendency for the Kodi app to become unresponsive and needing to be killed and restarted. Then I tried it out on an old xbox One that I never used. It was pretty much the same thing as the Firestick. I missed a dedicated Kodi box.

So I looked for a dedicated Kodi box and the Vero 4K+ looked to be exactly what I wanted. I should be able to control everything from my TV remote and no crap I don’t want. Ordered it from PiShop and eagerly awaited it in the mail. Since I am so familiar with Kodi, I set it up just like I always do. I set my Synology samba shares, downloaded my OpenSubtitle & Yahoo weather addon’s and got to watching! My LG NANO91 recognized it as an LG Bluray player, so I thought I would be golden! Turns out the LG Magic Remote doesn’t play nice with Vero/Raspberry/Linux. My issue appears to be that I get about 6 - 10 “clicks” or button presses and then the Vero doesn’t recognize the remote any longer.

So I figure that I will just have to endure the included remote. However I noticed that it isn’t very responsive either. Many clicks aren’t registered or several clicks will get buffered and then they all come at once and Kodi goes crazy. So I switch to Kore on my phone. I can use it even though I don’t want to, but every in a while, it cannot connect to the Vero. This is where it gets really weird. When Kore cannot connect to Vero, it’s almost like it is not connected to the network any longer. It won’t play videos on my server, but it still has an IP address and I can see it connected on my router device list. I have to reboot the Vero for everything to work again.

In my attempt to fix everything, I signed up on here and started reading. After messing with a ton of settings, I decided to just completely reset the thing. I set it up with just my essentials. Video sources and subtitle addon, fix the overscan, add username and password for web UI and Kore control. That was about 2 hours ago. The remote issue persists, I can’t speak to the weird network issues.

I’ve been reading my logs and honestly, it’s either Greek or gibberish to me. I set my log up to DEBUG until the remote no longer worked and then stopped the logger with the Vero remote. But I don’t see where it says anything about an error. So why am I posting here? I just need someone to tell me if I perhaps have a “bad egg” or if this is the normal experience.

I am in no way saying the Vero is junk or Linux sucks or anything like that, I’m just kind of disappointed in the whole experience. If I knew that LG were such a pain to use with Kodi, I would have bought a Sony! But the slow or laggy response with the included remote has me scratching my head. In case you can’t tell, I like to chat, so if you are still reading this Dickensian post and you want more information, I shall be happy to provide it.

I’m confident we can get this solved, but for now, we’ll need to see some logs to work out what’s going on.

For example: it would be good to know if you are using a wired connection or WiFi. Logs will tell us this.

Can you clarify how you reset the device? Did you reinstall OSMC from the download page?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

As a quick aside: don’t use overscan - it’s better to set Just Scan or 1:1 pixel mapping on your TV. If you let us know the TV brand we can tell you the exact setting.

As you have an LG remote it sounds like an LG TV, so the option would be Just Scan.

Sam, thank you for replying so quickly! I was having dinner, so I apologize for late reply. I will do the log submission in just a minute. Yes, the TV is an LG 75NANO91ANA webOS version 5.2.0-2508 (jhericurl-jardine).

I do have a question for you in regards to the “Just Scan” setting. Where is it? I have never used that. For as long as I can remember I have used the following:
System - Display - Video Calibration. There is no option for 1:1 or Just Scan.

Also, I am on a wireless network currently. But the Vero is about 15 feet away from the router. There just isn’t a “pretty” way to get a cord over to it.

On a side note - I dug out my old Raspberry Pi. It hasn’t been turned on since Sept 2019. Plugged it in, put a generic wifi dongle on it and bam! Work like a charm. LG remote works fine. It’s the darnedest thing.

Not in Kodi, but on your TV. Configure the TV for Just Scan and then no need for Calibration/Change on Kodi/OSMC.
If you don’t find it on the TV let us know.

lol… Boy is my face red. I found the Just Scan setting on my TV just like you said. I had it set to 16:9 Aspect Ratio and Scan to Auto. I changed it to Original and Just Scan to On instead of auto.

Guess what? My damn remote appears to work as it’s supposed to. Embarrassing to say the least! Why in the world would the display/scan have any effect on the way the remote(s) function?

I do still have the logs set up to catch the network issue. So I will report back again.

Well that would also suprize me, but good that we solved two topics in one :wink:
So was that you LG Magic issue solved or the Vero Remote?

The LG Magic Remote is working better than the Vero Remote.

As for the disappearing on the network issue, it happened while I was testing the remote. Here is the log:

Ok, first another suggestion for your configuration (not related to the network issue).

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

How did you realized the “disappearing”? Where you playing a file and it stopped playing or where you navigating one of your sources?

Also what is your NAS/Server?

I’ll pick this up tomorrow morning, a bit late here now.

@fzinken - I noticed the disappearing originally when Kore could not connect to the Vero.

Then while trying browse my shares normally when that wouldn’t work, I would get errors.

I have changed my display settings to match what you recommended. I honestly can’t tell a difference in appearance, so I think that is a win.

Ok, that would indicate a network loss on the OS level. But there are no network loss in your logs.
Suggest you run either a Ping or SSH session from your PC to to see if that is interrupted at that time.

Also I wonder did you had a cable connected to the Ethernet Port at one time?

Nope, never needed to drag a wire out when I originally set the box up.

Ok, was suprized to see the interface up. Maybe just to avoid issues disable the Ethernet.
Anyway let’s do some network checks to see where issue might come from.

I have done the ping, 100% packet loss. A reboot restores network though. I don’t know if the “wait and see” approach would work only because I have not tried it.

That is really odd. Do you have an IP reserved for the Vero in your DHCP server?
Can you check logs in your router?

Also I am now a bit confused. I thought you were saying the network is only temporary gone. For the above logs was network gone but reappeared when you uploaded the logs or you had to restart to regain network?

Yes, I have the IP address reserved for this device, 2 Firesticks, my NAS, my TV, and my desktop.

I was poking around with the web interface and I noticed a notification that the websocket connection was lost. It was only momentarily before the connection was restored. I have left the page up and continued to poke around and noticed that it happens frequently just scrolling through the settings. Do you know if this is normal? Could this be another bit of info?

Surely not normal. But as you wrote you are not only loosing the websocket connection but even ping stops at that time. Which surely indicates an OS level network issue