Got IP Address & LAN but no Internet - Brain teaser!

Weird problem is vexing me.

My Pi connects to Wi-Fi LAN and gets IP address but cannot connect to Internet.


  • I can browse to device from rest of LAN - connecting perfectly, just can get to Internet. (not just reporting via GUI, actually no internet. No peers on resilio-sync or transmission, Plex, IMDB lookups etc)
  • IP Address, DG and DNS all appear as expected
  • Works well using ethernet cable
  • Oct 2017 update, latest Pi
  • Router is v24 DDWRT
  • I’ve tried another Pi with SD card and still problematic = no Wi-Fi interface fault on Pi
  • Will connect to personal hotspot from mobile perfectly
  • Only addons are watchdog and Plex. I’ve tried disabling Plex to no avail
  • I’ve tried static and dynamic IP, reboots of router etc.
  • I’ve tried resetting and forgetting wi-fi network
  • All other devices in network can get internet
  • DDWRT show Pi is connected (of course, as i can browse shares from WLAN connected laptop)

Feels to me as if Pi not getting correct Default Gateway (as connects to LAN), yet if i look at IP config when connected Pi is showing correct DG.

Only thing i think it could be is that router is issuing correct DG and for reasons i can’t fathom.

Cheers, Geoff.

Try rebooting the router.

What happens if you try to ping by IP (to bypass DNS) from command line? is always a good test.

1 Like

It’s possible low segnal trouble… have you tryed to connect to internet your Pi by a LAN cable ?

thx. if i ping i get steady stream of replies.

If i ping i get zip.

Does this mean Pi not getting Default gateway ? me thinks it does?

when i look under settings it does appear to get correct one from DHCP, the same one that other devices on the network get (and these ones work well).

mmm. Does appear as if Pi being issued correct DHCP creds, but actuals not actually routing via DG. Things that make you go Hmmmm.


It sounds basic, but you need to start locally and move outwards. Ping your router’s LAN address. Ping its WAN address. Ping its default GW. Ping the default DNS server. Ping an external IP address. Ping a known URL. When you get no response, use traceroute to find where the pings get dropped.
BTW traceroute does not seem to be installed by default in current OSMC but can easily be added using apt-get install traceroute_

I’ll second what @Steve_Eckett says.

Could you also provide the output from the following commands:

route -n
cat /etc/resolv.conf

thanks so much, after some pinging (as per suggestions) i worked out that the Pi was 20000 ms to ping internet facing router…turned out to be an old DDWRT QoS queue i put in especially so traffic from Pi wouldn’t interfere with wife’s legit work…the entry for Pi was ‘bulk’ and for some reason it was deferring Pi traffic even when there was no other traffic on network. i blame my wife.

Thx again. Good suggestions.