GPIO remote doesn't work after clean OSMC installation

So far I was using the very old OSMC version (2018.x) on my RP2. The lates problems with themoviedb scrapper forced me to update. Today I wanted to do this but unfortunately it couldn’t. So I installed the latest version, clean and fresh. But as I can see something has changed in the use of the infrared remote control. In the hardware settings I can see the warning “GPIO remote support with default pins incompatible with HiFiBerry and iqaudio” and remote control doesn’t work. I have looked at other threads regarding this incompatibility but I can see no one there is using the remote connected to the GPIO so I have not found a solution. What to do to make this remote control work?

So do you have an audio card connected?

I do not have an additional sound card. But I already know where the problem was. In the old version of OSMC, there were two options to set - ‘gpio_out_pin’ and ‘gpio_in_pin’, and in the new version there is only ‘gpio_pin’. I read it wrong and set pin 17 there, but it should be 18. Now the remote is working properly.

1 Like