Gpio-shutdown RPI4 OSMC 2021.11-2

Does anyone know if dtoverlay=gpio-shutdown is working for RPI4 running OSMC 2021.11-2 (kernel: Linux 5.10.78-2-osmc)?

I’ve trawled through previous posts on this topic to no avail (see list at end). Perhaps the most relevant post is this one OSMC raspDAC overlays gpio-shutdown pin 17 &22 - #22 by dillthedog by @dillthedog.

With dtoverlay=gpio-shutdown added to config-user.txt I see “Power key pressed” in the systemd logs whenever I short GPIO3 to GND but nothing else happens i.e. the system doesn’t proceed to shutdown. I have tried stopping the mediacenter as recommended (in the above post) but this doesn’t change the behaviour.

If, instead of accessing the command line, I short the pins when the OSMC interface is up, the act of shorting the pins brings up the “power menu” i.e. the menu which shows the options exit, power off system, reboot, custom shutdown timer, settings.

Any suggestions for further debugging? It’s starting to feel a bit out of my league.

Related posts:

  1. OSMC raspDAC overlays gpio-shutdown pin 17 &22 - #22 by dillthedog
  2. Dtoverlay=gpio-shutdown - #7 by deepo
  3. Raspberry Pi 4 B GPIO boot and shutdown button(s) - Raspberry Pi Stack Exchange
  4. pi 3 - Raspberry Pi 3 model B "dtoverlay=gpio-shutdown" - Raspberry Pi Stack Exchange
  5. [SOLVED] gpio-shutdown overlay not working - Raspberry Pi Forums