Green HD content playback with new Krypton upgrade

Upgraded to Krypton this afternoon. Any HD content I try and play is ‘green’ - the background frame is green. SD content displays normally. Sometimes after playing HD content, the default skin is purple. All was working correctly before the upgrade to Krypton.

Screen pictures

What information can I provide to try and help debug this?

Upload the pictures to our forum.
Did you read the troubleshooting thread at the top of the forum?


With debug enabled my pi3 reboots itself when navigating back to the main menu after playing a video. Not sure how useful that upload will be.

I can’t find information about posting pictures to your forum. Do you have a link?

Just press the Upload button in the menu bar. It a box with a arrow showing upwards.
Also to your problem if you have a crash when enabling Debug logs I assume either an SD Card or Powersupply issue.

I’ve had this raspberry pi 3 for over 6 months running osmc with no problems until today’s update to Krypton. I attached another power supply to the board and it didn’t reboot after playing a HD video and navigating back to My OSMC. Not sure if I just got lucky or if the new PS made a differfence =)

Here’s the Log upload

Are you still getting green content with the new power supply?

I’m not seeing any video playback in the log.
Enabled debug. Reboot. Play a video with a problem. Stop video. Upload log.

It may be worth adding “config_hdmi_boost=7” to config.txt. If that doesn’t help you can increase the number to 11.

Yes - still getting green screens on HD content with new power supply.

New logs

Setting config_hdmi_boost to 7 and rebooting had no effect - same with 11. Still get the green screen.

I don’t see anything wrong in log.
After having the problem can you report output of:
vcgencmd get_throttled

Can you explain the exact sequence from booting up.
e.g. Does the HD video always appear green immediately, or only after a while, or sometimes?
Do all HD videos behave the same, or do specific ones provoke the issue.

You say the GUI may remain purple. Does this ever happen without playing a HD video. Does it ever return to normal.

Can you test with a different TV and/or HDMI cable?

Can you enable omxplayer in video/acceleration settings?
Can you disable both omxplayer and mmal in video/acceleration settings?

Any change?

osmc@osmc:~$ vcgencmd get_throttled

Sequence: Reboot, Select “TV Shows” from menu, scroll down to “Archer”, Select “Season 3”, Select “Episode 8” - screen goes black, then turns solid green, then video starts with green tint shown in picture above. Starting in the middle of an episode (resuming) also gives an initial green screen, then video starts with green background.

All the HD videos I have tried do the same thing: Initial black screen then full green screen, then video plays with green “tint” over everything. SD videos play fine.

I’ve never seen the purple hued screen change without getting the green screen HD video. After a reboot it remains normal as I navigate through the menus until I play a HD video. After I get the purple hued screen, SD videos have that same purple hued background until I reboot.

Here’s my setup: I have my Pi3 connected via a Pioneer receiver via HDMI cable (Television Input). The pioneer receiver is connected to my Toshiba tv via HDMI cable. I also have a blu-ray player connected via the receiver. Blu-ray plays fine - no image corruption.

Connecting the PI directly to a monitor via a different HDMI cable: Video is clear - I can’t get green screen to appear.

Using the same HDMI cable (from above test) from my Pi to my receiver: Green screen. If I unplug the cable either from the receiver or the Pi, and plug it back in, the video comes back clear. If I stop and restart the video it’s green again.

Running the Pi directly to the TV (bypassing the receiver): Clear video.

So it would seem that my receiver is the culprit somehow. Trying different inputs on the receiver has no effect - I still get the initial green screen, then if I unplug the cable and plug it back it the video is normal.

Any ideas if the upgrade to Krypton would cause this? IE - did my receiver happen to go ‘bad’ at the same time? I suppose I could try downgrading to a pre-Krypton build and see if I have the same issues …

Was this run after the green screen problem?

I think it is unlikely Krypton caused this. Downgrading would be interesting.

One change Sam make in Krypton release is enabling “Adjust display refresh rate to match video” by default.
Can you try disabling that (in system/video settings). I suspect you may now be using a new video refresh rate that you never tested with Jarvis.

vcgencmd was run after playing a HD video with green background.

I don’t see that “Adjust display refresh rate” option anywhere in “Settings: System:”

Under Display I have:
Resolution: 1920x1080p
Refresh rate: 59.94
Delay after change of refresh rate: Off
Enable higher colour depth artwork: enabled
Set GUI resolution limit: Auto

There are 3d options, and then a “Calibration” section that has nothing in it.

Settings - > Player - > Videos - > Adjust display refresh rate

Ah - it’s in player settings/video

Sorry, found the Adjust display refresh rate" setting in Settings:Player and turned it off, rebooted and now HD videos play normally! WOOT!

Thank you so much for your help.

8 posts were split to a new topic: Can’t Play 4k 60p h.264