Green line in GUI

I just received my new Vero V. Installed the latest update, then restored a backup from my 4k+. Everything is working well but with one problem: in the GUI there is a flickering line of green “noise” near the bottom of the screen. This is present whatever refresh rates/ resolution I try to set. The settings are identical to my 4k+ which did not have this issue. I’m also using the same HDMI cable as before (an 8K compatible Ultra high speed).

The weird thing is, the green line goes away when a video is playing, but once I bring up the OSD it is there again. Attaching some example images to show where it is and isn’t present. Since the line is not there when playing video, I guess it is not a hardware fault…

Are you playing a video with a resolution that is not divisible by 8?

Can you post the MediaInfo output of the affected file


Hi Sam, the issue is not present when videos are playing; in the above screen of Gemini Man you can see the picture is perfect.

The issue occurs just sitting in the menu GUI or when bringing up the GUI/OSD over a video.

Do you have another display you can test on?

On a fresh boot, does the issue appear before playing anything?


The issue appears as soon as OSMC/Kodi starts. It’s not present on the splash screen for the chipset at boot. I can try it on another display tomorrow.

That would be great. Some logs via My OSMC will also be useful


Hi Sam,

I tried 2 more things this morning:
Plugged the Vero directly into the TV without going through the AVR; green line still appears as soon as OSMC starts.
Plugged the Vero into a different screen (1440p PC monitor); green line still appears.
The issue seems to be independent of screen/resolution.
As I mentioned though, it’s NOT present when a video is playing. So I’m not sure which logs you would need? Just a log from when the Vero boots?

Below pic is the same effect showing on the PC monitor:

Have you tried to change GUI resolution/framerate to see if it goes away?

Yes, tried various combinations with no difference.


This is an odd one.

Can you take a screenshot and see if the line is present there?
It looks like a potential issue with the HDMI PHY.

If you know how to use SSH, we can do a couple of test patterns and see if it displays there.

I assume when you did this you also tried another HDMI cable.

I noted in your logs you have the UI at 1080p25. Keeping it at 1080p50/1080p60 will give you a more responsive UI.


Yes, for that I used the cable that came with the Vero.

Also took a couple of screenshots. Interestingly, the line is also visible here. That suggests it’s a software issues, doesn’t it?

Yes, if we see it in Kodi, then it’s not a damaged HDMI connector. If it was a damaged connector then we would probably see odd patterns in multiple places rather than a single line.

If you stop Kodi with systemctl stop mediacenter you should see the OSMC splash screen. Is the green line present there?


I SSH’d in and did systemctl stop mediacenter, but there was no splash screen. The screen is just black, still with the green line:

I followed that up with ‘reboot’ on the command line, and get the OSMC splash screen when Kodi comes back up. It’s hard to see because of the colour, but you can just about tell that the line is also there.

It is not there on the AMLogic splash screen or the brief flash of kernel messages as the system starts up.

Try reinstalling OSMC and see if it comes up in the installer.

Otherwise we might need to get it back and replace it


One other last thing, we have some framebuffer changes in our staging repository.

Can you try and update and see if anything changes for better or worse?

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have received the update.

Hi Sam,

Thanks for all your suggestions.
Unfortunately, the issue still persists. I reinstalled OSMC with the latest image via USB Stick, and I also did the staging update as per your last post, but still have a green line. I guess this is an RMA?

Yep. Contact and we will support it. Please include your order number.

I’ll get back to you tomorrow evening