Green screen after update on Vero4k


I am having a lot of green-screen issues after the last two updates. I’ve never had this problem before the September update. It happened few times with September update, I found this post:

And I was expecting to be solved in the next update. I didn’t installed the staging version because it was happening from time to time and I decided to wait the actual update. But now, with November update it is worse, it is happening a lot.

Here’s the log:

It’s weird, because the two releases notes claims to fix the green screen problem, but in my case was the opposite, no green screen until it was mention in the fixes :smiley: . Not complaining, just making fun of the irony…

FYI I did an apt update / dist-upgrade just in case. This is the output:

osmc@vero4k:~$ sudo apt-get update
Get:1 bullseye-security InRelease [48.4 kB]
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libapt-inst2.0 libbind9-161 libcdio18 libdns1104 libdns1110 libevent-2.1-6 libfdk-aac1 libffi6 libgeoip1 libhogweed4
  libicu63 libidn11 libip4tc0 libip6tc0 libiptc0 libisc1100 libisc1105 libisccc161 libisccfg163 libjson-c3 liblwres161
  libmpdec2 libnettle6 libnfs12 libprocps7 libpython2-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib
  libpython3.7 libpython3.7-minimal libpython3.7-stdlib libreadline7 python2 python2-minimal python2.7
  python2.7-minimal python3.7 python3.7-minimal
Use 'sudo apt autoremove' to remove them.
The following packages will be upgraded:
  libntfs-3g883 ntfs-3g
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 562 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 bullseye-security/main armhf ntfs-3g armhf 1:2017.3.23AR.3-4+deb11u3 [401 kB]
Get:2 bullseye-security/main armhf libntfs-3g883 armhf 1:2017.3.23AR.3-4+deb11u3 [161 kB]
Fetched 562 kB in 0s (1509 kB/s)
(Reading database ... 41652 files and directories currently installed.)
Preparing to unpack .../ntfs-3g_1%3a2017.3.23AR.3-4+deb11u3_armhf.deb ...
Unpacking ntfs-3g (1:2017.3.23AR.3-4+deb11u3) over (1:2017.3.23AR.3-4+deb11u2) ...
Preparing to unpack .../libntfs-3g883_1%3a2017.3.23AR.3-4+deb11u3_armhf.deb ...
Unpacking libntfs-3g883 (1:2017.3.23AR.3-4+deb11u3) over (1:2017.3.23AR.3-4+deb11u2) ...
Setting up libntfs-3g883 (1:2017.3.23AR.3-4+deb11u3) ...
Setting up ntfs-3g (1:2017.3.23AR.3-4+deb11u3) ...
Processing triggers for libc-bin (2.31-113) ...

I have the feeling that it happens more with MKV files, but I am not sure if the container can affect to this issue. Anyway, the last video giving me a green screen was H.264 encoded. Also, it looks quite random, the same video triggers the problem on different moments.

The Vero4k is connected to a Samsung soundbar, which is connected with eARC to a SamsungTV.

Please, tell me if you need more information for this.

Thank you!


Do you have a specific file that you can reproduce this problem with?

The problem has been reported as resolved, so it would be good to test with a specific problematic file


Hi Sam,

Thank you for your prompt response. I know the problem was reported solved, I was expecting to have it solved with this update, but not for me. Let’s see if I can help you to find the reason.

Yes, I still have the last “problematic” file. It is 6.1 Gb. What do you want to do with it? I will try to reproduce again the issue, maybe I’ll try to cut it to have a minimum file size throwing the green screen. I’ll do some more tests as soon as I get access to my Vero. For now I am pasting here the mediainfo for the file, in case it helps.

Format                                   : Matroska
Format version                           : Version 4
File size                                : 6.16 GiB
Duration                                 : 1 h 24 min
Overall bit rate                         : 10.4 Mb/s
Writing application                      : mkvmerge v69.0.0 ('Day And Age') 64-bit
Writing library                          : libebml v1.4.2 + libmatroska v1.6.4

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4
Format settings                          : CABAC / 4 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 4 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 1 h 24 min
Bit rate mode                            : Constant
Bit rate                                 : 10 000 kb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 30.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.161
Stream size                              : 5.78 GiB (94%)
Default                                  : Yes
Forced                                   : No
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

ID                                       : 2
Format                                   : E-AC-3
Format/Info                              : Enhanced AC-3
Commercial name                          : Dolby Digital Plus
Codec ID                                 : A_EAC3
Duration                                 : 1 h 24 min
Bit rate mode                            : Constant
Bit rate                                 : 640 kb/s
Channel(s)                               : 6 channels
Channel layout                           : L R C LFE Ls Rs
Sampling rate                            : 48.0 kHz
Frame rate                               : 31.250 FPS (1536 SPF)
Compression mode                         : Lossy
Stream size                              : 388 MiB (6%)
Language                                 : English
Service kind                             : Complete Main
Default                                  : Yes
Forced                                   : No

Text #1
ID                                       : 3
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Duration                                 : 1 h 23 min
Bit rate                                 : 70 b/s
Frame rate                               : 0.297 FPS
Count of elements                        : 1484
Stream size                              : 43.3 KiB (0%)
Language                                 : English
Default                                  : No
Forced                                   : No

Text #2
ID                                       : 4
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Duration                                 : 1 h 23 min
Bit rate                                 : 75 b/s
Frame rate                               : 0.323 FPS
Count of elements                        : 1625
Stream size                              : 46.0 KiB (0%)
Title                                    : SDH
Language                                 : English
Default                                  : No
Forced                                   : No

Thanks again

If you can produce a small sample of the file which still reproduces the problem this would be useful.

Notably: the green screen issue affected HEVC material and that’s what we issued a fix for. Your content appears to be H264.


Sorry for the late response, I’ve been doing some tests and waiting for the issue to happen again.

I couldn’t reproduce the problem with the media I’ve posted above (the H264 video) I checked which the videos where I remember it happened (that ones were HEVC) and I couldn’t reproduce the issue. Even going forward and backward around the timestamp when the green screen happened.

Let’s put this in hold, I know that it happened twice after the update and the second time was after a “hard” reboot (I mean, cutting the power supply).

I know the update was done and running. Also I am sure the media was H264. But anyway, I am the user, don’t trust me too much :wink: It seems it’s gone for now and I can’t do many tests these days.

So I will back to you if it appears again, thank you for the support.

PS: I don’t know if this can be related or no, but it is also giving me a hard time with CEC. When vero4K comes back from sleep, sometimes I need to go to the TV settings and select Kodi in the CEC list in order to have the TV remote working with Kodi. That was automatic before.


The seeking issue with video playback that resulted in a green screen was only occurring with HEVC content, to my knowledge. It could have well been the case that H264 content was also affected but most Vero users are playing modern titles that are HEVC encoded and that could have been missed in reports (although I would be surprised).

Let us know how it goes, and come back to us regarding that if it does occur.

The September update resulted in some users reporting quite serious regressions with CEC. Unfortunately while we got a lot of reports, logging was somewhat limited. As a result, I’ve simply reinstated CEC to its pre-update state from September. So if it worked fine on previous updates it should be OK now.

However – I’d recommend powering off everything at the mains for a few minutes to ensure that the CEC peripheral bus fully resets itself.

If you then continue to have issues, let’s follow it up in a new thread with some fresh logs.




I just wanted to add here that I experience the same green screen issues with multiple mkv files on Raspberry 3 B+.

So it does not seem to be individual problem.


This thread is regarding playback on Vero 4K/4K+



I’ve just wanted to say that after a rainy weekend watching movies without any green screen, it is safe to say that the problem is gone. I have no explanation for what happened just after the update, but if it occurs again I will open a new thread.

Also, the CEC issues are gone following your advice.

Thank you for the support.

I’m glad to hear this.