Green Screen when Playing UDP Stream


I’ve been trying to play a FFmpeg UDP stream, and if either MMAL or OMX acceleration is enabled I only get a green screen displayed. The audio comes through fine.

With MMAL and OMX acceleration disabled, the video displays but it can’t seem to keep up and displays as if in slow motion while the audio plays normally. I tried increasing GPU memory allocation to 512 which helped speed a little bit, but still no good.

I don’t think this is particularly a OSMC problem, as I tried OpenElec as well and same thing happens. Playing the video stream through VLC or Kodi on a Windows PC has no problems.

Does anyone know any way to get around this problem with OSMC and the RPi2 hardware acceleration?

I’ve got these debug logs:
MMAL Enabled:
MMAL Disabled:

One thing I noted in the logs is around line 341 in the MMAL Enabled log and line 289 in the MMAL Disabled log is some discrepancies with CMMALRenderer and CXBMCRenderManager info. I have no idea what the numbers mean and whether they’re relevant to anything.
eg. CMMALRenderer::init_vout configured:0 format:18->18 vs. CMMALRenderer::init_vout configured:0 format:18->1

Thanks in advance for any help anyone can offer.

I changed the ffmpeg source stream video codec to libxvid instead of libx264 and now it plays the stream in OSMC with MMAL on with no issues. I’m happy with this solution.

This green screen phenomenum is also sometimes seen with some TVR boxes.
It seems particularly likely with monitor types (unpredictable), and there is suggestion that it is associated with timing of signals.
You might look to see if a monitor or cabling change changes it.