Gui resolution drops to 480p

Sometimes my Vero4K+ lowers it’s GUI resolution from 1080p to 480p.

I was able to create a debug log and I noticed this line where it’s happening:

2020-05-06 22:27:50.774 T:4068605952 DEBUG: AMLUtils::aml_set_display_resolution new video mode is 480p60hz

and it only seems to happen directly after I stop playing a video.
And if I enter the settings menu the GUI resolution is still displayed as 1080p…

I hope that the debug log can explain why this is happening. I’ve already looked into whitelisting but that doesn’t make any difference.

I’m using the latest Amber Skin beta but I’m not sure if a skin can cause this behavior.

And, making things a bit more difficult, the problem seems to happen at random and isn’t easy to reproduce.


Can you post all debug logs please, not just the Kodi.log.

Could you try living with the OSMC skin for a bit to see if that makes a difference.

@darwindesign here’s a link to logs which were made using the grab-logs -A

@grahamh I can certainly try this but it will probably take some time. However, I’m sure that this didn’t happen when I was running a different skin. So is it possible for a skin to cause this? Then I’ll move over to the Amber support thread.


I don’t know, really, but when you stop a video, the skin is doing all sorts of things. It would be good just to eliminate one variable as I can’t recall anyone else having this issue.

Thanks for the quick reply. I’ll post in the Amber support thread and update the topic if I find out anything new.

The developer of the skins wrote that he doesn’t have any idea how the skin could do this and that he has never encountered this problem.

I’ll switch to another skin for a week to see if the problem goes away (or not).

I was able to reproduce the problem with the Estuary skin so it must be something else. Until now I’ve only been able to reproduce it on the first try without debug logs enabled. I’ve tried to reproduce with debug logs but for now I’ve given up after 30 or more tries.

So the logs which I previously posted are probably the best for now.

You might try changing your adjust display refresh rate to on start/stop and see if that makes any difference.

1 Like

Enabling HDMI HPD Lock might help, maybe…?

In his case I would suggest hardcoding some resolutions in a disp_cap file but he should try HPD Lock first.

If I remember correctly, I already tried the HPD lock option so now I’ve changed the adjust display refresh option from always to start/stop. I’ll update the thread as soon as I have any new info.

Thanks for all the suggestions!

I reported this issue back in July 2019 but it stopped happening and I couldn’t reproduce it. We never got to the bottom of it back then, it just started working again!

Thanks for letting me know, so the issue didn’t come with a recent update but I can’t think of any recent change in my configuration. I re-installed my Vero4K+ in February so the configuration is “clean”/

Until now, changing the adjust display rate from always to start stop (as darwindesign suggested) has resolved the problem but let’s see if that continues.

I suspect that the problem starts when switching to the GUI during playback. The amber skin allows for continued playing in the background and the autosubs plugin always pops up it’s gui at the beginning of the playback (it stops the video).

EDIT: I haven’t had the problem since switching to start stop so the workaround seems to be working :slightly_smiling_face: