H264 content causes temps to exceed 80 deg - pi3

Hi there,

I’ve been an avid user of OSMC since the early days across numerous Pis, and I’m a massive fan - thank you for the support through the years!

I was wondering if you might be able to give a few pointers based on my logs, since out of seemingly nowhere I’m getting consistently high temps playing back H264 content (between 80-85 deg throughout playback).

The only variable that aligns with the temp increase is getting a new 4k tv - my old 1080p tv needed some playing around with the config.txt file to get it to consistently output, and I haven’t changed the file since upgrading the tv. The GUI is set to 1080p res.

I’m using the official OSMC power supply, I have had a heatsink on the CPU for years and it’s been in a transparent case since day one, running with the top off for a few weeks due to the temps.

Looking through the forums this morning I’ve tried removing unnecessary add-ons but this hasn’t had any effect.

  • The issue you are currently experiencing with OSMC - temps above 80 deg when playing H264 content
  • What you were doing when this issue occurred - play back any H264 content (720p or 1080p)
  • Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue. - select any H264 content, play back. Within 10-15 secs, temp is >80 degrees.

I wrote a basic script upon noticing the temperature alerts to log temperatures each second, viewing via SSH shows very quick increase to >80 degrees. It idles at around 72 degrees when not viewing content.

  • The device you are currently running OSMC on - pi3b
  • What peripherals are attached to the device? - official OSMC remote, 1TB HDD, 4k tv @ 1080p, USB wifi dongle replaced recently due to an older dongle falling out of support.
  • Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present? - not knowingly, maybe a few weeks.

This occurs with ambient temp anywhere between 18 and 27 degrees (it’s hot today!)

Any guidance appreciated, logs are below:


Try removing the force_turbo line.

Thanks for getting back to me so quickly Sam, still hovering at 81-82 playing back the same file after reboot(s) sadly.

Happy to try a fresh install in case that might help things, or buy a 5v fan - just curious as it’s seemingly out of nowhere.

Uploaded a fresh logfile just in case anything can be gleamed from it: https://paste.osmc.tv/sohigalaxu

Perhaps the heat is caused by the library re-scan which is running on your system

I think that might just be a quirk of me following the log uploader guidelines to a t (i.e. enable debugging, reboot, recreate the issue by playing content, upload log), with library rescan occurring on reboot.

With the Pi on 24/7, the temp warning will display regardless of proximity to reboot (and therefore library rescan) - for example the pi has been up for 2 hrs since my last logfile dump, I played the same video and I’m back at a consistent 81-82 degrees from idling around 50/60 degrees.

The thing is going to run hot when you disable hardware offloading…

<setting id="videoplayer.usemmal">false</setting>
<setting id="videoplayer.useomxplayer" default="true">false</setting>

The stock setting is just MMAL enabled but with either or both turned back on you should find minimal temps during playback.

On a side note if you wanted better cooling IMO you would be much better off going with a FLIRC case or similar with a large passive heatsink rather than a noisy fan that wears out.

1 Like

btw. besides the heat issue

====================== Pi Audio Cap =================== szl3J3wq
     PCM supported: Max channels: 2, Max samplerate: 192kHz, Max samplesize 24 bits.
     AC3 supported: Max channels: 6, Max samplerate:  48kHz, Max rate  640 kb/s.
     DTS supported: Max channels: 6, Max samplerate:  96kHz, Max rate 1536 kb/s.
  DTS_HD supported: Max channels: 8, Max samplerate: 192kHz, Max rate    8 kb/s.

Your settings at settings->system->audio should be

  • channels: 2.0
  • output config: best match
  • allow passthrough: enabled
  • ac3: enabled
  • ac3 transcoding: enabled
  • E-ac3 disabled
  • DTS: enabled
1 Like

How on earth I had both disabled I’ll never know. That fixed it! Now playing at 60 degrees.

Thank you!!!

1 Like

Thanks much appreciated! I must admit I’m a bit of a philistine when it comes to audio settings…

Also good point on the case. I have the same problem with a pi4 I got a few weeks ago. So hot in the official case! Likely to just replace the case on that basis.

I have a RPi 3, 3 B+, and a RPi 4 all in FLIRC cases and where it is not uncommon for them to be in ambient temperatures in excess of 38 °C. I’ve never had a temperature issue so i’m fairly happy with their performance. I also rather like the way they look.

I’ll take a look for sure! I was tempted by the Argon One but again overkill…