Handling of 3D Subtitles on Raspberry Pi2

Hi Folks, i have a problem with 3D Playback on my Raspberry Pi. I am using the Program 3DBD2MK3D for storing my 3D BD on my File-Server. This Program creates a subtitle File which preserves the 3D depth information from the source so when a TV plays a file the subtitles will be like you are using a 3D player. Depending on the format you chose (Side by Side or Top/Bottom) a sup or idx will be created with a subtitle for each side of the Picture (left and right side for SBS and top and bottom for TAB). When using the Raspberry Pi to playback such a file the TV is turned into 3D mode, the Picture is displayed correctly but the subtitles are still displayed twice, left and right or top and buttom of the picture. Fun Fact, this Problem is only present on my Raspberry Pi. The Vero 4k and 4k+ do not have this Problem, they show the subtitles correct. Befor using a Vero i used the Raspberry with Libreelec to manage my Media Library. With the update to Krypton it started with these problems. If i am going back to Jarvis the playback is fine. I asked at the Kodi Forum if they changed something or have an idea why this is happening, but no one helped me out. All they said is, that they did not change anything and that was all help i got. Like i said, with the Vero Device these problem were gone, but now i wanted to use my Raspberry again on a 3rd TV, i saw it is happening again. I installed the lastest OSMC Release btw, no more Libreelec for me. Fun Fact: Libreelec with Krypton was unable to set my TV in 3D Mode, Libreelec with Jarvis did. Is there a difference how 3D Files, especially the Subtitles, are handled on the Raspberry and the Vero? Maybe someone has an idea what i can do to fix this without buying a third Vero :slightly_smiling_face:
Cheers Sebastian


How are the files named?


The files are named with the movie title and file extension .mk3D, also the 3D MKV Flag with the 3D format is used. Kodi recognize the files as 3D movies. If you mean the subtitle files, they are muxed into the mkv file.

Usually they need a name like Some.Movie.3DSBS.mkv. Pi and Vero have different hardware acceleration pipelines, so there may be some platform differences in terms of capability


According to the Kodi Wiki it doesn’t matter if the file is named with a 3D Tag or if the 3D flag into the mkv is used. Like i said, with Jarvis everything is fine, but with Krypton i have this problem. DoesnÄt that point to a software problem?

is there a jarvis osmc build still available for testing?

There’d be old images at http://download.osmc.tv.


Hey Sam, consider the problem as solved. I just tested the last Jarvis Build and like i expected, it worked. With the actual Krypton Build i got it only working if i disable the whole 3D functionality and set my TV manually in 3D Mode. That breaks the Kodi GUI during playback, but it works. I also tested the latest Leia Build and it works with that, also with 3D functionality. So it seems to be a Kodi based Problem which is solved with the next Kodi Release. I am only glad that it works on the Vero with Krypton. With the Raspberry i can wait until a stable Leia release is available.