Hard Drive installer and the ? hard drive icon after rebooting

I’ve tried to use the new hard drive installer with both the original 40GB hard drive and a 1TB hard drive (w/SATA adapter) that I had been using Crystalbuntu and Openelec. Both times I ended up with the flashing Question Mark and hard drive icon after unplugging and rebooting. I have tried and semi-successfully installed the previous HD install (11-23-2015) by removing the 1TB drive and using USBIT to put the image onto the HD. It completed the install but then froze during the inital setup questioning.

Also, tried SSHing the image onto the ATV1 after running a USB install method but ended up with the same results.

Any Suggestions? Thinks in advance.

P.S. I tried using USBIT to put the image of the new HD installer onto the 1TB hard drive and it went through the process of formatting and copying the files. It went to reboot and got the Question Mark hard drive icon. I remember someone mentioning that it may need a hard reboot after that, I pulled the plug and started it up after a minute or so. After waiting around 10-15 minutes of black screen I got the Question Mark hard drive icon again. The USB install is fine but I’d like to free up the USB port for a DVD drive that I use for DVD movies or music CDs.

P.P.S. I guess being stubborn has its benefits. I tried placing the older HD installer onto the hard drive with USBIT again (same file, same hard drive.) I was using diskpart in Windows each time to clean the drive and initialize it. One time I left the drive blank but the rest of the time, like this time, I partitioned it and formatted to NTFS. This time it got through the formatting and installation a little quicker than normal. Rebooted itself and I got the black screen. I unplugged it waited about 10 minutes (time for a coffee) and plug it back in. It’s running now but, I had noticed that while playing back some music I was streaming from my NAS, it was stuttering really bad, never a problem before (wired connection, BTW.) I thought I had seen it trying to update addons or something and I’m attributing the slowdown to that for now. I scanned for updates and it’s applying updates as I type this. I’ll let it settle in for a while to give it a test later.

Well, kind of got it sorted out. Still having some problems which may have to be addresses at another time or in another thread.

Anyway, after the reboot from updating, it rebooted to another Question Mark hard drive icon. Just had to do another hard reset. Don’t know if you need to wait the 10 minutes coffee break time to plug it back in but it seemed to work for me. Took a little while longer to load up to my home screen but it finally did.

Guess it was just my own impatience of having to hard reset after every reboot. Maybe the mods can close the thread if deemed necessary.

There are a couple of possibilities. One is that your hard disk is on the blink. The other, more likely one is that this issue is introduced by manually partitioning the HDD. None of this is necessary anymore, as the HDD installers are working correctly now. You can grab the latest one from the website.


Thanks Sam for the insight. As you may have read my opening, I did use the new installer but it ended up with the question mark hard drive, twice. I may try it again as I have found that hard resetting it after a more than a couple minutes unplugged, instead of the 10 seconds, seemed to work for me. In addition, I might try the new installer because I have been encountering problems with very bad stuttering and freezing of video and streaming audio from a NAS (that was one of the other issues I was going to address in another thread later.) My ATV1 is hardwired to my router.

My other question was regarding the CrystalHD card and video acceleration, as I had read in the FAQ, it is automatically selected if available. Just wondering if it was selected if it not only was supposed to appear in the menu but looked grayed out as well (not selectable and shown as not selected - an x instead of a filled in dot?)

Should I reformat my hard drive before trying the new installer again? Or should I just leave it alone and let the installer format the drive itself?

Thanks for all your hard work in this project.

It’s greyed out because it cannot be disabled. If your card was not detected it wouldn’t be showing up at all. If you have a keyboard attached, press ‘o’ (can also do this with Yatse) and you should see ‘chd-h264-osmc’ as the decoder.

Sounds like your hard disk may be on its way out, particularly if it’s one of the old ones


I will try to check out the on-screen decoder once I get it up and running again. It locked up when I was trying out the Apple Movie Trailer addon. So I’m in the process of re-installing now.

Did the HD installer just change? The file had 2016 in it now, its 2015 1204.

2015.12-4 is the version.

20160118 is the date of image creation.

Thanks. just noticed it after it was downloaded.


I tried installing the new HD installer to the ATV1’s original 40GB drive and it installed fine. Still had to do a hard reset after it completed installing and rebooted by itself (still got the question mark hard drive.) Talk about maybe having a drive on the blink… that original drive is sure loud compared to newer technology but still working. LOL!

Anyway, it’s running except for one hiccup. I get a 1-2 sec stutter when playing back music or video about every 20 seconds. I was going to try to upload those files to the ATV’s hard drive and see if it plays any better. With the USB install, I didn’t have this problem. I’m going to check that again but I’m pretty sure it doesn’t happen.

As for the 1TB drive maybe on the fritz, it’s on a diagnostics test now (10.5 hours left to go) and I will find out if it may have been the cause of its very slow performance. The reason I use the 1TB drive in the ATV is to put some media on it and make it portable. I like keeping the USB port free in case we rent a movie or someone has a music cd when we’re away. I can then just plug in the external dvd player and play on.

If you’re experiencing a performance degradation on your HDD install compared to your USB drive, it certainly sounds like the HDD may be the issue



Thanks Sam. I just tried a new USB install and it had slight hiccup too but, not as frequent as the hard drive install. I was streaming a FLAC file to the ATV. When I streamed an MP4 video to it, the playback started much faster than with the hard drive and the only hiccup I remember was at the beginning of the video. I still don’t have a keyboard hooked up to it and the virtual keyboard of the Kodi Remtoe App wouldn’t send the “o” keystroke so I couldn’t view the on-screen statistics but I can say if played as it did with Crystalbuntu and that was fine, as it should be.

I was watching the CPU and memory usage of both USB and hard drive installs and the CPU seemed to be jumping more with the HD install (frequency and amount) and the memory usage was slightly higher. Would that be normal?

Has anyone seen memory in an ATV1 go bad?

Definitely need to see some debug logs here



I’ll definitely try but, this week will be hectic.

Oh, also tried something unorthodox last night… I was using a USB hub and fired it up with the USB stick install and an external DVD drive. I started just fine. But I played a dvd and it started to play then once froze and another time stopped playing and went to the home screen. I was going to see if that corresponded to trying to link up via network with the Kodi Remtoe App. Off the top of my head, I recall the lock up was about the same time; not sure about the stopping and returning to the home screen though. I’ll try to see if I can replicate that.


Finally getting back to this. As I came back to check replies, I noticed a new installer for the HDD. I wanted to try it out before to see if it may correctly install to my hard drive. I removed my original 40GB, which had been working with the stuttering, and accessed it through my PC via external HDD usb adapter. I used USBIT to place the image on it and fired it up. Ran perfectly through the setup and was working without the stuttering. Even streaming audio and video through the network was working like in CB2. But, after 5 or 6 minutes (still setup it up) it froze and that happened a few times. Thought it may be the stuttering, so the last time, I let it sit for a while (30 mins.) Still was frozen after that time.

I put the HDD installer onto a USB stick (the same one that was running OSMC without a problem) and proceeded to install. Went without a hitch except it’s been around 20 mins after re-plugging the ATV when prompted to do so and it’s still on a black screen. Will try the other hard drive (SATA): the original and the SATA that I used before both tested ok in diagnostics tests.

still with the same hard drive as I wanted to see if rebooting a second time would allow me to get in as it has in the past. It did but, I still have the problem of it freezing. It happens about 5 or 6 minutes after restarting, sometimes less. For instance, I could be streaming music from my NAS, then all of a sudden, it’ll sound like a record skipping in one spot over and over. Thought it may just be partially frozen and left it for a few minutes. Nope, still stuck. Had to do the reboot thing a few times so I could get the debugging selected on and grab some log files. Not sure if I did it correctly but, here is what I have.


p.s. does the option of (can’t remember exact title) uploading log files to sd card work? Tried that a couple times and there was nothing on my flash drive. Or was it meant for something else?