Hard Freeze


I purchased a Vero 2 in June 2016. A few months ago, my Vero began to hang after several days of use. The hang manifested itself as follows: if audio was playing, then whatever data happened to be in the audio card’s buffer (I guess about 300 ms worth of audio) would play in a loop, and the picture on the screen would freeze (I did not get a kobi sad face). And, the device would no longer respond to the remote control or to a ping. Pulling the plug and restarting caused the system to start without complaint and everything worked again for a while. Unfortunately, the problem has gotten worse so that the hang typically occurs after about 15 minutes to an hour of use (whether I’m doing something or not). This makes the system effectively unusable for me :/.

To be sure that the problem was not related to an add-on (I only installed a few official add-ons related to playing web radio) or some file system corruption, I reflashed osmc with the latest firmware. Unfortunately, that did not help.


  • I don’t have anything connected to the device other than the remote.
  • I’ve never overclocked the device or modded it in anyway.

The logs are available here:


Thanks for your help!

:slight_smile: Neal

If you have a rfeplacement power supply, try it out.
Usually when that kind of things happen, it is power related.

Does it also crash when you start/playback a movie?

Hi Neal

I’d recommend taking a backup in My OSMC on to an external drive and reinstalling OSMC. Before restoring that backup, I’d try running OSMC with just one addon for 24 hours. If that’s OK, I’d add one more add-on a day until you find the problem. I know it’s a lot of hassle but it’s usually the best way to determine what the culprit is.

Has the environment changed in any way (new TV etc) since you started experiencing the problem?



Hi Sam,

Thanks for the feedback.

I’m sorry that my original post wasn’t clearer: I’ve already more or less done what you suggested. Last week, I reflashed the Vero 2 and without installing any plug-ins, i.e., using just the vanilla osmc distro, I experienced the exact same problems. (The only configuration that I did was setting up an NFS mount.)

I haven’t changed anything in my setup. In particular, I’m using the exact same screen.



HI Smurphy,

Unfortunately, I don’t have another power supply.

I’m sorry my original post wasn’t clearer: it doesn’t matter what I do (or not do): the Vero 2 hard freezes after a while (current after about 15 - 60 minutes after starting the Vero 2). That is, I can either leave the Vero 2 at the Kodi menu or I can start playing a movie. In both cases, the Vero 2 freezes. If a movie is playing then the buffered audio repeats until I turn the Vero 2 off. If I’m only at the Kodi screen, then there is no audio (which I assume is because no audio is being played back).

Thanks for your suggestions,


Hmm. Then I would take a backup as @sam_nazarko suggested before, and re-install the device from scratch and test it without the plugins to see if there is not some old code that is causing the crashes.

Hi Smurphy,

I’m sorry that I’m failing to communicate what I did. But as I tried to explain, I have already reinstalled the device from scratch and tested it without any plugins. The behavior has not changed: it still freezes.



In that case, we need to test the power supply. If it is not the power-supply, I think You’ll have to check with @sam_nazarko for a replacement unit (If it is still under warranty).
The question will be where to get a power-supply.