Harmony One and PInnacle Media Player remote repeats

I’ve been using Kodi and OSMC on a Raspberry Pi for a year and I’ve had no problem with it until this past week after the latest update. Now when I use either the Pinnacle remote with the it’s receiver or the Harmony One remote with Hub using the Pinnacle receiver It send two the command twice to my Raspberry Pi.

How can this be fix and working how it was working before te update?

Silly question, but did you reboot after the update ?

And what version of OSMC were you running before the update ?

Please provide full debug logs so we can get more information about the problem.

Yes…I actually decided to reinstall OSMC because it was being annoying and it still doesn’t work. I will post the debug file when this afternoon

I’ve discovered and fixed a bug that can cause issues with unwanted remote repeats.

The issue was that we were not guaranteeing that eventlircd was always started before Kodi, so depending on what else was going on during bootup, Kodi would sometimes start first. When this happens Kodi directly grabs the input devices, so they no longer pass through eventlircd’s repeat filter, thus unwanted repeats occur.

This has been fixed in the following commit and will be released in a future update:

For anyone that wants to test this fix early it is a very easy change to make. Simply edit the statup service for eventlircd:

sudo nano /lib/systemd/system/eventlircd.service

You will see a file that starts with the following lines:

Description = eventlircd remote support
After = remote-fs.target

Immediately after the After line add the following line:

Before = mediacenter.service

Then save the file and reboot. If this fixes your remote repeat problems please let us know. :smile:

After an update and reboot yesterday, my OSMC started seeing repeats, making it useless. If I hadn’t got my TV remote on standby (the CEC remote protocol was still working fine) I’d have been stuck.

This is why I don’t generally update systems that are working. Something almost always goes wrong.

Anyway, after applying your config file edits, my OSMC started behaving again with my harmony remote.

Now I just need to disable update checking so I don’t get bugged with “There is an update available” dialog boxes every time I turn on my TV.

Hi there

I have the same issue. I have changed the eventlircd.service file as per above, but I am still getting double key presses, mainly on the left, right and ok keys

I am running a Raspberry Pi 1, on USB, with an MCE remote using the RC-6 receiver. I tried implementing the RC-6 file in the Remotes part of the OSMC utility, but that didnt seem to fix it

I have pasted a debug log below


Would appreciate any help

Can you upload all logs using the MyOSMC log uploader please, as there is not enough information in just the Kodi.log.


sorry for the delay in getting back to you. Below are the osmc logs

I also just updated to the new release that came out yesterday, however that doesnt appear to have fixed the problem.

in the logs you may note that their are two remotes, the RC-6 mce, and I also had to use the Kore app, just so i could navigate around the screens to upload the logs

Let me know if you need any further information, and thank you again


Your lircd.conf profile still has 4 different MCE remote definitions in it - there is a known issue with some RC6 remotes where you will get duplicate button presses if you have multiple remote definitions in the same file. You need to copy then edit the file to include only one remote definition.

BTW I just realised I replied to you about the same issue in another thread, where you did not provide your debug logs - spreading the discussion of the same problem across two different threads only serves to confuse the situation - please try to keep to one thread for one issue.

Hi DBMandrake.

I removed three of the remote definitions from lircd.conf (I just left the first one), and re-booted it, and it works perfectly!

Thank you

Did the latest update fix this problem? seems to be still happening so I changed my remote to the Samsung remote and it seems to be working fine, but sometimes the remote feature stops working and I then I have to use my mobile phone

I did a reboot because the media centre hung at the end of a show when I tried to skip forward 10 seconds. And guess what… now I’m getting multiple remote commands again :confounded:
I’d turned off automatic updates, cos everything was working as it should be, finally. Now I guess I’m forced to update, and see what else is broken :sob: