Harmony remote issue since upgrade - multiple keypresses registered

Yes, I’m aware of a few similar threads on harmony remotes.
See here…

and here…

But my problem is a little different. I am using a harmony 650 universal remote ie an IR remote. Have been having issues since the August update. It was working fine prior to the upgrade.
A single keypress on the remote will cause multiple keypresses to be registered on the vero. eg if I skip 10s with a single press, it may register as 4 or 5 or 6 presses and skip forward 20 minutes of what I’m watching.
It’s definitely worse while under load, but can happen when just browsing menus too.

Any ideas? Would a log help? I’d upload one, but the problem is intermittent and I can’t be sure how/when to replicate it. (Also I’d assume the log would possibly just register that the harmony buttons were just pressed multiple time) .


IIRC there are delay settings in the MyHarmony app for the Vero device.
There are also delay settings accessible by holding down the Help button for 5 seconds…but I believe the one required (key_delay?) is only available in the app. Don’t think it had much affect last time I tried it…but it is worth a try.

I have the same problem with a Harmony 665, but I do not really use that remote anymore.

Yeah, I’ve just mucked around with the delay settings, and the device command repeats in the harmony app, but still having the same issues. DIdn’t have a problem until the August upgrade, so I suspect something in kodi has busted.

I think it might be time to retire the 650 anyway, considering it’s no longer being made.

For anyone playng along at home, I think I need to chalk this one up to user error. After going through a bunch of threads, the user in this thread from a few years ago had a similar issue, but it was the wifi network causing them grief.

I checked my wifi, and definitely nothing new around where the vero is located.
But I realised that during the August update, I was having some issues that meant I needed to pull the power plug to reboot my vero. I left the vero itself sitting directly on top of a powerboard/electrical board. I suspect the electromagnetic interference from it was causing havoc wtih the IR signal.

I’ve since moved it back to it’s original position (and also removed and reseated the IR extender). Since then then Harmony remote is working flawlessly as it was prior to the update, no further issues with multple keypresses registered. Unsure if it was moving it or the IR extender plug, but I’m gonna mark this as solved.

Thanks for listening :slight_smile: